Loading ...
Sorry, an error occurred while loading the content.

mouse cursor and copy/paste

Expand Messages
  • SanDiegoGary
    Hi, I m using VIM 7.3 on Windows 7 (32-bit). I want two things: 1) Prevent active window selection to change VIM cursor location (don t want the left mouse
    Message 1 of 2 , Mar 26, 2013
    • 0 Attachment
      Hi,

      I'm using VIM 7.3 on Windows 7 (32-bit). I want two things:
      1) Prevent active window selection to change VIM cursor location (don't want the left mouse click to select the VIM window to affect the existing VIM cursor)
      2) Ability to copy/paste to/from windows keyboard (preferrable with edit>copy and edit>paste).

      To get (1), I've tried "set mouse=v" (or =c or =i). Visual, Insert and Command each give me (1). Default of =a, or Normal does not.

      When I have Visual, Insert or Command mouse modes, the edit> copy function does not work. I've read help pages gui-mouse, gui-mouse-move and gui-mouse-select, and tried various combinations of "selectmode" and "mousemodel", but can't come up with a combination that works.

      Any ideas??

      Thanks!
      Gary

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... I think I experimented once with setting mouse= (empty) on a FocusLost autocmd, but I don t remember whether that actually worked. I don t seem to have it
      Message 2 of 2 , Mar 27, 2013
      • 0 Attachment
        On Tuesday, March 26, 2013 11:24:56 PM UTC-5, SanDiegoGary wrote:
        > Hi,
        >
        > I'm using VIM 7.3 on Windows 7 (32-bit). I want two things:
        > 1) Prevent active window selection to change VIM cursor location (don't want the left mouse click to select the VIM window to affect the existing VIM cursor)
        > 2) Ability to copy/paste to/from windows keyboard (preferrable with edit>copy and edit>paste).
        >
        > To get (1), I've tried "set mouse=v" (or =c or =i). Visual, Insert and Command each give me (1). Default of =a, or Normal does not.
        >
        > When I have Visual, Insert or Command mouse modes, the edit> copy function does not work. I've read help pages gui-mouse, gui-mouse-move and gui-mouse-select, and tried various combinations of "selectmode" and "mousemodel", but can't come up with a combination that works.
        >
        > Any ideas??
        >
        > Thanks!
        > Gary

        I think I experimented once with setting mouse= (empty) on a FocusLost autocmd, but I don't remember whether that actually worked. I don't seem to have it in my .vimrc currently.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.