Loading ...
Sorry, an error occurred while loading the content.

vim 64 python dll loading

Expand Messages
  • CanisMajorWuff
    Hello, I am trying to build vim on Win64. I have a successful build with Dynamic Python 27 Support. But it does not work properly it does not load the python
    Message 1 of 1 , Mar 26, 2013
    • 0 Attachment
      Hello,
      I am trying to build vim on Win64. I have a successful build with
      Dynamic Python 27 Support. But it does not work properly
      it does not load the python library. My vim plugins inform me that I
      need python to run them.
      Here you can see the build of if_python.c

      gcc -c -Iproto -DWIN32 -DWINVER=0x0500 -D_WIN32_WINNT=0x0500
      -DHAVE_PATHDEF -DFEAT_BIG -DHAVE_GETTEXT -DHAVE_LOCALE_H
      -DDYNAMIC_GETTEXT -DFEAT_CSCOPE -DFEAT_NETBEANS_INTG -DFEAT_GUI_W32
      -DFEAT_CLIPBOARD -DFEAT_MBYTE -DFEAT_MBYTE_IME -DDYNAMIC_IME
      -DDYNAMIC_ICONV -pipe -w -march=x86-64 -Wall -DFEAT_PYTHON
      -DDYNAMIC_PYTHON -DFEAT_XPM_W32 -I xpm/x64/include -I xpm/x64/../include
      -O3 -fomit-frame-pointer -freg-struct-return -s -I /d/python/2.7/include
      -DDYNAMIC_PYTHON_DLL=\"python27.dll\" if_python.c -o gobjx86-64/if_python.o

      I have python27.dll in path, I even put it the same directory with
      gvim.exe. python27.dll is also 64 bit. Does somebody have any idea how
      to solve it?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.