Loading ...
Sorry, an error occurred while loading the content.

Question Ctrl+Shift+V

Expand Messages
  • Hendrikus Godvliet
    I have a problem to get pasted copy in to Vim Please take a look to this two screenshots Gedit and Vim Vim make s a mash of the pasting code
    Message 1 of 10 , Mar 26, 2013
    • 0 Attachment
      I have a problem to get pasted copy in to Vim

      Please take a look to this two screenshots Gedit and Vim

      Vim make's a mash of the pasting code

      http://hendrikus-godvliet.appspot.com/chakras/30001

      Plaese can someone help to make me clear how to corect past copy from outsite Vim into Vim.


      Hendrikus

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bartłomiej Laskowski
      ... i CTRL+SHIFT+v esc ... or... in normal mode +P ... Pozdrawiam Laskowski Bartłomiej www.twardy.org hardy@twardy.org +48 693 001 458 ... -- -- You received
      Message 2 of 10 , Mar 26, 2013
      • 0 Attachment
        :set paste
        i CTRL+SHIFT+v esc
        :set nopaste

        or...
        in normal mode
        "+P


        :wq
        -----

        Pozdrawiam
        Laskowski Bartłomiej
        www.twardy.org
        hardy@...
        +48 693 001 458

        W dniu 26.03.2013 13:25, Hendrikus Godvliet pisze:
        > I have a problem to get pasted copy in to Vim
        >
        > Please take a look to this two screenshots Gedit and Vim
        >
        > Vim make's a mash of the pasting code
        >
        > http://hendrikus-godvliet.appspot.com/chakras/30001
        >
        > Plaese can someone help to make me clear how to corect past copy from outsite Vim into Vim.
        >
        >
        > Hendrikus
        >

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • David Fishburn
        On Tue, Mar 26, 2013 at 8:25 AM, Hendrikus Godvliet
        Message 3 of 10 , Mar 26, 2013
        • 0 Attachment


          On Tue, Mar 26, 2013 at 8:25 AM, Hendrikus Godvliet <hendrikusgodvliet@...> wrote:
          I have a problem to get pasted copy in to Vim

          Please take a look to this two screenshots Gedit and Vim

          Vim make's a mash of the pasting code

          http://hendrikus-godvliet.appspot.com/chakras/30001


          You most likely wanted to run this before you paste:
          :set paste

          Paste your code, then:
          :set nopaste

          Or vice versa.

          HTH,
          David 

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • David Ohlemacher
          I have this in my .vimrc: The first line sets a mapping so that pressing F2 in normal mode will invert the paste option, and will then show the value of
          Message 4 of 10 , Mar 26, 2013
          • 0 Attachment
            I have this in my .vimrc:

            "The first line sets a mapping so that pressing F2 in normal mode will
            invert the 'paste' option, and will then show the value of that option.
            The second line allows you to press F2 when in insert mode, to toggle
            'paste' on and off. The third line enables displaying whether 'paste' is
            turned on in insert mode.
            nnoremap <F2> :set invpaste paste?<CR>
            set pastetoggle=<F2>
            set showmode


            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Gary Johnson
            ... The solution depends on how you are pasting, whether you re using using vim or gvim, how your Vim was built, and how your Vim is configured. There is
            Message 5 of 10 , Mar 26, 2013
            • 0 Attachment
              On 2013-03-26, Hendrikus Godvliet wrote:
              > I have a problem to get pasted copy in to Vim
              >
              > Please take a look to this two screenshots Gedit and Vim
              >
              > Vim make's a mash of the pasting code
              >
              > http://hendrikus-godvliet.appspot.com/chakras/30001
              >
              > Plaese can someone help to make me clear how to corect past copy
              > from outsite Vim into Vim.

              The solution depends on how you are pasting, whether you're using
              using vim or gvim, how your Vim was built, and how your Vim is
              configured.

              There is usually no problem pasting to gvim, so I'm going to assume
              you're using vim in a terminal. (The URL above didn't show
              anything. NoScript asked if I wanted to allow scripts on that page
              and I declined.)

              If you are using a vim that supports X11 and the xterm_clipboard, as
              you should be, and if you have mouse=all, then pasting should work
              properly. Oftentimes a Linux distribution will provide a vim that
              does not have X11 and xterm_clipboard included. You can find out if
              yours does by executing ":version". If you don't have those two
              features, then either install a more fully-functional vim package or
              invoke vim as "gvim -v". The latter will run gvim in terminal mode.

              If none of that is possible, then as a last resort you can do as
              others have suggested and set paste before pasting and nopaste
              afterwards. The only time I ever have to use paste/nopaste is when
              I'm using vim from PuTTY over an ssh connection. Otherwise, normal
              pasting using the mouse "just works".

              HTH,
              Gary

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Christian Brabandt
              ... I don t understand what your problem is, and that webpage shows 2 screenshots but no problem description, just how to copy and paste. I guess, everybody
              Message 6 of 10 , Mar 26, 2013
              • 0 Attachment
                On Tue, March 26, 2013 13:25, Hendrikus Godvliet wrote:
                > I have a problem to get pasted copy in to Vim
                >
                > Please take a look to this two screenshots Gedit and Vim
                >
                > Vim make's a mash of the pasting code
                >
                > http://hendrikus-godvliet.appspot.com/chakras/30001
                >
                > Plaese can someone help to make me clear how to corect past copy from
                > outsite Vim into Vim.
                >

                I don't understand what your problem is, and that webpage shows 2
                screenshots but no problem description, just how to copy and paste.
                I guess, everybody here knows those basic principle.

                Are you copying from an application outside of vim into terminal vim?
                Then as others have outlined, the solution is usually :set paste
                Other solutions are mentioned in the faq at:
                http://vimhelp.appspot.com/vim_faq.txt.html#faq-14.14

                If you are copy and pasting within your vim session, then I would
                say, this shouldn't happen. Can you reproduce the behaviour starting
                from vim -u NONE -N?
                It if doesn't happen, then your .vimrc or a plugin is likely the problem
                if it also happens there, you might have found a bug.

                Also see the faq for debugging this kind of stuff:
                http://vimhelp.appspot.com/vim_faq.txt.html#faq-36.12

                regards,
                Christian

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Hendrikus Godvliet
                David Thank this what i missed. And from now on I will rock, set paste to the Vim. Hendrikus 2013/3/26 David Fishburn ... -- -- You
                Message 7 of 10 , Mar 26, 2013
                • 0 Attachment
                  David 

                  Thank this what i missed. And from now on I will rock, set paste to the Vim.


                  Hendrikus

                  2013/3/26 David Fishburn <dfishburn.vim@...>
                  set paste


                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                   
                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                   
                   
                • Marcin Szamotulski
                  ... I am looking for a nice setting to automate this process in urxvt terminal. I found:
                  Message 8 of 10 , Mar 26, 2013
                  • 0 Attachment
                    On 20:46 Tue 26 Mar , Hendrikus Godvliet wrote:
                    > David
                    >
                    > Thank this what i missed. And from now on I will rock, set paste to the Vim.
                    >
                    >
                    > Hendrikus
                    >
                    > 2013/3/26 David Fishburn <dfishburn.vim@...>
                    >
                    > > set paste
                    >
                    > --
                    > --
                    > You received this message from the "vim_use" maillist.
                    > Do not top-post! Type your reply below the text you are replying to.
                    > For more information, visit http://www.vim.org/maillist.php
                    >
                    > ---
                    > You received this message because you are subscribed to the Google Groups "vim_use" group.
                    > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    > For more options, visit https://groups.google.com/groups/opt_out.
                    >
                    >

                    I am looking for a nice setting to automate this process in urxvt
                    terminal. I found:
                    http://stackoverflow.com/questions/5585129/pasting-code-into-terminal-window-into-vim-on-mac-os-x/7053522#7053522
                    but it is not working for me. For now I use:

                    set pastetoggle=<f9>
                    imap <c-r> <f9><c-r>

                    So I don't need to remember to set the pastmode. Is there a plugin out
                    there for this?

                    Best,
                    Marcin Szamotulski

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Hendrikus Godvliet
                    Gary  Thanks for your information. I am on Linux Mind and using Vim. You make me aware that i can paste with the mouse and it works.  Greating Hendrikus Op
                    Message 9 of 10 , Mar 27, 2013
                    • 0 Attachment
                      Gary 

                      Thanks for your information. I am on Linux Mind and using Vim. You make me aware that i can paste with the mouse and it works. 

                      Greating Hendrikus

                      Op di, mrt 26, 2013 at 4:28 ,Gary Johnson <garyjohn@...> schreef:
                      On 2013-03-26, Hendrikus Godvliet wrote:
                      > I have a problem to get pasted copy in to Vim
                      >
                      > Please take a look to this two screenshots Gedit and Vim
                      >
                      > Vim make's a mash of the pasting code
                      >
                      > http://hendrikus-godvliet.appspot.com/chakras/30001
                      >
                      > Plaese can someone help to make me clear how to corect past copy
                      > from outsite Vim into Vim.

                      The solution depends on how you are pasting, whether you're using
                      using vim or gvim, how your Vim was built, and how your Vim is
                      configured.

                      There is usually no problem pasting to gvim, so I'm going to assume
                      you're using vim in a terminal. (The URL above didn't show
                      anything. NoScript asked if I wanted to allow scripts on that page
                      and I declined.)

                      If you are using a vim that supports X11 and the xterm_clipboard, as
                      you should be, and if you have mouse=all, then pasting should work
                      properly. Oftentimes a Linux distribution will provide a vim that
                      does not have X11 and xterm_clipboard included. You can find out if
                      yours does by executing ":version". If you don't have those two
                      features, then either install a more fully-functional vim package or
                      invoke vim as "gvim -v". The latter will run gvim in terminal mode.

                      If none of that is possible, then as a last resort you can do as
                      others have suggested and set paste before pasting and nopaste
                      afterwards. The only time I ever have to use paste/nopaste is when
                      I'm using vim from PuTTY over an ssh connection. Otherwise, normal
                      pasting using the mouse "just works".

                      HTH,
                      Gary

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.



                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                       
                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                       
                       
                    • Hendrikus Godvliet
                      ... http://vimhelp.appspot.com/vim_faq.txt.html#faq-14.14 Thanks for this info, it make it clear why and how text will be inserted literally. Gr Hendrikus  Op
                      Message 10 of 10 , Mar 27, 2013
                      • 0 Attachment
                        >Other solutions are mentioned in the faq at:

                        Thanks for this info, it make it clear why and how text will be inserted literally.


                        Gr Hendrikus 

                        Op di, mrt 26, 2013 at 4:42 ,Christian Brabandt <cblists@...> schreef:
                        On Tue, March 26, 2013 13:25, Hendrikus Godvliet wrote:
                        > I have a problem to get pasted copy in to Vim
                        >
                        > Please take a look to this two screenshots Gedit and Vim
                        >
                        > Vim make's a mash of the pasting code
                        >
                        > http://hendrikus-godvliet.appspot.com/chakras/30001
                        >
                        > Plaese can someone help to make me clear how to corect past copy from
                        > outsite Vim into Vim.
                        >

                        I don't understand what your problem is, and that webpage shows 2
                        screenshots but no problem description, just how to copy and paste.
                        I guess, everybody here knows those basic principle.

                        Are you copying from an application outside of vim into terminal vim?
                        Then as others have outlined, the solution is usually :set paste
                        Other solutions are mentioned in the faq at:
                        http://vimhelp.appspot.com/vim_faq.txt.html#faq-14.14

                        If you are copy and pasting within your vim session, then I would
                        say, this shouldn't happen. Can you reproduce the behaviour starting
                        from vim -u NONE -N?
                        It if doesn't happen, then your .vimrc or a plugin is likely the problem
                        if it also happens there, you might have found a bug.

                        Also see the faq for debugging this kind of stuff:
                        http://vimhelp.appspot.com/vim_faq.txt.html#faq-36.12

                        regards,
                        Christian

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.



                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                         
                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                         
                         
                      Your message has been successfully submitted and would be delivered to recipients shortly.