Loading ...
Sorry, an error occurred while loading the content.

Re: hi CursorLine

Expand Messages
  • Andy Wokula
    ... You should put custom settings after this command. -- Andy -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply
    Message 1 of 11 , Mar 25, 2013
    • 0 Attachment
      Am 23.03.2013 02:11, schrieb rail shafigulin:
      > Here is what the output of verbose hi CursorLine
      > CursorLine xxx term=underline ctermbg=237 guibg=#3a3a3a
      > Last set from
      > ~/vimfiles/bundle/colour-sampler-pack/colors/xoria256.vim
      >
      > Here is the setting from xoria256.vim
      > hi CursorLine ctermbg=237 guibg=#3a3a3a cterm=none gui=none
      >
      > And here is how it is set in my vimrc
      > colorscheme xoria256
      > " Set the line of with the cursor to be underlined.
      > hi CursorLine gui=underline guibg=NONE term=underline cterm=underline
      > " Turn on the highlight of the line with the cursor.
      > set cursorline
      >
      > The output looks like it is a mixture of the downloaded colorscheme and my
      > own settings.
      > I run my pathogen plugin before the colorscheme is set.
      >
      > I'm not sure what is going on.

      :syntax on is also known to set the color scheme.
      You should put custom settings after this command.

      --
      Andy

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Anthony Campbell
      ... Perhaps make a test vimrc file with just the one line to see if that works? If it does,k there must be something the regular file that is precenting it
      Message 2 of 11 , Mar 25, 2013
      • 0 Attachment
        On 22 Mar 2013, FlashBurn wrote:
        > I don't use gvimrc file. Good guess though.
        >
        > Are there any other suggestions on what might be going wrong. Any help is appreciated.
        >
        > --
        > --
        > You received this message from the "vim_use" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php
        >
        > ---
        > You received this message because you are subscribed to the Google Groups "vim_use" group.
        > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        > For more options, visit https://groups.google.com/groups/opt_out.

        Perhaps make a test vimrc file with just the one line to see if that
        works? If it does,k there must be something the regular file that is
        precenting it working.

        --
        Anthony Campbell - ac@...
        http://www.acampbell.org.uk
        http://www.reviewbooks.org.uk
        http://www.skepticviews.org.uk
        http://www.acupuncturecourse.org.uk
        http://www.smashwords.com/profile.view/acampbell
        https://itunes.apple.com/ca/artist/anthony-campbell/id73235412





        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • FlashBurn
        ... That s exactly what was happening. I put my colorscheme setting after syntax on and it worked. Thanks. -- -- You received this message from the vim_use
        Message 3 of 11 , Mar 25, 2013
        • 0 Attachment
          >
          > :syntax on is also known to set the color scheme.
          >

          That's exactly what was happening. I put my colorscheme setting after syntax on and it worked.

          Thanks.


          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.