Loading ...
Sorry, an error occurred while loading the content.

Re: open quickfix windows after csope and jump

Expand Messages
  • Gary Johnson
    ... I think that should have worked. I grep d for a pattern, executed :copen and tried various :normal commands with , and and
    Message 1 of 10 , Mar 21, 2013
    • 0 Attachment
      On 2013-03-20, FlashBurn wrote:
      > On Tuesday, March 19, 2013 5:54:23 PM UTC-4, Christian Brabandt wrote:

      > > You need 2 commands:
      > >
      > > :copen
      > >
      > > :norm! "\<Cr>"
      > >
      >
      > I tried the following:
      > function! CscopeFind(action, word)
      > try
      > exe ':cs f '.a:action.' '.a:word
      > copen
      > normal "\<cr>"
      > catch
      > echohl WarningMsg | echo 'Can not find '.a:word.' with querytype as '.a:action.'.' | echohl None
      > endtry
      > endfunction
      >
      > And it didn't work. I also tried normal "<cr>", normal! "\<cr>",
      > and normal! "<cr>". None of them worked. Does anybody have any
      > other ideas?

      I think that should have worked.

      I grep'd for a pattern, executed ":copen" and tried various
      ":normal" commands with "\<CR>", "\<LF>" and "\<Enter>" and none
      worked. I think this may be a bug.

      However, I also skimmed quickfix.txt and found that the command
      ".cc" should also work, and it worked for me, so try

      .cc

      where you now have

      normal "\<cr>"

      HTH,
      Gary

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • FlashBurn
      ... Gary it worked. But I didn t use normal .cc , I simply used cc instead. Here is how it looks function! CscopeFind(action, word) try exe :cs f
      Message 2 of 10 , Mar 21, 2013
      • 0 Attachment
        On Thursday, March 21, 2013 1:24:12 PM UTC-4, Gary Johnson wrote:
        > On 2013-03-20, FlashBurn wrote:
        >
        > > On Tuesday, March 19, 2013 5:54:23 PM UTC-4, Christian Brabandt wrote:
        >
        >
        >
        > > > You need 2 commands:
        >
        > > >
        >
        > > > :copen
        >
        > > >
        >
        > > > :norm! "\<Cr>"
        >
        > > >
        >
        > >
        >
        > > I tried the following:
        >
        > > function! CscopeFind(action, word)
        >
        > > try
        >
        > > exe ':cs f '.a:action.' '.a:word
        >
        > > copen
        >
        > > normal "\<cr>"
        >
        > > catch
        >
        > > echohl WarningMsg | echo 'Can not find '.a:word.' with querytype as '.a:action.'.' | echohl None
        >
        > > endtry
        >
        > > endfunction
        >
        > >
        >
        > > And it didn't work. I also tried normal "<cr>", normal! "\<cr>",
        >
        > > and normal! "<cr>". None of them worked. Does anybody have any
        >
        > > other ideas?
        >
        >
        >
        > I think that should have worked.
        >
        >
        >
        > I grep'd for a pattern, executed ":copen" and tried various
        >
        > ":normal" commands with "\<CR>", "\<LF>" and "\<Enter>" and none
        >
        > worked. I think this may be a bug.
        >
        >
        >
        > However, I also skimmed quickfix.txt and found that the command
        >
        > ".cc" should also work, and it worked for me, so try
        >
        >
        >
        > .cc
        >
        >
        >
        > where you now have
        >
        >
        >
        > normal "\<cr>"
        >
        >
        >
        > HTH,
        >
        > Gary

        Gary it worked. But I didn't use normal ".cc", I simply used cc instead.
        Here is how it looks

        function! CscopeFind(action, word)
        try
        exe ':cs f '.a:action.' '.a:word
        copen
        cc
        catch
        echohl WarningMsg | echo 'Can not find '.a:word.' with querytype as '.a:action.'.' | echohl None

        I'm also wondering if the dot (.) in front of a cc in your response is a type, or Vim has special meaning for it

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Gary Johnson
        ... Right. That s why I wrote it out as I did. I didn t write normal .cc I wrote .cc ... To be honest, I don t know why the . is needed either, but
        Message 3 of 10 , Mar 21, 2013
        • 0 Attachment
          On 2013-03-21, FlashBurn wrote:
          > On Thursday, March 21, 2013 1:24:12 PM UTC-4, Gary Johnson wrote:

          > > However, I also skimmed quickfix.txt and found that the command
          > > ".cc" should also work, and it worked for me, so try
          > >
          > > .cc
          > >
          > > where you now have
          > >
          > > normal "\<cr>"

          > Gary it worked. But I didn't use normal ".cc", I simply used cc
          > instead.

          Right. That's why I wrote it out as I did. I didn't write

          normal ".cc"

          I wrote

          .cc

          > Here is how it looks
          >
          > function! CscopeFind(action, word)
          > try
          > exe ':cs f '.a:action.' '.a:word
          > copen
          > cc
          > catch
          > echohl WarningMsg | echo 'Can not find '.a:word.' with querytype as '.a:action.'.' | echohl None
          >
          > I'm also wondering if the dot (.) in front of a cc in your
          > response is a type, or Vim has special meaning for it

          To be honest, I don't know why the . is needed either, but
          paragraph in quickfix.txt (beginning at line 353) began

          In the quickfix window, each line is one error. The line number
          is equal to the error number. You can use ":.cc" to jump to the
          error under the cursor.

          so that's what I tried, it worked, and so that's what I suggested to
          you.

          Regards,
          Gary

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          Hi Gary! ... No, actually, this was an error on my side. normal doesn t understand the -notation: ,----[ :h exe ]- ... `---- Mit freundlichen Grüßen
          Message 4 of 10 , Mar 21, 2013
          • 0 Attachment
            Hi Gary!

            On Do, 21 Mär 2013, Gary Johnson wrote:

            > > And it didn't work. I also tried normal "<cr>", normal! "\<cr>",
            > > and normal! "<cr>". None of them worked. Does anybody have any
            > > other ideas?
            >
            > I think that should have worked.
            >
            > I grep'd for a pattern, executed ":copen" and tried various
            > ":normal" commands with "\<CR>", "\<LF>" and "\<Enter>" and none
            > worked. I think this may be a bug.

            No, actually, this was an error on my side. normal doesn't understand
            the <key>-notation:

            ,----[ :h exe ]-
            | ":execute" is also a nice way to avoid having to type
            | control characters in a Vim script for a ":normal"
            | command: >
            | :execute "normal ixxx\<Esc>"
            | This has an <Esc> character, see |expr-string|.
            `----


            Mit freundlichen Grüßen
            Christian
            --
            Humor hat viel mit Verstand zu tun.
            -- Helmut Dietl

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.