Loading ...
Sorry, an error occurred while loading the content.

vim and tcomment

Expand Messages
  • FlashBurn
    I have just loaded tcomment plugin, https://github.com/tomtom/tcomment_vim. I code in C and need to be able to do line comments ( // ). For some reason this
    Message 1 of 5 , Mar 21, 2013
    • 0 Attachment
      I have just loaded tcomment plugin, https://github.com/tomtom/tcomment_vim. I code in C and need to be able to do line comments ( // ). For some reason this plugin does only block comments ( /* ... */). I looked through the documentation but was not able to find a way to configure the plugin to do the line comments. Does anybody know how to do it?

      Any help is appreciated.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Marc Weber
      Use github.com/MarcWeber/vim-adddon-commenting which always prefers those # // like line prefix comments and you re done. Otherwise this is not a question for
      Message 2 of 5 , Mar 21, 2013
      • 0 Attachment
        Use github.com/MarcWeber/vim-adddon-commenting which always prefers
        those # // like line prefix comments and you're done.

        Otherwise this is not a question for the vim mailinglist, but for
        github/tomtom/issues -> improve documentation (I hope you've read that)

        This is my "view" - there might be more solutions.

        Marc Weber

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Marcin Sztolcman
        ... For example, from my .vimrc: let g:tcommentLineC = { commentstring : // %s , } -- Marcin Sztolcman :: http://urzenia.net/ :: http://sztolcman.eu/ --
        Message 3 of 5 , Mar 21, 2013
        • 0 Attachment
          On 21 mar 2013, at 16:55, FlashBurn <rail.shafigulin@...> wrote:

          > I have just loaded tcomment plugin, https://github.com/tomtom/tcomment_vim. I code in C and need to be able to do line comments ( // ). For some reason this plugin does only block comments ( /* ... */). I looked through the documentation but was not able to find a way to configure the plugin to do the line comments. Does anybody know how to do it?


          For example, from my .vimrc:

          let g:tcommentLineC = {
          \ 'commentstring': '// %s',
          \}

          --
          Marcin Sztolcman :: http://urzenia.net/ :: http://sztolcman.eu/

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Chris Lott
          ... Typo in link, should be: https://github.com/MarcWeber/vim-addon-commenting Nice plugin. c -- Chris Lott -- -- You received this
          Message 4 of 5 , Mar 21, 2013
          • 0 Attachment
            On Thu, Mar 21, 2013 at 8:09 AM, Marc Weber <marco-oweber@...> wrote:
            > Use github.com/MarcWeber/vim-adddon-commenting which always prefers
            > those # // like line prefix comments and you're done.

            Typo in link, should be: https://github.com/MarcWeber/vim-addon-commenting

            Nice plugin.

            c
            --
            Chris Lott <chris@...>

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • rail shafigulin
            ... Thank you it worked. However if you run pathogen this string must be set before pathogen is called. -- -- You received this message from the vim_use
            Message 5 of 5 , Mar 22, 2013
            • 0 Attachment



              On Thu, Mar 21, 2013 at 12:37 PM, Marcin Sztolcman <marcin@...> wrote:
              On 21 mar 2013, at 16:55, FlashBurn <rail.shafigulin@...> wrote:

              > I have just loaded tcomment plugin, https://github.com/tomtom/tcomment_vim. I code in C and need to be able to do line comments ( // ). For some reason this plugin does only block comments ( /* ... */). I looked through the documentation but was not able to find a way to configure the plugin to do the line comments. Does anybody know how to do it?


              For example, from my .vimrc:

              let g:tcommentLineC = {
                  \ 'commentstring': '// %s',
                  \}

              --
              Marcin Sztolcman :: http://urzenia.net/ :: http://sztolcman.eu/

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to a topic in the Google Groups "vim_use" group.
              To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_use/xA7yBFDXb3I/unsubscribe?hl=en.
              To unsubscribe from this group and all its topics, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.



              Thank you it worked. However if you run pathogen this string must be set before pathogen is called. 

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
               
               
            Your message has been successfully submitted and would be delivered to recipients shortly.