Loading ...
Sorry, an error occurred while loading the content.

Re: How to get rid of oddly-highlighted keywords in Vim

Expand Messages
  • Charles E Campbell
    ... Since no one else has responded to you, here s a somewhat generic answer (I myself am not a groovy user). If you re having a syntax highlighting issue,
    Message 1 of 5 , Mar 20, 2013
    • 0 Attachment
      Benjamin Klein wrote:
      > For what it's worth, I am using Vim for a Grails project, written in
      > Groovy, and I have the Groovy plugin[1] installed. There are certain
      > keywords (“delete” is one) that for some reason are highlighted in red
      > wherever they occur in my source files. What might be the reason for
      > this? I don't think it's the Groovy plugin, because this was occurring
      > back before I had it installed. Also: How might I get rid of this
      > highlighting?
      Since no one else has responded to you, here's a somewhat generic answer
      (I myself am not a groovy user). If you're having a syntax highlighting
      issue, then I suggest attempting to contact the syntax highlighting
      file's maintainer. Look for vim73/syntax/groovy.vim, open it up, and
      you'll see the maintainer's name and email therein.

      Regards,
      C Campbell

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Benjamin Klein
      ... Heh -- funnily enough, removing the words I didn t need highlighted from that very file was enough to do the trick (obviously, to anybody with experience
      Message 2 of 5 , Mar 27, 2013
      • 0 Attachment
        On Mar 20, 2013, at 10:12 PM, Charles E Campbell <drchip@...> wrote:

        > Look for vim73/syntax/groovy.vim, open it up, and you'll see the maintainer's name and email therein.

        Heh -- funnily enough, removing the words I didn't need highlighted from that very file was enough to do the trick (obviously, to anybody with experience in doing these plugins, but I have none). So thanks. :)

        Ben

        --
        b

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        Hi Benjamin! ... Nevertheless, you should at least let the maintainer know of the problem, so he can fix it and other users don t stumble on it later. And,
        Message 3 of 5 , Mar 27, 2013
        • 0 Attachment
          Hi Benjamin!

          On Mi, 27 Mär 2013, Benjamin Klein wrote:

          > On Mar 20, 2013, at 10:12 PM, Charles E Campbell <drchip@...> wrote:
          >
          > > Look for vim73/syntax/groovy.vim, open it up, and you'll see the maintainer's name and email therein.
          >
          > Heh -- funnily enough, removing the words I didn't need highlighted from that very file was enough to do the trick (obviously, to anybody with experience in doing these plugins, but I have none). So thanks. :)

          Nevertheless, you should at least let the maintainer know of the
          problem, so he can fix it and other users don't stumble on it later.

          And, remember, whenever you change files whithin the $VIMRUNTIME
          directory, those changes might silently being overwritten on later
          upgrades:
          http://vimhelp.appspot.com/vim_faq.txt.html#faq-36.11

          regards,
          Christian
          --
          Kein Lesen ist der Mühe wert, wenn es nicht unterhält.
          -- William Somerset Maugham

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Benjamin Klein
          ... I shall do so. And thanks :) Ben -- b Sent from my iPhone -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply
          Message 4 of 5 , Mar 28, 2013
          • 0 Attachment
            On Mar 27, 2013, at 4:30 PM, Christian Brabandt <cblists@...> wrote:

            > Nevertheless, you should at least let the maintainer know of the
            > problem, so he can fix it and other users don't stumble on it later.
            >
            > And, remember, whenever you change files whithin the $VIMRUNTIME
            > directory, those changes might silently being overwritten on later
            > upgrades:
            > http://vimhelp.appspot.com/vim_faq.txt.html#faq-36.11

            I shall do so. And thanks :)

            Ben

            --
            b

            Sent from my iPhone

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.