Loading ...
Sorry, an error occurred while loading the content.

Cut and paste w/mouse

Expand Messages
  • TommyB
    Hey Folks, I m a longtime unix/linux commandline vi user, and work mostly at the console. Does dinosaur come to mind? Well anyway... Recently I ve started
    Message 1 of 5 , Mar 8, 2013
    • 0 Attachment
      Hey Folks,

      I'm a longtime unix/linux commandline vi user, and work mostly at the console.
      Does dinosaur come to mind? Well anyway...

      Recently I've started using vim and like the automatic formating and highlighting features.

      In vi, I can use the mouse to copy something from another terminal and paste it into the file I'm editing.

      I can't figure out a way to do that with vim. I copy something with the left mouse button, press "i" to insert and then press the right mouse button.
      The -- (insert) VISUAL -- mode comes up with a bunch of highlighted lines.

      Is there a way to disable the Visual mode? If(not), then vim is just a pretty way to display my code.
      Of course I may have to learn something new! It may be tough, (Old dog ya' know!) but I'm willing to try.

      Thanks for any help/suggestions.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Try from either Normal or insert mode, the middle mouse button, if you insist on using the mouse. If you prefer the keyboard, from Normal mode you paste
      Message 2 of 5 , Mar 8, 2013
      • 0 Attachment
        On Friday, March 8, 2013 10:41:52 AM UTC-6, TommyB wrote:
        > Hey Folks,
        >
        > I'm a longtime unix/linux commandline vi user, and work mostly at the console.
        > Does dinosaur come to mind? Well anyway...
        >
        > Recently I've started using vim and like the automatic formating and highlighting features.
        >
        > In vi, I can use the mouse to copy something from another terminal and paste it into the file I'm editing.
        >
        > I can't figure out a way to do that with vim. I copy something with the left mouse button, press "i" to insert and then press the right mouse button.
        > The -- (insert) VISUAL -- mode comes up with a bunch of highlighted lines.
        >

        Try from either Normal or insert mode, the middle mouse button, if you insist on using the mouse.

        If you prefer the keyboard, from Normal mode you paste from the primary selection clipboard with "*p or from the system clipboard with "+p. From Insert mode it's CTRL+R followed by * or +.

        This assumes that your Vim was compiled with clipboard support, compiled with mouse support, and that the mouse is turned on in the options (e.g. :set mouse=a).

        Check the output of :version to make sure your Vim is compiled with clipboard support. If not, you'll need to upgrade before you can interact with the system clipboard.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Gary Johnson
        ... An alternative to upgrading is using gvim instead of vim, if gvim is installed on your system, by either linking, e.g., $ ln -s $(which gvim) ~/bin/vim or
        Message 3 of 5 , Mar 8, 2013
        • 0 Attachment
          On 2013-03-08, Ben Fritz wrote:

          > Check the output of :version to make sure your Vim is compiled
          > with clipboard support. If not, you'll need to upgrade before you
          > can interact with the system clipboard.

          An alternative to upgrading is using gvim instead of vim, if gvim is
          installed on your system, by either linking, e.g.,

          $ ln -s $(which gvim) ~/bin/vim

          or using an alias, e.g.,

          $ alias vim='gvim -v'

          Regards,
          Gary

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • TommyB
          ... Tried the two suggestions above. They don t work for me. The first just pastes random text. The second is OOTQ because I don t use windoze. Thanks anyway.
          Message 4 of 5 , Mar 8, 2013
          • 0 Attachment
            On Friday, March 8, 2013 11:41:52 AM UTC-5, TommyB wrote:
            > Hey Folks,
            >
            > I'm a longtime unix/linux commandline vi user, and work mostly at the console.
            > Does dinosaur come to mind? Well anyway...
            >
            > Recently I've started using vim and like the automatic formating and highlighting features.
            >
            > In vi, I can use the mouse to copy something from another terminal and paste it into the file I'm editing.
            >
            > I can't figure out a way to do that with vim. I copy something with the left mouse button, press "i" to insert and then press the right mouse button.
            > The -- (insert) VISUAL -- mode comes up with a bunch of highlighted lines.
            >
            > Is there a way to disable the Visual mode? If(not), then vim is just a pretty way to display my code.
            > Of course I may have to learn something new! It may be tough, (Old dog ya' know!) but I'm willing to try.
            >
            > Thanks for any help/suggestions.

            Tried the two suggestions above. They don't work for me. The first just pastes random text. The second is OOTQ because I don't use windoze. Thanks anyway.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Gary Johnson
            ... By the second I assume you mean mine. Who said anything about Windows? The solution I gave is for Unix. It s a workaround for the all-too-common
            Message 5 of 5 , Mar 8, 2013
            • 0 Attachment
              On 2013-03-08, TommyB wrote:
              > On Friday, March 8, 2013 11:41:52 AM UTC-5, TommyB wrote:
              > > Hey Folks,
              > >
              > > I'm a longtime unix/linux commandline vi user, and work mostly
              > > at the console. Does dinosaur come to mind? Well anyway...
              > >
              > > Recently I've started using vim and like the automatic formating
              > > and highlighting features.
              > >
              > > In vi, I can use the mouse to copy something from another
              > > terminal and paste it into the file I'm editing.
              > >
              > > I can't figure out a way to do that with vim. I copy something
              > > with the left mouse button, press "i" to insert and then press
              > > the right mouse button. The -- (insert) VISUAL -- mode comes up
              > > with a bunch of highlighted lines.
              > >
              > > Is there a way to disable the Visual mode? If(not), then vim is
              > > just a pretty way to display my code. Of course I may have to
              > > learn something new! It may be tough, (Old dog ya' know!) but
              > > I'm willing to try.
              > >
              > > Thanks for any help/suggestions.
              >
              > Tried the two suggestions above. They don't work for me. The first
              > just pastes random text. The second is OOTQ because I don't use
              > windoze. Thanks anyway.

              By "the second" I assume you mean mine. Who said anything about
              Windows? The solution I gave is for Unix. It's a workaround for
              the all-too-common problem that some Linux distributions provide a
              vim package that is not configured to interact with an X server.

              As one who uses vim in a terminal all day to do all my editing
              tasks, including copying and pasting to and from various
              applications, I can assure you that when properly configured,
              copying and pasting works just fine.

              If you really want to solve this, I'm sure we can. We have for many
              other users who have reported similar issues. We do need a little
              more information from you besides "they don't work."

              To start with, we need to know whether your vim was built with
              support for X and the clipboard. Posting the full output of
              ":version" or "vim --version" will give us that.

              If your vim does appear to support X and the clipboard, then the
              next step is to find out exactly what you did and exactly what you
              saw. When you do that, make sure you start vim as

              vim -N -u NONE

              so that we can eliminate plugins and configuration differences from
              the problem.

              Regards,
              Gary

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.