Loading ...
Sorry, an error occurred while loading the content.

Re: Filtering popupmenu-completion without changing word before cursor

Expand Messages
  • Martin Lundberg
    ... The first sentence describing longest in the help is Only insert the longest common text of the matches. It inserts the longest common text of the
    Message 1 of 6 , Mar 5, 2013
    View Source
    • 0 Attachment
      On Tuesday, March 5, 2013 6:30:35 PM UTC+1, Ben Fritz wrote:
      > Setting 'longest' won't add anything to any sort of "filter". I have no idea what you mean there.

      The first sentence describing 'longest' in the help is "Only insert the longest common text of the matches." It inserts the longest common text of the matches, I don't want that.

      > You also mentioned "a one-line buffer at the top" showing up for completion. Maybe you also want "preview"? I.e. it sounds to me like you want
      >
      > :set completeopt=longest,menuone,preview
      >
      > What exactly isn't happening that you expect with that setting? Or, what is happening that you don't want? Please be precise.

      You can see what I mean with a one line buffer here: http://www.youtube.com/watch?feature=player_detailpage&v=_MYuiqhfrIU#t=28s

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.