Loading ...
Sorry, an error occurred while loading the content.

Something is overriding my comments= commands

Expand Messages
  • Jason
    I have a .vimrc where I run: set comments= I added the command to my ~/.vim/cpp.vim file and ~/.gvimrc file as well. Yet somehow, I have comments set to a
    Message 1 of 2 , Mar 5, 2013
    View Source
    • 0 Attachment
      I have a .vimrc where I run:
      set comments=

      I added the command to my ~/.vim/cpp.vim file and ~/.gvimrc file as well. Yet somehow, I have comments set to a non-blank value that puts garbage all over my files when I run my comment creation macros. I can unset it by hand in every session, but the point of the .vimrc file is to avoid doing that every time.

      Is there a way to see where this is getting set? Or to somehow turn it off system-wide (short of a custom compilation)?

      Here's my vim --version:
      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Oct 26 2012 16:45:33)
      Included patches: 1-547
      Modified by pkg-vim-maintainers@...
      Compiled by buildd@
      Huge version with GTK2 GUI. Features included (+) or not (-):
      +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent
      +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
      +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
      +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
      +file_in_path +find_in_path +float +folding -footer +fork() +gettext
      -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
      +linebreak +lispindent +listcmds +localmap +lua +menu +mksession +modify_fname
      +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm
      -mouse_sysmouse +mouse_xterm +mouse_urxvt +multi_byte +multi_lang -mzscheme
      +netbeans_intg +path_extra +perl +persistent_undo +postscript +printer +profile
      +python -python3 +quickfix +reltime +rightleft +ruby +scrollbind +signs
      +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
      +tag_old_static -tag_any_white +tcl +terminfo +termresponse +textobjects +title
      +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
      +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim
      +xsmp_interact +xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/usr/share/vim"
      Compilation: gcc-4.6 -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -I/usr/include/tcl8.5 -D_REENTRANT=1 -D_THREAD_SAFE=1 -D_LARGEFILE64_SOURCE=1
      Linking: gcc-4.6 -L. -Wl,-Bsymbolic-functions -Wl,-z,relro -rdynamic -Wl,-export-dynamic -Wl,-E -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,--as-needed -o vim -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm -ltinfo -lnsl -lselinux -lacl -lattr -lgpm -ldl -L/usr/lib -llua5.1 -Wl,-E -fstack-protector -L/usr/local/lib -L/usr/lib/perl/5.14/CORE -lperl -ldl -lm -lpthread -lcrypt -L/usr/lib/python2.7/config -lpython2.7 -lpthread -ldl -lutil -lm -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions -L/usr/lib -ltcl8.5 -ldl -lpthread -lieee -lm -lruby-1.9.1 -lpthread -lrt -ldl -lcrypt -lm -L/usr/lib

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Gary Johnson
      ... To see where it is getting set, execute ... To override a filetype plugin s setting of this, put your setting in, for example,
      Message 2 of 2 , Mar 5, 2013
      View Source
      • 0 Attachment
        On 2013-03-05, Jason wrote:
        > I have a .vimrc where I run:
        > set comments=
        >
        > I added the command to my ~/.vim/cpp.vim file and ~/.gvimrc file
        > as well. Yet somehow, I have comments set to a non-blank value
        > that puts garbage all over my files when I run my comment creation
        > macros. I can unset it by hand in every session, but the point of
        > the .vimrc file is to avoid doing that every time.
        >
        > Is there a way to see where this is getting set? Or to somehow
        > turn it off system-wide (short of a custom compilation)?

        To see where it is getting set, execute

        :verbose set comments?

        To override a filetype plugin's setting of this, put your setting
        in, for example,

        ~/.vim/after/ftplugin/cpp.vim

        Putting your setting in ~/.vim/ftplugin/cpp.vim will not work
        because the default $VIMRUNTIME/ftplugin/cpp.vim file is loaded
        after ~/.vim/ftplugin/cpp.vim. (See ":help 'rtp'".)

        Putting your setting in ~/.vim/cpp.vim will not work because Vim
        does not read that file unless you source it explicitly.

        You may want to read

        :help ftplugin-overrule
        :help startup

        Regards,
        Gary

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.