Loading ...
Sorry, an error occurred while loading the content.
 

Re: ctrlP to navigate arbitrary directory

Expand Messages
  • Fabien Meghazi
    ... Cool ! Just discovered CtrlP with this post and I like it, especially the root path autodiscovery ! I d like to change the default behaviour of in
    Message 1 of 9 , Mar 5, 2013
      On Thu, Feb 28, 2013 at 3:37 PM, Kent <kent.yuan@...> wrote:
      > I use FuzzyFinder for years. Recently I heard a lot about CtrlP. And gave it
      > a try. It does have some good features over FF.

      Cool ! Just discovered CtrlP with this post and I like it, especially
      the root path autodiscovery !

      I'd like to change the default behaviour of <cr> in CtrlP shell in
      order to open in new tab instead of current window. I can't see an
      option for that in ctrlp.txt. Is it possible ?

      --
      Fabien Meghazi

      Website: http://www.amigrave.com
      Email: agr@...
      IM: amigrave@...

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Benjamin R. Haskell
      ... Yes. Here s what you re asking for (put it in your .vimrc): let g:ctrlp_prompt_mappings = { AcceptSelection( t ) : [ ], } See: :help
      Message 2 of 9 , Mar 5, 2013
        On Tue, 5 Mar 2013, Fabien Meghazi wrote:

        > On Thu, Feb 28, 2013 at 3:37 PM, Kent <kent.yuan@...> wrote:
        >> I use FuzzyFinder for years. Recently I heard a lot about CtrlP. And
        >> gave it a try. It does have some good features over FF.
        >
        > Cool ! Just discovered CtrlP with this post and I like it, especially
        > the root path autodiscovery !
        >
        > I'd like to change the default behaviour of <cr> in CtrlP shell in
        > order to open in new tab instead of current window. I can't see an
        > option for that in ctrlp.txt. Is it possible ?

        Yes. Here's what you're asking for (put it in your .vimrc):

        let g:ctrlp_prompt_mappings = {
        \ 'AcceptSelection("t")': ['<cr>'],
        \ }

        See: :help 'g:ctrlp_prompt_mappings'

        --
        Best,
        Ben

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Fabien Meghazi
        ... I tried it without success. I tried it before and after pathogen#infect, also tried to enter the command manually but the files still open in current
        Message 3 of 9 , Mar 5, 2013
          On Tue, Mar 5, 2013 at 4:07 PM, Benjamin R. Haskell <vim@...> wrote:
          > Yes. Here's what you're asking for (put it in your .vimrc):
          >
          > let g:ctrlp_prompt_mappings = {
          > \ 'AcceptSelection("t")': ['<cr>'],
          > \ }

          I tried it without success. I tried it before and after
          pathogen#infect, also tried to enter the command manually but the
          files still open in current window.

          --
          Fabien Meghazi

          Website: http://www.amigrave.com
          Email: agr@...
          IM: amigrave@...

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Benjamin R. Haskell
          ... I forgot you also need to remove the binding from AcceptSelection( e ) (a default). You can either map something else to it (e.g. Ctrl-X): let
          Message 4 of 9 , Mar 5, 2013
            On Tue, 5 Mar 2013, Fabien Meghazi wrote:

            > On Tue, Mar 5, 2013 at 4:07 PM, Benjamin R. Haskell wrote:
            >> Yes. Here's what you're asking for (put it in your .vimrc):
            >>
            >> let g:ctrlp_prompt_mappings = {
            >> \ 'AcceptSelection("t")': ['<cr>'],
            >> \ }
            >
            > I tried it without success. I tried it before and after
            > pathogen#infect, also tried to enter the command manually but the
            > files still open in current window.

            I forgot you also need to remove the '<cr>' binding from
            'AcceptSelection("e")' (a default). You can either map something else
            to it (e.g. Ctrl-X):

            let g:ctrlp_prompt_mappings = {
            \ 'AcceptSelection("t")': ['<cr>'],
            \ 'AcceptSelection("e")': ['<c-x>'],
            \ }

            Or just remove it:

            let g:ctrlp_prompt_mappings = {
            \ 'AcceptSelection("t")': ['<cr>'],
            \ 'AcceptSelection("e")': [],
            \ }

            --
            Best,
            Ben

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Fabien Meghazi
            ... Thanks Benjamin, you made my day ! -- Fabien Meghazi Website: http://www.amigrave.com Email: agr@amigrave.com IM: amigrave@gmail.com -- -- You received
            Message 5 of 9 , Mar 5, 2013
              On Tue, Mar 5, 2013 at 4:59 PM, Benjamin R. Haskell <vim@...> wrote:
              > I forgot you also need to remove the '<cr>' binding from
              > 'AcceptSelection("e")' (a default). You can either map something else to it
              > (e.g. Ctrl-X):

              Thanks Benjamin, you made my day !


              --
              Fabien Meghazi

              Website: http://www.amigrave.com
              Email: agr@...
              IM: amigrave@...

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.