Loading ...
Sorry, an error occurred while loading the content.

Non-monospace fonts?

Expand Messages
  • Hakan YILDIZ
    When I use a non-monospace font in gvim, the characters are placed as if the font is monospaced. Is there anyway to force that non-monospace fonts are
    Message 1 of 3 , Feb 23, 2013
    • 0 Attachment
      When I use a non-monospace font in gvim, the characters are placed as if
      the font is monospaced. Is there anyway to force that non-monospace fonts
      are displayed correctly with different character widths?

      Thanks.

      Hakan Yildiz

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • John Little
      ... No, not without rewriting so much of vim it wouldn t be vim any more IMO. Regards, John Little -- -- You received this message from the vim_use maillist.
      Message 2 of 3 , Feb 23, 2013
      • 0 Attachment
        On Sunday, February 24, 2013 11:44:16 AM UTC+13, Hakan Yildiz wrote:

        > Is there anyway to force that non-monospace fonts
        > are displayed correctly with different character widths?

        No, not without rewriting so much of vim it wouldn't be vim any more IMO.

        Regards, John Little

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Tony Mechelynck
        ... Indeed. If you want your text to display with proportional text, justification on both sides, titles larger than the text, and what-not, don t use Vim, use
        Message 3 of 3 , Feb 24, 2013
        • 0 Attachment
          On 24/02/13 02:30, John Little wrote:
          > On Sunday, February 24, 2013 11:44:16 AM UTC+13, Hakan Yildiz wrote:
          >
          >> Is there anyway to force that non-monospace fonts
          >> are displayed correctly with different character widths?
          >
          > No, not without rewriting so much of vim it wouldn't be vim any more IMO.
          >
          > Regards, John Little
          >
          Indeed. If you want your text to display with proportional text,
          justification on both sides, titles larger than the text, and what-not,
          don't use Vim, use some WYSIWYG word processor such as LibreOffice
          Writer (or MS-Office Word).


          Best regards,
          Tony.
          --
          Lackland's Laws:
          (1) Never be first.
          (2) Never be last.
          (3) Never volunteer for anything

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.