Loading ...
Sorry, an error occurred while loading the content.

Re: Having trouble activating the matchit plugin

Expand Messages
  • Gary Johnson
    ... With Vim 7.3.646 on an Ubuntu Linux system, I went to a directory containing an HTML file and executed the following (one line). view -N -u NONE --cmd let
    Message 1 of 3 , Feb 23, 2013
    • 0 Attachment
      On 2013-02-22, cjsmall wrote:
      > [I am subscribed to this group and get daily posts. I tried to email
      > this post to vim@... (as the community page states) and it bounced
      > back without any specifically helpful info. What's wrong? Has the
      > email address changed to vim_use@... or could it be something
      > else? Thanks.]
      >
      > I'm using CSW build of vim 7.3 on a Solaris 10 SPARC system.
      >
      > I would like to use the matchit plugin that ships with vim. I read
      > the instructions, copied the matchit.txt and matchit.vim files from
      > the system macros directory to my ~/.vim/doc and ~/.vim/plugin
      > directories. I can read the matchit documentation with :help matchit,
      > but vim will not jump to matching HTML tags or C keywords using "%".
      > I have tried everything in the docs and have searched the internet for
      > advice. It appears that many other people have the same problem, but
      > none of the suggestions I found work for them or for me.
      >
      > Can anyone suggest what might be wrong? Thanks for any help you can
      > offer.

      With Vim 7.3.646 on an Ubuntu Linux system, I went to a directory
      containing an HTML file and executed the following (one line).

      view -N -u NONE --cmd 'let &rtp = $VIMRUNTIME' --cmd 'filetype plugin on' --cmd 'runtime macros/matchit.vim' index.html

      That used only the stock files that come with Vim. I could use % to
      jump between the beginning and ending <html>, <head>, <body> and all
      the other tags I tried, so the matchit plugin worked fine for me.

      Try that and see how it works. If it doesn't work, there is
      apparently something lacking in that version or installation of Vim.
      If it does work, then there is something wrong with the way you have
      tried to enable the matchit plugin.

      HTH,
      Gary

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • cjsmall
      ... Gary: I tried this and it works! I tried a few things and it turns out that what I was missing in my master .vimrc file was the: filetype indent on line.
      Message 2 of 3 , Feb 23, 2013
      • 0 Attachment
        On Saturday, February 23, 2013 10:55:04 AM UTC-8, Gary Johnson wrote:

        > view -N -u NONE --cmd 'let &rtp = $VIMRUNTIME' --cmd 'filetype plugin on' --cmd 'runtime macros/matchit.vim' index.html
        >
        > Try that and see how it works. If it doesn't work, there is

        Gary: I tried this and it works! I tried a few things and it turns out that what I was missing in my master .vimrc file was the:

        filetype indent on

        line. Without that, all the other things I was trying were of no use. Thanks for the very helpful suggestion. It's great to get this working. Now that I'm looking at the right section of the vim manual, I also got indent working too! :-)

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.