Loading ...
Sorry, an error occurred while loading the content.

Terminal Keycodes Sent To Vim

Expand Messages
  • Ümit Kablan
    Hi Vimmers, I have recently made a huge upgrade to my Arch Linux which caused the terminal (I use LXTermial or Sakura) send different keycodes than before.
    Message 1 of 1 , Feb 23 5:22 AM
    • 0 Attachment
      Hi Vimmers,

      I have recently made a huge upgrade to my Arch Linux which caused the
      terminal (I use LXTermial or Sakura) send different keycodes than
      before. i.e. doing <Ctrl-V><Left> I see ^[[1;3D]. Since I have a
      Xmodmap configuration to use AltGr-HJKL as arrow keys
      (https://github.com/umitkablan/vims/blob/master/Xmodmap) I can imagine
      that I am supposed to track the problem for my custom usage. But
      still, can you route me to the files that might be changed and result
      in that behaviour? My &term is screen-256color and I use it inside
      tmux (without tmux is not working as expected as well).

      In-Vim solutions like mapping
      noremap <Esc>[1;3C <Right>

      is secondary for me because I do not want that kind of dirt in my vimrc.


      --
      Ümit

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.