Loading ...
Sorry, an error occurred while loading the content.

Having trouble activating the matchit plugin

Expand Messages
  • cjsmall
    [I am subscribed to this group and get daily posts. I tried to email this post to vim@vim.org (as the community page states) and it bounced back without any
    Message 1 of 3 , Feb 22, 2013
    • 0 Attachment
      [I am subscribed to this group and get daily posts. I tried to email
      this post to vim@... (as the community page states) and it bounced
      back without any specifically helpful info. What's wrong? Has the
      email address changed to vim_use@... or could it be something
      else? Thanks.]

      I'm using CSW build of vim 7.3 on a Solaris 10 SPARC system.

      I would like to use the matchit plugin that ships with vim. I read
      the instructions, copied the matchit.txt and matchit.vim files from
      the system macros directory to my ~/.vim/doc and ~/.vim/plugin
      directories. I can read the matchit documentation with :help matchit,
      but vim will not jump to matching HTML tags or C keywords using "%".
      I have tried everything in the docs and have searched the internet for
      advice. It appears that many other people have the same problem, but
      none of the suggestions I found work for them or for me.

      Can anyone suggest what might be wrong? Thanks for any help you can
      offer.
      --
      Jeff

      Here is the build info:

      :ver
      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Nov 25 2010 14:37:23)
      Included patches: 1-55
      Compiled by dam@current9s
      Huge version with GTK2-GNOME GUI. Features included (+) or not (-):
      +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
      +cindent +clientserver +clipboard +cmdline_compl +cmdline_hist
      +cmdline_info +comments +conceal +cryptv +cscope +cursorbind
      +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags
      +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path
      +float +folding -footer +fork() +gettext -hangul_input +iconv
      +insert_expand +jumplist +keymap +langmap +libcall +linebreak
      +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname
      +mouse +mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm +mouse_netterm
      -mouse_sysmouse +mouse_xterm +multi_byte +multi_lang -mzscheme
      +netbeans_intg -osfiletype +path_extra -perl +persistent_undo
      +postscript +printer +profile -python -python3 +quickfix +reltime
      +rightleft -ruby +scrollbind +signs +smartindent -sniff +startuptime
      +statusline -sun_workshop +syntax +tag_binary +tag_old_static -
      tag_any_white -tcl +terminfo +termresponse +textobjects +title
      +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra
      +viminfo +vreplace +wildignore +wildmenu +windows +writebackup +X11 -
      xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/opt/csw/share/vim"
      f-b for $VIMRUNTIME: "/opt/csw/share/vim/vim73"
      Compilation: /opt/SUNWspro/bin/cc -c -I. -Iproto -DHAVE_CONFIG_H -
      DFEAT_GUI_GTK -D_REENTRANT -D_PTHREADS -D_POSIX_PTHREAD_SEMANTICS -
      DXTHREADS -DXUSE_MTSAFE_API -I/opt/csw/include/gtk-2.0 -I/opt/csw/lib/
      gtk-2.0/include -I/o pt/csw/include/atk-1.0 -I/opt/csw/include/cairo -
      I/opt/csw/include/pango-1.0 -I/opt/csw/include/glib-2.0 -I/opt/csw/lib/
      glib-2.0/include -I/opt/csw/include/pixman-1 -I/opt/csw/include/
      freetype2 -I/opt/csw/include -I/opt/csw/ include/libpng12 -DORBIT2=1
      -D_REENTRANT -D_PTHREADS -D_POSIX_PTHREAD_SEMANTICS -DXTHREADS -
      DXUSE_MTSAFE_API -I/opt/csw/include/libgnomeui-2.0 -I/opt/csw/include/
      libart-2.0 -I/opt/csw/include/gconf/2 -I/opt/csw/include/gno me-
      keyring-1 -I/opt/csw/include/libgnome-2.0 -I/opt/csw/include/
      libbonoboui-2.0 -I/opt/csw/include/libgnomecanvas-2.0 -I/opt/csw/
      include/gtk-2.0 -I/opt/csw/include/gnome-vfs-2.0 -I/opt/csw/lib/gnome-
      vfs-2.0/include -I/opt/cs w/include/orbit-2.0 -I/opt/csw/include/
      dbus-1.0 -I/opt/csw/lib/dbus-1.0/include -I/opt/csw/include/glib-2.0 -
      I/opt/csw/lib/glib-2.0/include -I/opt/csw/include -I/opt/csw/include/
      libbonobo-2.0 -I/opt/csw/include/bonobo-activa tion-2.0 -I/opt/csw/
      include/libxml2 -I/opt/csw/include/pango-1.0 -I/opt/csw/include/
      gail-1.0 -I/opt/csw/include/freetype2 -I/opt/csw/include/atk-1.0 -I/
      opt/csw/lib/gtk-2.0/include -I/opt/csw/include/cairo -I/opt/csw/
      include/ pixman-1 -I/opt/csw/include/libpng12 -I/opt/csw/include -
      xO3 -m32 -xarch=v8 -xnorunpath -I/usr/openwin/include Linking: /opt/
      SUNWspro/bin/cc -L/opt/csw/lib -L/usr/openwin/lib -m32 -xarch=v8 -
      norunpath -L/opt/csw/lib -o vim-x11 -L/opt/csw/lib -lgtk-x11-2.0 -
      lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -
      lpango cairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -
      lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lintl -L/
      opt/csw/lib -L/usr/openwin/lib -lgnomeui-2 -lbonoboui-2 -lgnomevfs-2
      -lgnomecanvas-2 -lgnome-2 -lp opt -lbonobo-2 -lbonobo-activation -
      lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -
      lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -
      lfreetype -lfontconfig -lgconf-2 -lgmodule-2.0 - lgobject-2.0 -
      lgthread-2.0 -lrt -lglib-2.0 -lintl -lXt -lX11 -lSM -lICE -lm -lnsl -
      lsocket -lncurses -liconv -lintl -ldl

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Gary Johnson
      ... With Vim 7.3.646 on an Ubuntu Linux system, I went to a directory containing an HTML file and executed the following (one line). view -N -u NONE --cmd let
      Message 2 of 3 , Feb 23, 2013
      • 0 Attachment
        On 2013-02-22, cjsmall wrote:
        > [I am subscribed to this group and get daily posts. I tried to email
        > this post to vim@... (as the community page states) and it bounced
        > back without any specifically helpful info. What's wrong? Has the
        > email address changed to vim_use@... or could it be something
        > else? Thanks.]
        >
        > I'm using CSW build of vim 7.3 on a Solaris 10 SPARC system.
        >
        > I would like to use the matchit plugin that ships with vim. I read
        > the instructions, copied the matchit.txt and matchit.vim files from
        > the system macros directory to my ~/.vim/doc and ~/.vim/plugin
        > directories. I can read the matchit documentation with :help matchit,
        > but vim will not jump to matching HTML tags or C keywords using "%".
        > I have tried everything in the docs and have searched the internet for
        > advice. It appears that many other people have the same problem, but
        > none of the suggestions I found work for them or for me.
        >
        > Can anyone suggest what might be wrong? Thanks for any help you can
        > offer.

        With Vim 7.3.646 on an Ubuntu Linux system, I went to a directory
        containing an HTML file and executed the following (one line).

        view -N -u NONE --cmd 'let &rtp = $VIMRUNTIME' --cmd 'filetype plugin on' --cmd 'runtime macros/matchit.vim' index.html

        That used only the stock files that come with Vim. I could use % to
        jump between the beginning and ending <html>, <head>, <body> and all
        the other tags I tried, so the matchit plugin worked fine for me.

        Try that and see how it works. If it doesn't work, there is
        apparently something lacking in that version or installation of Vim.
        If it does work, then there is something wrong with the way you have
        tried to enable the matchit plugin.

        HTH,
        Gary

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • cjsmall
        ... Gary: I tried this and it works! I tried a few things and it turns out that what I was missing in my master .vimrc file was the: filetype indent on line.
        Message 3 of 3 , Feb 23, 2013
        • 0 Attachment
          On Saturday, February 23, 2013 10:55:04 AM UTC-8, Gary Johnson wrote:

          > view -N -u NONE --cmd 'let &rtp = $VIMRUNTIME' --cmd 'filetype plugin on' --cmd 'runtime macros/matchit.vim' index.html
          >
          > Try that and see how it works. If it doesn't work, there is

          Gary: I tried this and it works! I tried a few things and it turns out that what I was missing in my master .vimrc file was the:

          filetype indent on

          line. Without that, all the other things I was trying were of no use. Thanks for the very helpful suggestion. It's great to get this working. Now that I'm looking at the right section of the vim manual, I also got indent working too! :-)

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.