Loading ...
Sorry, an error occurred while loading the content.

CTRL-W_= with quickfix window?

Expand Messages
  • Tim Chase
    Futzing around with the quickfix (QF) window, I found that using CTRL-W= ( make the windows the same size , :help CTRL-W_= ) ignores the quickfix window in
    Message 1 of 2 , Feb 21, 2013
    • 0 Attachment
      Futzing around with the quickfix (QF) window, I found that using
      CTRL-W= ("make the windows the same size", ":help CTRL-W_=") ignores
      the quickfix window in its size calculations. Is there some option I
      can set to just treat it like other windows? I wasn't able to turn up
      anything in my search.

      The aforementioned help says "Make all windows (almost) equally high
      and wide", and I'm not sure whether the parenthetical "almost" is
      supposed to apply to the "all" or the "equally". I can understand
      that, if it goes with "equally", that some may be one line
      larger/smaller than average to spread out the remainder when dividing
      the screen up. However that would suggest that the ^W= applies to
      *all* windows, not *almost all*.

      I just keep getting snagged when I maximize my edit window and it
      scrunches the QF window to one line, but I then have to manually
      re-increase the size of the QF window if I want to re-see context.

      -tim



      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Isn t this just because of winfixheight ? It gets set automatically for quickfix or preview window. You could probably make an autocmd to clear that
      Message 2 of 2 , Feb 21, 2013
      • 0 Attachment
        On Thursday, February 21, 2013 11:35:42 AM UTC-6, Tim Chase wrote:
        > Futzing around with the quickfix (QF) window, I found that using
        >
        > CTRL-W= ("make the windows the same size", ":help CTRL-W_=") ignores
        >
        > the quickfix window in its size calculations. Is there some option I
        >
        > can set to just treat it like other windows? I wasn't able to turn up
        >
        > anything in my search.
        >
        >
        >
        > The aforementioned help says "Make all windows (almost) equally high
        >
        > and wide", and I'm not sure whether the parenthetical "almost" is
        >
        > supposed to apply to the "all" or the "equally". I can understand
        >
        > that, if it goes with "equally", that some may be one line
        >
        > larger/smaller than average to spread out the remainder when dividing
        >
        > the screen up. However that would suggest that the ^W= applies to
        >
        > *all* windows, not *almost all*.
        >
        >
        >
        > I just keep getting snagged when I maximize my edit window and it
        >
        > scrunches the QF window to one line, but I then have to manually
        >
        > re-increase the size of the QF window if I want to re-see context.
        >
        >
        >
        > -tim

        Isn't this just because of 'winfixheight'? It gets set automatically for quickfix or preview window. You could probably make an autocmd to clear that option.

        Or just close your quickfix when you're not looking at it, and then re-open it.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.