Loading ...
Sorry, an error occurred while loading the content.

Re: Help regarding netrw, sorry if this is not the right way to ask for help.

Expand Messages
  • Charles E Campbell
    ... You can also try two commands provided by netrw: gf : treat string under cursor as a file s name gd: treat string under cursor as a directory s name Netrw
    Message 1 of 2 , Feb 20, 2013
    • 0 Attachment
      Manas K wrote:
      > Hello Dr.Chip!
      >
      > I tried out that version to the same effect. I did post earlier on the
      > vim mailing list and a gentleman (Tony) confirmed my suspicion that
      > once a directory was opened by using the direct path, any other
      > directory I further try to navigate will need to have a "/" after it,
      > which somehow sub-directories don't show.
      >
      You can also try two commands provided by netrw:

      gf : treat string under cursor as a file's name
      gd: treat string under cursor as a directory's name

      Netrw has a variable that may help you:

      g:netrw_ftp_list_cmd

      See :help g:netrw_ftp_list_cmd . The point is: netrw expects the
      listing delivered by ftp to include the name followed by "/" in the case
      of directories. Try using ftp directly; does

      ls -lF

      show directories with trailing slashes? It could either be the site
      that's causing trouble, your ftp doesn't pass along options, etc. If you
      find some magic option that gets those slashes, modify the variable.

      Regards,
      C Campbell

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... ah, interesting: thanks Dr. Chip. With my version of ftp (which may or may not act like the OP s one), ls gives a long listing without directory slashes,
      Message 2 of 2 , Feb 22, 2013
      • 0 Attachment
        On 21/02/13 06:22, Charles E Campbell wrote:
        > Manas K wrote:
        >> Hello Dr.Chip!
        >>
        >> I tried out that version to the same effect. I did post earlier on the
        >> vim mailing list and a gentleman (Tony) confirmed my suspicion that
        >> once a directory was opened by using the direct path, any other
        >> directory I further try to navigate will need to have a "/" after it,
        >> which somehow sub-directories don't show.
        >>
        > You can also try two commands provided by netrw:
        >
        > gf : treat string under cursor as a file's name
        > gd: treat string under cursor as a directory's name
        >
        > Netrw has a variable that may help you:
        >
        > g:netrw_ftp_list_cmd
        >
        > See :help g:netrw_ftp_list_cmd . The point is: netrw expects the
        > listing delivered by ftp to include the name followed by "/" in the case
        > of directories. Try using ftp directly; does
        >
        > ls -lF
        >
        > show directories with trailing slashes? It could either be the site
        > that's causing trouble, your ftp doesn't pass along options, etc. If you
        > find some magic option that gets those slashes, modify the variable.
        >
        > Regards,
        > C Campbell
        >

        ah, interesting: thanks Dr. Chip.

        With my version of ftp (which may or may not act like the OP's one),
        "ls" gives a long listing without directory slashes, but "ls -lF"
        outputs the same listing with the slashes. Thanks!

        Best regards,
        Tony.
        --
        "Let me assure you that to us here at First National, you're not just a
        number. You're two numbers, a dash, three more numbers, another dash
        and another number."
        -- James Estes

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.