Loading ...
Sorry, an error occurred while loading the content.

Re: wide letter spacing when using gvim (GUI mode)

Expand Messages
  • Alex Dong Li
    I think Tony has got the point: Monospace on my system is a proportional font, not a width-fixed font. Sorry for my wrong assumption! As matter of the fact, I
    Message 1 of 12 , Feb 20, 2013
    • 0 Attachment
      I think Tony has got the point: Monospace on my system is a proportional font, not a width-fixed font. Sorry for my wrong assumption! As matter of the fact, I do not have any width-fixed fonts available to gvim.

      Thank everyone who has helped very much! Also sorry for sending file attachments to everyone!

      Alex.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • John Little
      ... You don t need root access to install a font for your own use. - Download a .ttf or .otf to wherever. - With KDE, open it with kfontviewer, click install,
      Message 2 of 12 , Feb 20, 2013
      • 0 Attachment
        On Thursday, February 21, 2013 9:21:54 AM UTC+13, alexdongli wrote:
        > I wishes I had the root access to our company linux servers so that I could >compile vim with multi-byte disabled. Too many libraries/headers are missing >for me to compile gvim myself.

        You don't need root access to install a font for your own use.
        - Download a .ttf or .otf to wherever.
        - With KDE, open it with kfontviewer, click install, click personal.
        - With Gnome3, I think nautilus has support. Gnome 2 had gnome-font-viewer.

        This just copies the font file to .fonts in your home directory, in a directory whose name is the first letter of the font file name. I just downloaded monofur.ttf, and copied it to ~/.fonts/m, and gvim found it without further ado. (Unpleasant font, IMO).

        Regards, John Little

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.