Loading ...
Sorry, an error occurred while loading the content.

Copying text from wikipedia yields: lots of ???

Expand Messages
  • Daniel M. Eldridge
    Pasting text from a wikipedia articles leaves me with lots of ???? [image: Inline image 2] ... That s the fist five lines of the languages in which there s a
    Message 1 of 9 , Feb 18, 2013
    • 0 Attachment
      Pasting text from a wikipedia articles leaves me with lots of ????
      Inline image 2

      For example:
      Afrikaans
      ???????
      Az?rbaycanca
      ?????????
      Boarisch


      That's the fist five lines of the languages in which there's a Vim article--as seen from the English language article:

      here's a (partial) screenshot:
      Inline image 2

      What do I need to set so that Vim will display what I now see in Notepad:
      Inline image 3

      and stop showing me Question Marks???
      Inline image 1

      I'm running Vim 7.3 on Win7-64 bit:
      Inline image 3


      thank-you in advance,
      --Dan

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • John Beckett
      ... I haven t looked at your images, but the problem is very likely to be due to use of an incorrect encoding. The first two lines in your vimrc should be: set
      Message 2 of 9 , Feb 18, 2013
      • 0 Attachment
        Daniel M. Eldridge wrote:
        > Pasting text from a wikipedia articles leaves me with lots of
        > ????

        I haven't looked at your images, but the problem is very likely
        to be due to use of an incorrect encoding. The first two lines
        in your vimrc should be:

        set nocompatible
        set encoding=utf-8

        Saying "should be" is a bit of an over-generalisation, but it is
        sufficiently accurate for most cases. Does the problem still
        occur after restarting Vim with the above?

        John

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Daniel M. Eldridge
        Humm...I was missing the encoding=utf-8 line but now--so now problem has not been solved. Now, instead of ???? marks I get solid blocks--the size of a
        Message 3 of 9 , Feb 18, 2013
        • 0 Attachment
          Humm...I was missing the encoding=utf-8 line
          but now--so now problem has not been solved.

          Now, instead of ???? marks I get solid blocks--the size of a character.

          I think this is the right track, but I'm clueless as the proper settings.
          awaiting instructions,

          --Dan

          On Mon, Feb 18, 2013 at 8:37 PM, John Beckett <johnb.beckett@...> wrote:
          Daniel M. Eldridge wrote:
          > Pasting text from a wikipedia articles leaves me with lots of
          > ????

          I haven't looked at your images, but the problem is very likely
          to be due to use of an incorrect encoding. The first two lines
          in your vimrc should be:

          set nocompatible
          set encoding=utf-8

          Saying "should be" is a bit of an over-generalisation, but it is
          sufficiently accurate for most cases. Does the problem still
          occur after restarting Vim with the above?

          John

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.



          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • John Little
          On Tuesday, February 19, 2013 2:55:34 PM UTC+13, Daniel M. Eldridge wrote: Please don t top-post. ... That means your font doesn t have the character. Vim
          Message 4 of 9 , Feb 18, 2013
          • 0 Attachment
            On Tuesday, February 19, 2013 2:55:34 PM UTC+13, Daniel M. Eldridge wrote:

            Please don't top-post.

            > Now, instead of ???? marks I get solid blocks--the size of a character.

            That means your font doesn't have the character. Vim doesn't cast about looking for any font that has a glyph, like browsers will. Try another font; click Edit on the menu bar, -> Select Font, or

            :set guifont=*

            http://vim.wikia.com/wiki/The_perfect_programming_font might be a place to start looking if you don't have a good one already.

            BTW, 7.3.46 is quite old now, ~2006. You can get a much more recent vim for windows from http://cream.sourceforge.net/download.html.

            Regards, John Little

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • John Beckett
            ... You need a font which supports the characters you are looking at. DejaVu Sans Mono is an example of a great and free font:
            Message 5 of 9 , Feb 18, 2013
            • 0 Attachment
              Daniel M. Eldridge wrote:
              > Humm...I was missing the encoding=utf-8 line but now--so now
              > problem has not been solved.
              >
              > Now, instead of ???? marks I get solid blocks--the size of a
              > character.

              You need a font which supports the characters you are looking at.

              DejaVu Sans Mono is an example of a great and free font:
              http://dejavu-fonts.org/wiki/Main_Page

              There will still be lots of characters that are not supported by
              a particular font.

              Put the cursor on one of the solid-block characters and type ga
              to see its hex (and decimal) code. You can also type g8 to see
              the bytes used to represent that character in UTF-8. There will
              be a page somewhere with a list of typical Unicode characters
              and their hex codes, and you can copy/paste some into Vim to
              confirm that you are getting the text, and that your problem is
              therefore the font.

              John

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Christian Brabandt
              Hi John! ... 7.3 was released in Summer 2010, IIRC regards, Christian -- Der Weise sagt niemals, was er tut - aber er tut niemals etwas, was er nicht sagen
              Message 6 of 9 , Feb 19, 2013
              • 0 Attachment
                Hi John!

                On Mo, 18 Feb 2013, John Little wrote:

                > BTW, 7.3.46 is quite old now, ~2006. You can get a much more recent vim for windows from http://cream.sourceforge.net/download.html.

                7.3 was released in Summer 2010, IIRC

                regards,
                Christian
                --
                Der Weise sagt niemals, was er tut - aber er tut niemals etwas, was
                er nicht sagen könnte.
                -- Jean-Paul Sartre

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Daniel M. Eldridge
                ... I ve found a number of fonts that have increased coverage--more characters, but I m confused about how to display more fonts in Edit | Select Font... --Dan
                Message 7 of 9 , Feb 19, 2013
                • 0 Attachment
                  On Mon, Feb 18, 2013 at 9:26 PM, John Little <John.B.Little@...> wrote:
                  On Tuesday, February 19, 2013 2:55:34 PM UTC+13, Daniel M. Eldridge wrote:

                  Please don't top-post.

                  > Now, instead of ???? marks I get solid blocks--the size of a character.

                  That means your font doesn't have the character.  Vim doesn't cast about looking for any font that has a glyph, like browsers will.  Try another font; click Edit on the menu bar, -> Select Font, or

                  :set guifont=*

                  http://vim.wikia.com/wiki/The_perfect_programming_font might be a place to start looking if you don't have a good one already.

                  BTW, 7.3.46 is quite old now, ~2006.  You can get a much more recent vim for windows from  http://cream.sourceforge.net/download.html.

                  Regards, John Little

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.


                  Thank-you John.
                  I've found a number of fonts that have increased coverage--more characters, but I'm confused about how to display more fonts in Edit | Select Font...

                  --Dan

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                   
                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                   
                   
                • Ben Fritz
                  ... Vim should display all *monospace* fonts currently installed on your system in this menu. If the fonts you found are not monospace, Vim will not show them.
                  Message 8 of 9 , Feb 19, 2013
                  • 0 Attachment
                    On Tuesday, February 19, 2013 2:06:07 PM UTC-6, Daniel M. Eldridge wrote:
                    >
                    >
                    > Thank-you John.
                    > I've found a number of fonts that have increased coverage--more characters, but I'm confused about how to display more fonts in Edit | Select Font...
                    >
                    >

                    Vim should display all *monospace* fonts currently installed on your system in this menu.

                    If the fonts you found are not monospace, Vim will not show them.

                    If they are monospace...did you install them by copying their files to C:\Windows\Fonts or wherever that folder is?

                    Note: see http://vim.wikia.com/wiki/Change_font for useful related information.

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Daniel M. Eldridge
                    ... and clicking on Show more fonts displays Control Panel All Control Panel Items Fonts and in Details view I can choose to display a bunch of attributes,
                    Message 9 of 9 , Feb 19, 2013
                    • 0 Attachment
                      On Tue, Feb 19, 2013 at 3:23 PM, Ben Fritz <fritzophrenic@...> wrote:
                      On Tuesday, February 19, 2013 2:06:07 PM UTC-6, Daniel M. Eldridge wrote:
                      >
                      >
                      > Thank-you John.
                      > I've found a number of fonts that have increased coverage--more characters, but I'm confused about how to display more fonts in Edit | Select Font...
                      >
                      >

                      Vim should display all *monospace* fonts currently installed on your system in this menu.

                      If the fonts you found are not monospace, Vim will not show them.

                      If they are monospace...did you install them by copying their files to C:\Windows\Fonts or wherever that folder is?

                      Note: see http://vim.wikia.com/wiki/Change_font for useful related information.

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.


                      Aha. Got it!
                      and clicking on "Show more fonts" displays Control Panel\All Control Panel Items\Fonts
                      and in Details view I can choose to display a bunch of attributes, however, NOT ONE OF 'em is Mono Space or Variable Space!
                      Argh.

                      Courier_New has lots of coverage, though it does not display all of the characters from the languages section of the Jeremy Lin article:

                      but, then neither does my browser:
                      Inline image 1

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                       
                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                       
                       
                    Your message has been successfully submitted and would be delivered to recipients shortly.