Loading ...
Sorry, an error occurred while loading the content.

Re: Vim :: How To Disable Swap File for FileType

Expand Messages
  • Ben Fritz
    ... Please bottom-post. ... This should tell you what the current filetype is and in which script it was set. Vim by default includes this to detect the text
    Message 1 of 4 , Feb 11, 2013
    • 0 Attachment
      On Saturday, February 9, 2013 9:43:13 PM UTC-6, edw...@... wrote:
      > I change _vimrc to filetype text  as a test I.E. set ft=text and the swap file was still being created … However, I disabled my plugins and the autocmd worked … I’m of the impression there’s a conflict with subsequent filetype settings …
      >  
      > As such I decided on an alternative :: Saving the swaps into a dedicated directory …
      >  
      > IE. set dir=$HOME/_vimswap//,%TEMP%//,/%TMP%//,.
      >  
      > That will work for me …
      >  
      > Thanks Benjamin
      >  

      Please bottom-post.

      If you suspect further filetype settings are interfering, it's easy enough to figure out where it's being set:

      :verbose set filetype?

      This should tell you what the current filetype is and in which script it was set.

      Vim by default includes this to detect the "text" filetype:

      au BufNewFile,BufRead *.txt,*.text setf text

      What file extension is your text file? Do you have any filetype detection rules to make Vim detect it as such?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.