Loading ...
Sorry, an error occurred while loading the content.
 

Text formatting and special treatment of particular words

Expand Messages
  • Marco
    Hi, when reformatting a text paragraph with gwip it causes some words to be treated special. Example: Lorem ipsum dolor sit amet, consetetur sadipscing elitr,
    Message 1 of 3 , Feb 11, 2013
      Hi,

      when reformatting a text paragraph with gwip it causes some words to
      be treated special. Example:


      Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumydiam for tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.

      Formatting the paragraph with “gwip” results in

      Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumydiam
      for tempor invidunt ut labore et dolore magna aliquyam erat, sed diam
      voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet
      clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit
      amet.

      This makes sense for programming, but not for plain text. Filetype
      is not set BTW. I assumed that some of the formatoptions were
      responsible for the recognition of the keywords so I removed all
      formatoptions yielding the same result as described.

      How can I control this behaviour and remove special treatment of
      particular words?

      Marco
    • Paul Isambert
      ... I guess set nocindent is what you re looking for ( cindent indents after keywords). Best, Paul -- -- You received this message from the vim_use
      Message 2 of 3 , Feb 11, 2013
        Selon Marco <netuse@...>:

        > Hi,
        >
        > when reformatting a text paragraph with gwip it causes some words to
        > be treated special. Example:
        >
        >
        > Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumydiam
        > for tempor invidunt ut labore et dolore magna aliquyam erat, sed diam
        > voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita
        > kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.
        >
        > Formatting the paragraph with â gwipâ results in
        >
        > Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumydiam
        > for tempor invidunt ut labore et dolore magna aliquyam erat, sed diam
        > voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet
        > clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit
        > amet.
        >
        > This makes sense for programming, but not for plain text. Filetype
        > is not set BTW. I assumed that some of the formatoptions were
        > responsible for the recognition of the keywords so I removed all
        > formatoptions yielding the same result as described.
        >
        > How can I control this behaviour and remove special treatment of
        > particular words?

        I guess "set nocindent" is what you're looking for ("cindent" indents after
        keywords).

        Best,
        Paul


        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Marco
        ... That was a nudge in the right direction. I disabled “smartindent” for text files and it works fine. Thanks. Marco
        Message 3 of 3 , Feb 11, 2013
          On 2013–02–11 Paul Isambert wrote:

          > I guess "set nocindent" is what you're looking for ("cindent" indents after
          > keywords).

          That was a nudge in the right direction. I disabled “smartindent”
          for text files and it works fine. Thanks.

          Marco
        Your message has been successfully submitted and would be delivered to recipients shortly.