Loading ...
Sorry, an error occurred while loading the content.

RE: Visual Mode Selection in Windows 7

Expand Messages
  • John Beckett
    ... Please delete excessive text when replying. Don t quote a chain of previous messages, and make sure to delete email addresses. David Fishburn mentioned the
    Message 1 of 7 , Feb 8, 2013
    • 0 Attachment
      Roy Fulbright wrote:
      > I tried hjkl, but they lose the selection the same as
      > the arrow keys.

      Please delete excessive text when replying. Don't quote a chain
      of previous messages, and make sure to delete email addresses.

      David Fishburn mentioned the two alternatives:
      (1) Press v then move cursor for character selection.
      (2) Press Ctrl-V (or Ctrl-Q if Ctrl-V used for paste)
      then move cursor for block selection.

      A third alternative is to press V for line selection.

      Like most regulars here I fixed up my vimrc file years ago and
      have forgotten exactly what a default Windows install does. The
      problem of the selection being lost when moving the cursor is
      probably due to settings in vimrc that make Vim's selection work
      like Notepad (and other Windows apps). In Notepad, moving the
      cursor without holding down Shift removes the selection.

      These are the problem lines:

      source $VIMRUNTIME/mswin.vim
      behave mswin

      John

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.