Loading ...
Sorry, an error occurred while loading the content.

RE: Visual Mode Selection in Windows 7

Expand Messages
  • Roy Fulbright
    Date: Fri, 8 Feb 2013 11:01:19 -0800 Subject: Re: Visual Mode Selection in Windows 7 From: cfcollision@gmail.com To: vim_use@googlegroups.com On Fri, Feb 8,
    Message 1 of 7 , Feb 8, 2013
    • 0 Attachment

       

      Date: Fri, 8 Feb 2013 11:01:19 -0800
      Subject: Re: Visual Mode Selection in Windows 7
      From: cfcollision@...
      To: vim_use@...




      On Fri, Feb 8, 2013 at 10:56 AM, Dan Wierenga <dwierenga@...> wrote:


      On Fri, Feb 8, 2013 at 10:19 AM, Roy Fulbright <rfulbrig@...> wrote:
       I am using gvim 7.3 on Windows 7. I need to select the four x's in the following sample text. I positioned the cursor on the upper left 'x', then typed 'v' to enter visual mode. So far so good, but when I move the cursor to the lower right 'x' I lose the selection. How do I designate the selection area in visual mode?

      When I use the arrows keys on Windows 7, I lose the selection.   However, hjkl works just fine.  I've never really bothered to figure out why, I just use it as a little reminder to keep my hand away from the arrow keys. :D

      HTH,
      Dan
       
       
      I tried hjkl, but they lose the selection the same as the arrow keys.
       

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • John Beckett
      ... Please delete excessive text when replying. Don t quote a chain of previous messages, and make sure to delete email addresses. David Fishburn mentioned the
      Message 2 of 7 , Feb 8, 2013
      • 0 Attachment
        Roy Fulbright wrote:
        > I tried hjkl, but they lose the selection the same as
        > the arrow keys.

        Please delete excessive text when replying. Don't quote a chain
        of previous messages, and make sure to delete email addresses.

        David Fishburn mentioned the two alternatives:
        (1) Press v then move cursor for character selection.
        (2) Press Ctrl-V (or Ctrl-Q if Ctrl-V used for paste)
        then move cursor for block selection.

        A third alternative is to press V for line selection.

        Like most regulars here I fixed up my vimrc file years ago and
        have forgotten exactly what a default Windows install does. The
        problem of the selection being lost when moving the cursor is
        probably due to settings in vimrc that make Vim's selection work
        like Notepad (and other Windows apps). In Notepad, moving the
        cursor without holding down Shift removes the selection.

        These are the problem lines:

        source $VIMRUNTIME/mswin.vim
        behave mswin

        John

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.