Loading ...
Sorry, an error occurred while loading the content.
 

Mapping control+j not working

Expand Messages
  • Juanmi
    Hey I have this mapping for easy navigation on windows map h map
    Message 1 of 3 , Feb 5, 2013
      Hey I have this mapping for easy navigation on windows
      map <C-h> <C-w>h map <C-j> <C-w>j map <C-k> <C-w>k map <C-l> <C-w>l
      and control+h, control+k, control+l works fine and smooth. But when I press control+j instead of moving the bottom windows it goes to insert mode. If I press control+w then j it works correctly.
      Could you provide some advices?
      Thanks.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Juanmi
      ... BTW you can check vimrc here: https://github.com/bodypheo/vim-config/blob/master/vimrc -- -- You received this message from the vim_use maillist. Do not
      Message 2 of 3 , Feb 5, 2013
        El martes, 5 de febrero de 2013 15:36:10 UTC+1, Juanmi escribió:
        > Hey I have this mapping for easy navigation on windows
        > map <C-h> <C-w>h map <C-j> <C-w>j map <C-k> <C-w>k map <C-l> <C-w>l
        > and control+h, control+k, control+l works fine and smooth. But when I press control+j instead of moving the bottom windows it goes to insert mode. If I press control+w then j it works correctly.
        > Could you provide some advices?
        > Thanks.

        BTW you can check vimrc here: https://github.com/bodypheo/vim-config/blob/master/vimrc

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • vim@...
        ... A couple things occur to me. First, all four work for me if I use nnoremap rather than map . So, while I don t see a mapping in there for either
        Message 3 of 3 , Feb 5, 2013
          On Tue, 5 Feb 2013 06:38:23 -0800 (PST), Juanmi wrote:
          > El martes, 5 de febrero de 2013 15:36:10 UTC+1, Juanmi escribió:
          > > Hey I have this mapping for easy navigation on windows
          > > map <C-h> <C-w>h
          > > map <C-j> <C-w>j
          > > map <C-k> <C-w>k
          > > map <C-l> <C-w>l
          > and control+h, control+k, control+l works fine
          > and smooth. But when I press control+j instead of moving the
          > bottom windows it goes to insert mode. If I press control+w then
          > j it works correctly. Could you provide some advices? Thanks.
          >
          > BTW you can check vimrc here:
          > https://github.com/bodypheo/vim-config/blob/master/vimrc

          A couple things occur to me. First, all four work for me if I use
          "nnoremap" rather than "map". So, while I don't see a mapping in
          there for either straight <c-w> or "l" which would trigger an odd
          mapping, it doesn't preclude it.

          Additionally, I find the native behavior of <C-L> (redrawing the
          screen) quite useful. You're welcome to tromp that, but I'd suggest
          using Alt+{h/j/k/l} instead of Control to allow you to keep the
          existing functionality.

          -tim


          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.