Loading ...
Sorry, an error occurred while loading the content.

Omnicomplete shows strange behavior when preview window is enabled

Expand Messages
  • Benjamin Isbarn
    Hi, I m currently investing some time learning vim and setting my .vimrc up. Doing so I ve come across a problem I couldn t solve myself. I m using the
    Message 1 of 21 , Feb 3, 2013
    • 0 Attachment
      Hi,

      I'm currently investing some time learning vim and setting my .vimrc up. Doing
      so I've come across a problem I couldn't solve myself. I'm using the
      AutoComplPop Plugin so that the Omnicomplete "Window" pops up automatically. I
      also enabled the Preview Window through this command in my .vimrc

      let g:acp_completeoptPreview = 1

      But everytime the preview window pops up the Omnicomplete popup vanishes, In
      large lists I am able to see the last entries in the status line. Even more
      strange when i navigate in the invisible list an reach the " " entry alias
      "Back at original" the whole list pops up and is visible.

      I allready changed the cholorscheme and switched to gvim but the error stays
      the same.

      I attached my .vimrc, I hope someone knows what the problem is.

      Regards

      Benjamin Isbarn

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Unfortunately the misbehavior of the completion menu in the presence of folds is a known unfixed bug. ... popup completion menu closes quickly when there
      Message 2 of 21 , Feb 4, 2013
      • 0 Attachment
        On Sunday, February 3, 2013 11:01:43 AM UTC-6, Benjamin Isbarn wrote:
        > Hi,
        >
        >
        >
        > I'm currently investing some time learning vim and setting my .vimrc up. Doing
        >
        > so I've come across a problem I couldn't solve myself. I'm using the
        >
        > AutoComplPop Plugin so that the Omnicomplete "Window" pops up automatically. I
        >
        > also enabled the Preview Window through this command in my .vimrc
        >
        >
        >
        > let g:acp_completeoptPreview = 1
        >
        >
        >
        > But everytime the preview window pops up the Omnicomplete popup vanishes, In
        >
        > large lists I am able to see the last entries in the status line. Even more
        >
        > strange when i navigate in the invisible list an reach the " " entry alias
        >
        > "Back at original" the whole list pops up and is visible.
        >
        >
        >
        > I allready changed the cholorscheme and switched to gvim but the error stays
        >
        > the same.
        >
        >
        >
        > I attached my .vimrc, I hope someone knows what the problem is.
        >
        >
        >
        > Regards
        >
        >
        >
        > Benjamin Isbarn

        Unfortunately the misbehavior of the completion menu in the presence of folds is a known unfixed bug.

        :help todo shows:

        popup completion menu closes quickly when there is a fold in the buffer. (Jan
        Christoph Ebersbach, 2011 Jul 3)

        And also:

        Completion menu disappears when using 'cursorcolumn'. (Sven-Hendrik Haase,
        2011 May 23)


        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Benjamin Isbarn
        ... Removing set cursorcolumn from my .vimrc solved this issue. Guess I have to watch the changelogs for some updates on this bug. Anyway thank you for the
        Message 3 of 21 , Feb 5, 2013
        • 0 Attachment
          On Monday, February 04, 2013 08:00:15 AM you wrote:
          > Unfortunately the misbehavior of the completion menu in the presence of
          > folds is a known unfixed bug.
          > :help todo shows:
          > popup completion menu closes quickly when there is a fold in the buffer.
          > (Jan Christoph Ebersbach, 2011 Jul 3)
          >
          > And also:
          >
          > Completion menu disappears when using 'cursorcolumn'. (Sven-Hendrik Haase,
          > 2011 May 23)

          Removing 'set cursorcolumn' from my .vimrc solved this issue. Guess I have to
          watch the changelogs for some updates on this bug. Anyway thank you for the
          quick awnser, also the command ':help todo' is handy, still got a bunch of
          thinks to learn :)

          Best regards

          Benjamin Isbarn

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          ... Can someone show me how to reproduce this issue? I have seen this issue in the todo list, but so far, whenever I tried it, I couldn t reproduce it. I am
          Message 4 of 21 , Feb 5, 2013
          • 0 Attachment
            On Mon, February 4, 2013 17:00, Ben Fritz wrote:
            > On Sunday, February 3, 2013 11:01:43 AM UTC-6, Benjamin Isbarn wrote:
            >> Hi,
            >>
            >>
            >>
            >> I'm currently investing some time learning vim and setting my .vimrc up.
            >> Doing
            >>
            >> so I've come across a problem I couldn't solve myself. I'm using the
            >>
            >> AutoComplPop Plugin so that the Omnicomplete "Window" pops up
            >> automatically. I
            >>
            >> also enabled the Preview Window through this command in my .vimrc
            >>
            >>
            >>
            >> let g:acp_completeoptPreview = 1
            >>
            >>
            >>
            >> But everytime the preview window pops up the Omnicomplete popup
            >> vanishes, In
            >>
            >> large lists I am able to see the last entries in the status line. Even
            >> more
            >>
            >> strange when i navigate in the invisible list an reach the " " entry
            >> alias
            >>
            >> "Back at original" the whole list pops up and is visible.
            >>
            >>
            >>
            >> I allready changed the cholorscheme and switched to gvim but the error
            >> stays
            >>
            >> the same.
            >>
            >>
            >>
            >> I attached my .vimrc, I hope someone knows what the problem is.
            >>
            >>
            >>
            >> Regards
            >>
            >>
            >>
            >> Benjamin Isbarn
            >
            > Unfortunately the misbehavior of the completion menu in the presence of
            > folds is a known unfixed bug.
            >
            > :help todo shows:
            >
            > popup completion menu closes quickly when there is a fold in the buffer.
            > (Jan
            > Christoph Ebersbach, 2011 Jul 3)
            >
            > And also:
            >
            > Completion menu disappears when using 'cursorcolumn'. (Sven-Hendrik Haase,
            > 2011 May 23)

            Can someone show me how to reproduce this issue? I have seen this issue
            in the todo list, but so far, whenever I tried it, I couldn't reproduce
            it. I am probably doing something wrong here.

            regards,
            Christian

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Ben Fritz
            ... I just tried reproducing using various minimal configurations based off the default Windows installed Vim and foldmethod=syntax on a C file but failed.
            Message 5 of 21 , Feb 5, 2013
            • 0 Attachment
              On Tuesday, February 5, 2013 2:46:51 AM UTC-6, Christian Brabandt wrote:
              > On Mon, February 4, 2013 17:00, Ben Fritz wrote:
              >
              > > On Sunday, February 3, 2013 11:01:43 AM UTC-6, Benjamin Isbarn wrote:
              >
              > >> Hi,
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> I'm currently investing some time learning vim and setting my .vimrc up.
              >
              > >> Doing
              >
              > >>
              >
              > >> so I've come across a problem I couldn't solve myself. I'm using the
              >
              > >>
              >
              > >> AutoComplPop Plugin so that the Omnicomplete "Window" pops up
              >
              > >> automatically. I
              >
              > >>
              >
              > >> also enabled the Preview Window through this command in my .vimrc
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> let g:acp_completeoptPreview = 1
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> But everytime the preview window pops up the Omnicomplete popup
              >
              > >> vanishes, In
              >
              > >>
              >
              > >> large lists I am able to see the last entries in the status line. Even
              >
              > >> more
              >
              > >>
              >
              > >> strange when i navigate in the invisible list an reach the " " entry
              >
              > >> alias
              >
              > >>
              >
              > >> "Back at original" the whole list pops up and is visible.
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> I allready changed the cholorscheme and switched to gvim but the error
              >
              > >> stays
              >
              > >>
              >
              > >> the same.
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> I attached my .vimrc, I hope someone knows what the problem is.
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> Regards
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> Benjamin Isbarn
              >
              > >
              >
              > > Unfortunately the misbehavior of the completion menu in the presence of
              >
              > > folds is a known unfixed bug.
              >
              > >
              >
              > > :help todo shows:
              >
              > >
              >
              > > popup completion menu closes quickly when there is a fold in the buffer.
              >
              > > (Jan
              >
              > > Christoph Ebersbach, 2011 Jul 3)
              >
              > >
              >
              > > And also:
              >
              > >
              >
              > > Completion menu disappears when using 'cursorcolumn'. (Sven-Hendrik Haase,
              >
              > > 2011 May 23)
              >
              >
              >
              > Can someone show me how to reproduce this issue? I have seen this issue
              >
              > in the todo list, but so far, whenever I tried it, I couldn't reproduce
              >
              > it. I am probably doing something wrong here.
              >
              >
              >

              I just tried reproducing using various minimal configurations based off the default Windows installed Vim and foldmethod=syntax on a C file but failed.

              This is annoying because it affects me every day on my normal Vim config. So, I expect some autocmd or mapping is interfering in some way.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Benjamin Isbarn
              ... Guess you could use my .vimrc which was attached to the initial post, but i ll attach it to this message as well. It s a really minimal config, so i hope
              Message 6 of 21 , Feb 5, 2013
              • 0 Attachment
                On Tuesday, February 05, 2013 09:46:51 AM Christian Brabandt wrote:
                > Can someone show me how to reproduce this issue? I have seen this issue
                > in the todo list, but so far, whenever I tried it, I couldn't reproduce
                > it. I am probably doing something wrong here.
                >
                > regards,
                > Christian

                Guess you could use my .vimrc which was attached to the initial post, but i'll
                attach it to this message as well. It's a really minimal config, so i hope
                you're able to reproduce this issue. I had this issue with the same .vimrc and
                the same plugins on 3 machines.

                Regards

                Benjamin Isbarn

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Christian Brabandt
                Hi Benjamin! ... I actually thought of something more light-weight which does not require installing various plugins. Mit freundlichen Grüßen Christian --
                Message 7 of 21 , Feb 5, 2013
                • 0 Attachment
                  Hi Benjamin!

                  On Di, 05 Feb 2013, Benjamin Isbarn wrote:

                  > Guess you could use my .vimrc which was attached to the initial post, but i'll
                  > attach it to this message as well. It's a really minimal config, so i hope
                  > you're able to reproduce this issue. I had this issue with the same .vimrc and
                  > the same plugins on 3 machines.

                  I actually thought of something more light-weight which does not require
                  installing various plugins.


                  Mit freundlichen Grüßen
                  Christian
                  --
                  Gehen dem Menschen Hühner und Hunde verloren, so weiß er, wo er sie
                  suchen soll. Geht ihm sein Herz verloren, so weiß er nicht, wo er es
                  suchen soll.
                  -- Meng-Tzu

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Christian Brabandt
                  Hi Benjamin! ... Tried it and even installed pathogen, Autocompl and the molokai colorscheme. It always showed the completion popup. I tried with a python, c
                  Message 8 of 21 , Feb 5, 2013
                  • 0 Attachment
                    Hi Benjamin!

                    On Di, 05 Feb 2013, Benjamin Isbarn wrote:

                    > Guess you could use my .vimrc which was attached to the initial post, but i'll
                    > attach it to this message as well. It's a really minimal config, so i hope
                    > you're able to reproduce this issue. I had this issue with the same .vimrc and
                    > the same plugins on 3 machines.

                    Tried it and even installed pathogen, Autocompl and the molokai
                    colorscheme. It always showed the completion popup. I tried with a
                    python, c and html file and enabled folding and cuc and disabled it. I
                    couldn't see a difference.

                    So please give me some exact hints, a sample file and what you entered
                    so that I can reproduce it.

                    regards,
                    Christian
                    --
                    Geschenke sind wie Angelhaken.
                    -- Martial (40-103 n.Chr.)

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Benjamin Isbarn
                    ... Hi Christian, i think i narrowed down the problem. However, i think i should give you a quick overview of my compiled in functions of vim and my system. I
                    Message 9 of 21 , Feb 6, 2013
                    • 0 Attachment
                      On Tuesday, February 05, 2013 11:04:05 PM Christian Brabandt wrote:
                      > Hi Benjamin!
                      >
                      > On Di, 05 Feb 2013, Benjamin Isbarn wrote:
                      > > Guess you could use my .vimrc which was attached to the initial post, but
                      > > i'll attach it to this message as well. It's a really minimal config, so
                      > > i hope you're able to reproduce this issue. I had this issue with the
                      > > same .vimrc and the same plugins on 3 machines.
                      >
                      > Tried it and even installed pathogen, Autocompl and the molokai
                      > colorscheme. It always showed the completion popup. I tried with a
                      > python, c and html file and enabled folding and cuc and disabled it. I
                      > couldn't see a difference.
                      >
                      > So please give me some exact hints, a sample file and what you entered
                      > so that I can reproduce it.
                      >
                      > regards,
                      > Christian

                      Hi Christian,

                      i think i narrowed down the problem. However, i think i should give you a
                      quick overview of my compiled in functions of vim and my system.

                      I tried it on three different machines, but all running Archlinux x86_64.
                      Output of "vim --version"

                      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Dec 8 2012 16:47:21)
                      Included patches: 1-754
                      Compiled by ArchLinux
                      Big version with GTK2 GUI. Features included (+) or not (-):
                      +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent
                      +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
                      +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
                      +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
                      +file_in_path +find_in_path +float +folding -footer +fork() +gettext
                      -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
                      +linebreak +lispindent +listcmds +localmap +lua +menu +mksession +modify_fname
                      +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm
                      +mouse_sgr -mouse_sysmouse +mouse_urxvt +mouse_xterm +multi_byte +multi_lang
                      -mzscheme +netbeans_intg +path_extra +perl +persistent_undo +postscript
                      +printer -profile +python -python3 +quickfix +reltime +rightleft +ruby
                      +scrollbind +signs +smartindent -sniff +startuptime +statusline -sun_workshop
                      +syntax +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
                      +termresponse
                      +textobjects +title +toolbar +user_commands +vertsplit +virtualedit +visual
                      +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup
                      +X11 -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
                      system vimrc file: "/etc/vimrc"
                      user vimrc file: "$HOME/.vimrc"
                      user exrc file: "$HOME/.exrc"
                      system gvimrc file: "/etc/gvimrc"
                      user gvimrc file: "$HOME/.gvimrc"
                      system menu file: "$VIMRUNTIME/menu.vim"
                      fall-back for $VIM: "/usr/share/vim"
                      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread -
                      I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -
                      I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -
                      I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -
                      I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/include/harfbuzz -
                      I/usr/local/include -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector
                      --param=ssp-buffer-size=4 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
                      Linking: gcc -L. -Wl,-O1,--sort-common,--as-needed,-z,relro -rdynamic -Wl,-
                      export-dynamic -Wl,-E -Wl,-rpath,/usr/lib/perl5/core_perl/CORE -Wl,-O1,--
                      sort-common,--as-needed,-z,relro -L/usr/local/lib -Wl,--as-needed -o vim -
                      lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0
                      -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -
                      lglib-2.0 -lSM -lICE -lXt -lX11 -lXdmcp -lSM -lICE -lm -lncurses -lnsl -
                      lacl -lattr -lgpm -ldl -L/usr/lib -llua -Wl,-E -Wl,-
                      rpath,/usr/lib/perl5/core_perl/CORE -Wl,-O1,--sort-common,--as-needed,-z,relro
                      -fstack-protector -L/usr/local/lib -L/usr/lib/perl5/core_perl/CORE -lperl -
                      lnsl -ldl -lm -lcrypt -lutil -lpthread -lc -L/usr/lib/python2.7/config -
                      lpython2.7 -lpthread -ldl -lutil -lm -Xlinker -export-dynamic -lruby -
                      lpthread -lrt -ldl -lcrypt -lm -L/usr/lib




                      I created an new user and tried to reproduce the error building a vimrc from
                      scratch. It turns out that you can reproduce this error with only two options
                      set:

                      filetype plugin on
                      set cursorcolumn

                      However, this error only occurs when you have the preview option of
                      omnicomplete enabled an try to auto complete something that will force the
                      preview window to pop up. Having the +python option compiled to your vim, the
                      easiest way would be to open a *.py file and type something like the following:



                      import sys

                      sys.


                      After the sys. try to invoke the auto completion with <C-X><C-O>, if the
                      preview window won't pop up try to set

                      :set completeopt+=preview


                      I hope this'll help you to reproduce the error. By the way, you can leave the
                      preview window open and disable the preview option via

                      :set completeopt-=preview

                      and the list will appear.


                      Best regards,

                      Benjamin Isbarn

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Christian Brabandt
                      ... Mysterious. I built latest (well almost, since yesterday vim mainline is a few patches away) Vim 7.3.798 on amd64 architecture on Ubuntu 12.10 and tried to
                      Message 10 of 21 , Feb 7, 2013
                      • 0 Attachment
                        On Wed, February 6, 2013 10:14, Benjamin Isbarn wrote:
                        > On Tuesday, February 05, 2013 11:04:05 PM Christian Brabandt wrote:
                        >> Hi Benjamin!
                        >>
                        >> On Di, 05 Feb 2013, Benjamin Isbarn wrote:
                        >> > Guess you could use my .vimrc which was attached to the initial post,
                        >> but
                        >> > i'll attach it to this message as well. It's a really minimal config,
                        >> so
                        >> > i hope you're able to reproduce this issue. I had this issue with the
                        >> > same .vimrc and the same plugins on 3 machines.
                        >>
                        >> Tried it and even installed pathogen, Autocompl and the molokai
                        >> colorscheme. It always showed the completion popup. I tried with a
                        >> python, c and html file and enabled folding and cuc and disabled it. I
                        >> couldn't see a difference.
                        >>
                        >> So please give me some exact hints, a sample file and what you entered
                        >> so that I can reproduce it.
                        >>
                        >> regards,
                        >> Christian
                        >
                        > Hi Christian,
                        >
                        > i think i narrowed down the problem. However, i think i should give you a
                        > quick overview of my compiled in functions of vim and my system.
                        >
                        > I tried it on three different machines, but all running Archlinux x86_64.
                        > Output of "vim --version"
                        >
                        > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Dec 8 2012 16:47:21)
                        > Included patches: 1-754
                        > Compiled by ArchLinux
                        > Big version with GTK2 GUI. Features included (+) or not (-):
                        > +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
                        > +cindent
                        > +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
                        > +comments
                        > +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
                        > +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
                        > +file_in_path +find_in_path +float +folding -footer +fork() +gettext
                        > -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
                        > +linebreak +lispindent +listcmds +localmap +lua +menu +mksession
                        > +modify_fname
                        > +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm
                        > +mouse_sgr -mouse_sysmouse +mouse_urxvt +mouse_xterm +multi_byte
                        > +multi_lang
                        > -mzscheme +netbeans_intg +path_extra +perl +persistent_undo +postscript
                        > +printer -profile +python -python3 +quickfix +reltime +rightleft +ruby
                        > +scrollbind +signs +smartindent -sniff +startuptime +statusline
                        > -sun_workshop
                        > +syntax +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
                        > +termresponse
                        > +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
                        > +visual
                        > +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
                        > +writebackup
                        > +X11 -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
                        > system vimrc file: "/etc/vimrc"
                        > user vimrc file: "$HOME/.vimrc"
                        > user exrc file: "$HOME/.exrc"
                        > system gvimrc file: "/etc/gvimrc"
                        > user gvimrc file: "$HOME/.gvimrc"
                        > system menu file: "$VIMRUNTIME/menu.vim"
                        > fall-back for $VIM: "/usr/share/vim"
                        > Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread -
                        > I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -
                        > I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0
                        > -
                        > I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1
                        > -
                        > I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/include/harfbuzz
                        > -
                        > I/usr/local/include -march=x86-64 -mtune=generic -O2 -pipe
                        > -fstack-protector
                        > --param=ssp-buffer-size=4 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
                        > Linking: gcc -L. -Wl,-O1,--sort-common,--as-needed,-z,relro -rdynamic
                        > -Wl,-
                        > export-dynamic -Wl,-E -Wl,-rpath,/usr/lib/perl5/core_perl/CORE
                        > -Wl,-O1,--
                        > sort-common,--as-needed,-z,relro -L/usr/local/lib -Wl,--as-needed -o vim
                        > -
                        > lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0
                        > -lpangocairo-1.0
                        > -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0
                        > -
                        > lglib-2.0 -lSM -lICE -lXt -lX11 -lXdmcp -lSM -lICE -lm -lncurses -lnsl
                        > -
                        > lacl -lattr -lgpm -ldl -L/usr/lib -llua -Wl,-E -Wl,-
                        > rpath,/usr/lib/perl5/core_perl/CORE
                        > -Wl,-O1,--sort-common,--as-needed,-z,relro
                        > -fstack-protector -L/usr/local/lib -L/usr/lib/perl5/core_perl/CORE -lperl
                        > -
                        > lnsl -ldl -lm -lcrypt -lutil -lpthread -lc -L/usr/lib/python2.7/config -
                        > lpython2.7 -lpthread -ldl -lutil -lm -Xlinker -export-dynamic -lruby -
                        > lpthread -lrt -ldl -lcrypt -lm -L/usr/lib
                        >
                        >
                        >
                        >
                        > I created an new user and tried to reproduce the error building a vimrc
                        > from
                        > scratch. It turns out that you can reproduce this error with only two
                        > options
                        > set:
                        >
                        > filetype plugin on
                        > set cursorcolumn
                        >
                        > However, this error only occurs when you have the preview option of
                        > omnicomplete enabled an try to auto complete something that will force the
                        > preview window to pop up. Having the +python option compiled to your vim,
                        > the
                        > easiest way would be to open a *.py file and type something like the
                        > following:
                        >
                        >
                        >
                        > import sys
                        >
                        > sys.
                        >
                        >
                        > After the sys. try to invoke the auto completion with <C-X><C-O>, if the
                        > preview window won't pop up try to set
                        >
                        > :set completeopt+=preview
                        >
                        >
                        > I hope this'll help you to reproduce the error. By the way, you can leave
                        > the
                        > preview window open and disable the preview option via
                        >
                        > :set completeopt-=preview
                        >
                        > and the list will appear.


                        Mysterious. I built latest (well almost, since yesterday vim mainline
                        is a few patches away) Vim 7.3.798 on amd64 architecture on Ubuntu 12.10
                        and tried to reproduce what you get and still, it seems to work fine.

                        Here is a screencast, of what I did.
                        http://www.256bit.org/~chrisbra/capture.gif

                        Can you try this please and see, if this triggers the bug for you?
                        I am starting to wonder, if this could be related to some video driver
                        bug or so.

                        regards,
                        Christian

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Benjamin Isbarn
                        ... Hey, this is realy strange. But i noticed one thing in your gif. Isn t the pop-up menu supposed to pop up right below or on the same line as the input
                        Message 11 of 21 , Feb 7, 2013
                        • 0 Attachment
                          On Thursday, February 07, 2013 10:06:08 AM Christian Brabandt wrote:
                          > Mysterious. I built latest (well almost, since yesterday vim mainline
                          > is a few patches away) Vim 7.3.798 on amd64 architecture on Ubuntu 12.10
                          > and tried to reproduce what you get and still, it seems to work fine.
                          >
                          > Here is a screencast, of what I did.
                          > http://www.256bit.org/~chrisbra/capture.gif
                          >
                          > Can you try this please and see, if this triggers the bug for you?
                          > I am starting to wonder, if this could be related to some video driver
                          > bug or so.
                          >
                          > regards,
                          > Christian

                          Hey, this is realy strange. But i noticed one thing in your gif. Isn't the
                          pop-up menu supposed to pop up right below or on the same line as the input
                          text? Your pop-up menu starts "in" the preview window. Anyway, I'm going to
                          download ubuntu 12.10 an do some testing on this tomorrow at university, since
                          my internet connection at home is terrible.

                          I don't think that this is and graphics card driver fault or something like
                          this, since i have the same issue inside the virtualbox on my machine in
                          university, which has a cpu built in graphics card on the host.

                          It might be an issue with Konsole. I use Konsole on all my machines. I
                          downloaded xterm and tried it and it worked, but when i resized the window
                          (the xterm window) i had the same issue.

                          Regards

                          Benjamin

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        • Ben Fritz
                          ... It is not a terminal issue, I see it on Windows gvim. I see the issue with syntax folding enabled and closed folds in the window; I do not use cursorcolumn
                          Message 12 of 21 , Feb 7, 2013
                          • 0 Attachment
                            On Thursday, February 7, 2013 10:23:47 AM UTC-6, Benjamin Isbarn wrote:
                            > It might be an issue with Konsole. I use Konsole on all my machines. I
                            >
                            > downloaded xterm and tried it and it worked, but when i resized the window
                            >
                            > (the xterm window) i had the same issue.
                            >

                            It is not a terminal issue, I see it on Windows gvim. I see the issue with
                            syntax folding enabled and closed folds in the window; I do not use
                            cursorcolumn except for a quick mapping to toggle it on when I want to quickly
                            find the cursor, then I toggle it back off.

                            Today I finally had a reproducible situation where I see the issue, so I dug
                            through my .vimrc to find the lines causing the problem.

                            Here are the lines:

                            " get rid of scrolloff option for certain buffers like the quickfix and
                            " preview windows
                            autocmd BufEnter *
                            \ if (&ft=='qf' || &previewwindow || (bufname('%') ==# "__Tag_List__" || bufname("%")==?'__Tagbar__')) && !exists('s:scrolloff_sav') |
                            \ let s:scrolloff_sav=&scrolloff |
                            \ set scrolloff=0 |
                            \ endif
                            " File type will not be set on the first BufEnter
                            autocmd Filetype qf
                            \ if !exists('s:scrolloff_sav') |
                            \ let s:scrolloff_sav=&scrolloff |
                            \ set scrolloff=0 |
                            \ endif
                            autocmd BufLeave *
                            \ if (&ft=='qf' || &previewwindow || (bufname('%') ==# "__Tag_List__" || bufname("%")==?'__Tagbar__')) && exists('s:scrolloff_sav') |
                            \ let &scrolloff=s:scrolloff_sav |
                            \ unlet s:scrolloff_sav |
                            \ endif

                            A few relevant settings:

                            completeopt=menuone,preview
                            omnifunc=ccomplete#Complete
                            foldmethod=syntax
                            scrolloff=5

                            If I use the following procedure with the above autocmds in my .vimrc, I see the
                            popup menu flash briefly and go invisible. The preview window gets updated
                            properly as I press the <Up> and <Down> buttons as if the menu was visible.
                            <C-N> and <C-P> work as they are supposed to. But the popup menu stays
                            inivisible.

                            1. Edit a C file (the one I used was a proprietary code file for my employer, I
                            can't share it, sorry).
                            2. Go to a place in the C file in a nested fold (in my code, it is 5 levels
                            deep).
                            3. Close all folds with zM
                            4. Show the cursor line with zv
                            5. Type a partial match and press <C-X><C-O> to start omnicompletion (which
                            includes tags, I believe).

                            Now I see the issue or not, depending on my autocmds above.

                            I think what may be happening is that my autocmds are adjusting scrolloff on
                            BufEnter/BufLeave, which triggers because the preview window is most likely
                            entered to update it to show the completion menu info. When scrolloff is
                            updated, the window positions may change. Perhaps changing window scroll
                            position via autocmd while the completion menu is up causes problems.

                            --
                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          • Ben Fritz
                            ... I tried but was unable to create a minimal configuration based on these setting that would reproduce the issue. I ll look into it some more this weekend at
                            Message 13 of 21 , Feb 8, 2013
                            • 0 Attachment
                              On Thursday, February 7, 2013 12:24:25 PM UTC-6, Ben Fritz wrote:
                              >
                              > " get rid of scrolloff option for certain buffers like the quickfix and
                              > " preview windows
                              > autocmd BufEnter *
                              > \ if (&ft=='qf' || &previewwindow || (bufname('%') ==# "__Tag_List__" || bufname("%")==?'__Tagbar__')) && !exists('s:scrolloff_sav') |
                              > \ let s:scrolloff_sav=&scrolloff |
                              > \ set scrolloff=0 |
                              > \ endif
                              > " File type will not be set on the first BufEnter
                              > autocmd Filetype qf
                              > \ if !exists('s:scrolloff_sav') |
                              > \ let s:scrolloff_sav=&scrolloff |
                              > \ set scrolloff=0 |
                              > \ endif
                              > autocmd BufLeave *
                              > \ if (&ft=='qf' || &previewwindow || (bufname('%') ==# "__Tag_List__" || bufname("%")==?'__Tagbar__')) && exists('s:scrolloff_sav') |
                              > \ let &scrolloff=s:scrolloff_sav |
                              > \ unlet s:scrolloff_sav |
                              > \ endif
                              >
                              > A few relevant settings:
                              >
                              > completeopt=menuone,preview
                              > omnifunc=ccomplete#Complete
                              > foldmethod=syntax
                              > scrolloff=5
                              >

                              I tried but was unable to create a minimal configuration based on these setting that would reproduce the issue. I'll look into it some more this weekend at home.

                              --
                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                              For more options, visit https://groups.google.com/groups/opt_out.
                            • Benjamin Fritz
                              The attached vimrc.vim file (when used as the .vimrc, with no non-standard plugins), can reproduce the issue on the attached test.c file with the attached tags
                              Message 14 of 21 , Feb 8, 2013
                              • 0 Attachment
                                The attached vimrc.vim file (when used as the .vimrc, with no
                                non-standard plugins), can reproduce the issue on the attached test.c
                                file with the attached tags file.

                                Open the test.c file, go to line 62 (return 3), and insert a new line
                                above it. Type foo=Fun<C-X><C-O> to get the completion menu. Then
                                press the down or up arrows to navigate the completion menu.

                                I'm not really sure why I am setting fillchars within my foldtext
                                function but that seems to be one necessary component in this config
                                at least.

                                --
                                --
                                You received this message from the "vim_use" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_use" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                For more options, visit https://groups.google.com/groups/opt_out.
                              • Benjamin Fritz
                                ... gmail is being a huge pain. tags file attached...again. -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below
                                Message 15 of 21 , Feb 8, 2013
                                • 0 Attachment
                                  On Fri, Feb 8, 2013 at 9:32 PM, Benjamin Fritz <fritzophrenic@...> wrote:
                                  > The attached vimrc.vim file (when used as the .vimrc, with no
                                  > non-standard plugins), can reproduce the issue on the attached test.c
                                  > file with the attached tags file.
                                  >

                                  gmail is being a huge pain. tags file attached...again.

                                  --
                                  --
                                  You received this message from the "vim_use" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php

                                  ---
                                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                  For more options, visit https://groups.google.com/groups/opt_out.
                                • Ben Fritz
                                  ... OK this is getting ridiculous. It s attached to the email. Generate your own tags or copy-paste the following into a new file: !_TAG_FILE_FORMAT 2
                                  Message 16 of 21 , Feb 8, 2013
                                  • 0 Attachment
                                    On Friday, February 8, 2013 9:37:18 PM UTC-6, Ben Fritz wrote:
                                    > On Fri, Feb 8, 2013 at 9:32 PM, Benjamin Fritz <fritzophrenic@...> wrote:
                                    >
                                    > > The attached vimrc.vim file (when used as the .vimrc, with no
                                    >
                                    > > non-standard plugins), can reproduce the issue on the attached test.c
                                    >
                                    > > file with the attached tags file.
                                    >
                                    > >
                                    >
                                    >
                                    >
                                    > gmail is being a huge pain. tags file attached...again.

                                    OK this is getting ridiculous. It's attached to the email. Generate your own tags or copy-paste the following into a new file:

                                    !_TAG_FILE_FORMAT 2 /extended format; --format=1 will not append ;" to lines/
                                    !_TAG_FILE_SORTED 1 /0=unsorted, 1=sorted, 2=foldcase/
                                    !_TAG_PROGRAM_AUTHOR Darren Hiebert /dhiebert@.../
                                    !_TAG_PROGRAM_NAME Exuberant Ctags //
                                    !_TAG_PROGRAM_URL http://ctags.sourceforge.net /official site/
                                    !_TAG_PROGRAM_VERSION 5.8 //
                                    Func1 .\test.c ?^int Func1(void)$?;" function signature:(void)
                                    Func2 .\test.c ?^int Func2(void)$?;" function signature:(void)
                                    Func3 .\test.c ?^int Func3(void)$?;" function signature:(void)
                                    Func4 .\test.c ?^int Func4(void)$?;" function signature:(void)
                                    Func5 .\test.c ?^int Func5(void)$?;" function signature:(void)
                                    Func6 .\test.c ?^int Func6(void)$?;" function signature:(void)
                                    Func7 .\test.c ?^int Func7(void)$?;" function signature:(void)
                                    Func8 .\test.c ?^int Func8(void)$?;" function signature:(void)
                                    FuncCall .\test.c ?^int FuncCall(int a, int b, int c, int d, int e, int f, int g)$?;" function signature:(int a, int b, int c, int d, int e, int f, int g)
                                    test.c .\test.c 1;" file

                                    --
                                    --
                                    You received this message from the "vim_use" maillist.
                                    Do not top-post! Type your reply below the text you are replying to.
                                    For more information, visit http://www.vim.org/maillist.php

                                    ---
                                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                    For more options, visit https://groups.google.com/groups/opt_out.
                                  • Christian Brabandt
                                    Hi Ben! ... Interesting. On my main develop machine, using Ubuntu 12.10 with intel driver, this does not happen, but on my desktop Ubuntu 12.04 with vesa
                                    Message 17 of 21 , Feb 12, 2013
                                    • 0 Attachment
                                      Hi Ben!

                                      On Fr, 08 Feb 2013, Ben Fritz wrote:

                                      > On Friday, February 8, 2013 9:37:18 PM UTC-6, Ben Fritz wrote:
                                      > > On Fri, Feb 8, 2013 at 9:32 PM, Benjamin Fritz <fritzophrenic@...> wrote:
                                      > >
                                      > > > The attached vimrc.vim file (when used as the .vimrc, with no
                                      > >
                                      > > > non-standard plugins), can reproduce the issue on the attached test.c
                                      > >
                                      > > > file with the attached tags file.
                                      > >
                                      > > >
                                      > >
                                      > >
                                      > >
                                      > > gmail is being a huge pain. tags file attached...again.
                                      >
                                      > OK this is getting ridiculous. It's attached to the email. Generate your own tags or copy-paste the following into a new file:
                                      >
                                      > !_TAG_FILE_FORMAT 2 /extended format; --format=1 will not append ;" to lines/
                                      > !_TAG_FILE_SORTED 1 /0=unsorted, 1=sorted, 2=foldcase/
                                      > !_TAG_PROGRAM_AUTHOR Darren Hiebert /dhiebert@.../
                                      > !_TAG_PROGRAM_NAME Exuberant Ctags //
                                      > !_TAG_PROGRAM_URL http://ctags.sourceforge.net /official site/
                                      > !_TAG_PROGRAM_VERSION 5.8 //
                                      > Func1 .\test.c ?^int Func1(void)$?;" function signature:(void)
                                      > Func2 .\test.c ?^int Func2(void)$?;" function signature:(void)
                                      > Func3 .\test.c ?^int Func3(void)$?;" function signature:(void)
                                      > Func4 .\test.c ?^int Func4(void)$?;" function signature:(void)
                                      > Func5 .\test.c ?^int Func5(void)$?;" function signature:(void)
                                      > Func6 .\test.c ?^int Func6(void)$?;" function signature:(void)
                                      > Func7 .\test.c ?^int Func7(void)$?;" function signature:(void)
                                      > Func8 .\test.c ?^int Func8(void)$?;" function signature:(void)
                                      > FuncCall .\test.c ?^int FuncCall(int a, int b, int c, int d, int e, int f, int g)$?;" function signature:(int a, int b, int c, int d, int e, int f, int g)
                                      > test.c .\test.c 1;" file
                                      >

                                      Interesting. On my main develop machine, using Ubuntu 12.10 with intel
                                      driver, this does not happen, but on my desktop Ubuntu 12.04 with vesa
                                      driver I can reproduce the problem. I see, if I can debug it further.

                                      Mit freundlichen Grüßen
                                      Christian
                                      --
                                      Wie man sein Kind nicht nennen sollte:
                                      Jeff Etage

                                      --
                                      --
                                      You received this message from the "vim_use" maillist.
                                      Do not top-post! Type your reply below the text you are replying to.
                                      For more information, visit http://www.vim.org/maillist.php

                                      ---
                                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                      For more options, visit https://groups.google.com/groups/opt_out.
                                    • Ben Fritz
                                      ... This is off-topic for the problem at hand (disappearing completion menu), but I went back and looked at my main config to figure out why I was setting
                                      Message 18 of 21 , Feb 12, 2013
                                      • 0 Attachment
                                        On Friday, February 8, 2013 9:32:45 PM UTC-6, Ben Fritz wrote:
                                        >
                                        > I'm not really sure why I am setting fillchars within my foldtext
                                        >
                                        > function but that seems to be one necessary component in this config
                                        >
                                        > at least.

                                        This is off-topic for the problem at hand (disappearing completion menu), but I went back and looked at my main config to figure out why I was setting fillchars at all (obviously it seems pointless in the toy example .vimrc I posted).

                                        In my real config, my foldtext function switches on a buffer-local variable and the value of the 'diff' option to determine which of three different styles to use. I can't really think of a better place to put it. For now I think I'll put it into a CursorHold event rather than keeping it in the foldtext expression.

                                        --
                                        --
                                        You received this message from the "vim_use" maillist.
                                        Do not top-post! Type your reply below the text you are replying to.
                                        For more information, visit http://www.vim.org/maillist.php

                                        ---
                                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                        For more options, visit https://groups.google.com/groups/opt_out.
                                      • Christian Brabandt
                                        ... Ben, Benjamin, can you check, whether this patch fixes the problem for you? diff -r ba8835947b8b src/screen.c ... +++ b/src/screen.c Tue Feb 12
                                        Message 19 of 21 , Feb 12, 2013
                                        • 0 Attachment
                                          On Fr, 08 Feb 2013, Ben Fritz wrote:

                                          > On Friday, February 8, 2013 9:37:18 PM UTC-6, Ben Fritz wrote:
                                          > > On Fri, Feb 8, 2013 at 9:32 PM, Benjamin Fritz <fritzophrenic@...> wrote:
                                          > >
                                          > > > The attached vimrc.vim file (when used as the .vimrc, with no
                                          > >
                                          > > > non-standard plugins), can reproduce the issue on the attached test.c
                                          > >
                                          > > > file with the attached tags file.
                                          > >

                                          Ben, Benjamin,
                                          can you check, whether this patch fixes the problem for you?

                                          diff -r ba8835947b8b src/screen.c
                                          --- a/src/screen.c Wed Feb 06 19:58:43 2013 +0100
                                          +++ b/src/screen.c Tue Feb 12 22:28:06 2013 +0100
                                          @@ -545,6 +545,10 @@
                                          }
                                          #endif
                                          }
                                          +#ifdef FEAT_INS_EXPAND
                                          + if (pum_visible()) /* win_update() might have overwritten the popup menu */
                                          + pum_redraw();
                                          +#endif
                                          #if defined(FEAT_SEARCH_EXTRA)
                                          end_search_hl();
                                          #endif

                                          Bram, I think, this patch fixes an issue, that the completion menu is
                                          not correctly displayed when the preview window is used (and the windows
                                          are scrolled). It might be possible, that it also fixes those issues
                                          from the todo list:

                                          ,----
                                          | popup completion menu closes quickly when there is a fold in the buffer. (Jan
                                          | Christoph Ebersbach, 2011 Jul 3)
                                          `----

                                          ,----
                                          | Completion menu disappears when using 'cursorcolumn'. (Sven-Hendrik Haase,
                                          | 2011 May 23)
                                          `----

                                          But I am not sure, as reproducing the issue seems quite complicated (see
                                          the long thread on vim_use about how to reproduce it). Do you have more
                                          infos how to reproduce those issues?

                                          regards,
                                          Christian

                                          --
                                          --
                                          You received this message from the "vim_use" maillist.
                                          Do not top-post! Type your reply below the text you are replying to.
                                          For more information, visit http://www.vim.org/maillist.php

                                          ---
                                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                          For more options, visit https://groups.google.com/groups/opt_out.
                                        • Benjamin Fritz
                                          ... Yes, this patch works, at least for my toy test case! Thanks! I don t run self-compiled Vim at work on Windows (at least not yet). But it certainly acts
                                          Message 20 of 21 , Feb 12, 2013
                                          • 0 Attachment
                                            On Tue, Feb 12, 2013 at 3:37 PM, Christian Brabandt <cblists@...> wrote:
                                            >
                                            > On Fr, 08 Feb 2013, Ben Fritz wrote:
                                            >
                                            >> On Friday, February 8, 2013 9:37:18 PM UTC-6, Ben Fritz wrote:
                                            >> > On Fri, Feb 8, 2013 at 9:32 PM, Benjamin Fritz <fritzophrenic@...> wrote:
                                            >> >
                                            >> > > The attached vimrc.vim file (when used as the .vimrc, with no
                                            >> >
                                            >> > > non-standard plugins), can reproduce the issue on the attached test.c
                                            >> >
                                            >> > > file with the attached tags file.
                                            >> >
                                            >
                                            > Ben, Benjamin,
                                            > can you check, whether this patch fixes the problem for you?
                                            >
                                            > diff -r ba8835947b8b src/screen.c
                                            > --- a/src/screen.c Wed Feb 06 19:58:43 2013 +0100
                                            > +++ b/src/screen.c Tue Feb 12 22:28:06 2013 +0100
                                            > @@ -545,6 +545,10 @@
                                            > }
                                            > #endif
                                            > }
                                            > +#ifdef FEAT_INS_EXPAND
                                            > + if (pum_visible()) /* win_update() might have overwritten the popup menu */
                                            > + pum_redraw();
                                            > +#endif
                                            > #if defined(FEAT_SEARCH_EXTRA)
                                            > end_search_hl();
                                            > #endif
                                            >

                                            Yes, this patch works, at least for my toy test case! Thanks!

                                            I don't run self-compiled Vim at work on Windows (at least not yet).
                                            But it certainly acts like the same issue I've reproduced with my toy
                                            example. I did get the toy example by paring down my own Vim config
                                            after all.

                                            > Bram, I think, this patch fixes an issue, that the completion menu is
                                            > not correctly displayed when the preview window is used (and the windows
                                            > are scrolled). It might be possible, that it also fixes those issues
                                            > from the todo list:
                                            >
                                            > ,----
                                            > | popup completion menu closes quickly when there is a fold in the buffer. (Jan
                                            > | Christoph Ebersbach, 2011 Jul 3)
                                            > `----
                                            >

                                            I'm pretty sure it will fix this issue, since that's what I thought
                                            was affecting me.

                                            > ,----
                                            > | Completion menu disappears when using 'cursorcolumn'. (Sven-Hendrik Haase,
                                            > | 2011 May 23)
                                            > `----
                                            >

                                            This one I've never seen first-hand.

                                            > But I am not sure, as reproducing the issue seems quite complicated (see
                                            > the long thread on vim_use about how to reproduce it). Do you have more
                                            > infos how to reproduce those issues?
                                            >
                                            > regards,
                                            > Christian

                                            --
                                            --
                                            You received this message from the "vim_use" maillist.
                                            Do not top-post! Type your reply below the text you are replying to.
                                            For more information, visit http://www.vim.org/maillist.php

                                            ---
                                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                            For more options, visit https://groups.google.com/groups/opt_out.
                                          • Bram Moolenaar
                                            ... It s a bit of a brute force solution but I suppose it should be OK. ... Not much. I ll remove those remarks and await someone reporting a problem again,
                                            Message 21 of 21 , Feb 13, 2013
                                            • 0 Attachment
                                              Christian Brabandt wrote:

                                              > On Fr, 08 Feb 2013, Ben Fritz wrote:
                                              >
                                              > > On Friday, February 8, 2013 9:37:18 PM UTC-6, Ben Fritz wrote:
                                              > > > On Fri, Feb 8, 2013 at 9:32 PM, Benjamin Fritz <fritzophrenic@...> wrote:
                                              > > >
                                              > > > > The attached vimrc.vim file (when used as the .vimrc, with no
                                              > > >
                                              > > > > non-standard plugins), can reproduce the issue on the attached test.c
                                              > > >
                                              > > > > file with the attached tags file.
                                              > > >
                                              >
                                              > Ben, Benjamin,
                                              > can you check, whether this patch fixes the problem for you?
                                              >
                                              > diff -r ba8835947b8b src/screen.c
                                              > --- a/src/screen.c Wed Feb 06 19:58:43 2013 +0100
                                              > +++ b/src/screen.c Tue Feb 12 22:28:06 2013 +0100
                                              > @@ -545,6 +545,10 @@
                                              > }
                                              > #endif
                                              > }
                                              > +#ifdef FEAT_INS_EXPAND
                                              > + if (pum_visible()) /* win_update() might have overwritten the popup menu */
                                              > + pum_redraw();
                                              > +#endif
                                              > #if defined(FEAT_SEARCH_EXTRA)
                                              > end_search_hl();
                                              > #endif
                                              >
                                              > Bram, I think, this patch fixes an issue, that the completion menu is
                                              > not correctly displayed when the preview window is used (and the windows
                                              > are scrolled). It might be possible, that it also fixes those issues
                                              > from the todo list:

                                              It's a bit of a brute force solution but I suppose it should be OK.

                                              > ,----
                                              > | popup completion menu closes quickly when there is a fold in the buffer. (Jan
                                              > | Christoph Ebersbach, 2011 Jul 3)
                                              > `----
                                              >
                                              > ,----
                                              > | Completion menu disappears when using 'cursorcolumn'. (Sven-Hendrik Haase,
                                              > | 2011 May 23)
                                              > `----
                                              >
                                              > But I am not sure, as reproducing the issue seems quite complicated (see
                                              > the long thread on vim_use about how to reproduce it). Do you have more
                                              > infos how to reproduce those issues?

                                              Not much. I'll remove those remarks and await someone reporting a
                                              problem again, if there still is a problem.

                                              --
                                              Dogs must have a permit signed by the mayor in order to congregate in groups
                                              of three or more on private property.
                                              [real standing law in Oklahoma, United States of America]

                                              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                                              /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                                              \\\ an exciting new programming language -- http://www.Zimbu.org ///
                                              \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                                              --
                                              --
                                              You received this message from the "vim_use" maillist.
                                              Do not top-post! Type your reply below the text you are replying to.
                                              For more information, visit http://www.vim.org/maillist.php

                                              ---
                                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                              For more options, visit https://groups.google.com/groups/opt_out.
                                            Your message has been successfully submitted and would be delivered to recipients shortly.