Loading ...
Sorry, an error occurred while loading the content.

Re: Migrating text from vim to wysiwyg editor

Expand Messages
  • ping
    ... so along with a reverse operator we can have sth like these? //join each parag into a line noremap ,q :g/^ //split(format) them back into
    Message 1 of 21 , Feb 2, 2013
    • 0 Attachment
      On 2/1/2013 10:55 PM, Chris Schneider wrote:
      > You could do something like
      >
      > :g/^\</'{+,'}-j
      >
      > (assuming you have at least one blank line at the end of the file;
      > otherwise, you'd have to manually join the last line to the last
      > paragraph). Alternatively, you could do
      >
      > :v/^\s*$/norm vipJ
      >
      > which would have a similar behavior.
      so along with a "reverse" operator we can have sth like these?
      //join each parag into a line
      noremap ,q :g/^\</'{+,'}-j<cr>

      //split(format) them back into paragraphs
      noremap ,Q :g/^\S/normal gqqo<esc>

      I think the good thing is that they can be used under vsiual mode, which
      gives a control of the text range that these operators can be applied on...

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • jcordes
      ... Tim, Thanks very much for posting this. Your explanation (in a later post) makes a lot of sense, but for some reason I keep coming up with an invalid
      Message 2 of 21 , Feb 2, 2013
      • 0 Attachment
        On Friday, 1 February 2013 23:46:03 UTC-4, Tim Chase wrote:
        > You could do something like
        > :g/^\</'{+,'}-j
        >
        > (assuming you have at least one blank line at the end of the file;
        > otherwise, you'd have to manually join the last line to the last
        > paragraph).

        Tim,

        Thanks very much for posting this. Your explanation (in a later post) makes a lot of sense, but for some reason I keep coming up with an 'invalid range' error when I use
        :g/^\</'{+,'}-j
        This is in a short text file with some blank (empty) lines between paragraphs, on linux; line endings are just LF.

        VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Sep 24 2012 23:53:05)
        Huge version without GUI.

        Can you suggest anything I might be doing wrong?

        Thanks,
        John

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Gary Johnson
        ... I wanted the yank to be done line-wise and it was easier for me to type Y than to investigate whether y would work as well. Regards, Gary -- -- You
        Message 3 of 21 , Feb 2, 2013
        • 0 Attachment
          On 2013-02-02, Michael Henry wrote:
          > On 02/01/2013 10:42 PM, Gary Johnson wrote:
          > > then highlight the lines of the report using V. Then
          > >
          > > gqgvY
          > >
          > > to reformat all the paragraphs as long lines and yank them to the
          > > clipboard[...]
          >
          > I was interested to see the use of visual-mode "Y" above. In
          > the Vim help (and in brief empirical testing), I don't see any
          > difference between lowercase "y" and uppercase "Y" in visual
          > mode. I'm just curious why you've chosen to use the uppercase
          > alternative, since lowercase "y" is easier to type.

          I wanted the yank to be done line-wise and it was easier for me to
          type Y than to investigate whether y would work as well.

          Regards,
          Gary

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          Hi jcordes! ... Are you possibly missing a trailing empty line? Mit freundlichen Grüßen Christian -- Man begeht entweder Fehler des Stolzes oder des
          Message 4 of 21 , Feb 2, 2013
          • 0 Attachment
            Hi jcordes!

            On Sa, 02 Feb 2013, jcordes wrote:

            > On Friday, 1 February 2013 23:46:03 UTC-4, Tim Chase wrote:
            > > You could do something like
            > > :g/^\</'{+,'}-j
            > >
            > > (assuming you have at least one blank line at the end of the file;
            > > otherwise, you'd have to manually join the last line to the last
            > > paragraph).
            >
            > Tim,
            >
            > Thanks very much for posting this. Your explanation (in a later post) makes a lot of sense, but for some reason I keep coming up with an 'invalid range' error when I use
            > :g/^\</'{+,'}-j
            > This is in a short text file with some blank (empty) lines between paragraphs, on linux; line endings are just LF.
            >
            > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Sep 24 2012 23:53:05)
            > Huge version without GUI.
            >
            > Can you suggest anything I might be doing wrong?

            Are you possibly missing a trailing empty line?

            Mit freundlichen Grüßen
            Christian
            --
            Man begeht entweder Fehler des Stolzes oder des Kriechens, wenn man
            nicht die Anerkennung des eignen Werts voraussetzt.
            -- Jean Paul (eig. Johann Paul Friedrich Richter)

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • vim@...
            ... Sorry if it was just a tad prolix. :-) ... The only way I was able to trigger this was if either: 1) your relative-range happens to be swapped (such that
            Message 5 of 21 , Feb 2, 2013
            • 0 Attachment
              On Sat, 2 Feb 2013 10:27:27 -0800 (PST), jcordes wrote:
              > On Friday, 1 February 2013 23:46:03 UTC-4, Tim Chase wrote:
              > > You could do something like
              > > :g/^\</'{+,'}-j
              >
              > Thanks very much for posting this. Your explanation (in a later
              > post) makes a lot of sense,

              Sorry if it was just a tad prolix. :-)

              > but for some reason I keep coming up
              > with an 'invalid range' error when I use :g/^\</'{+,'}-j


              The only way I was able to trigger this was if either:

              1) your relative-range happens to be swapped (such that the 2nd line
              comes before the first line), or

              2) if your file only has one line in it.

              I might be able to better determine what's going on if you can
              produce a sample file against which I could test.

              -tim


              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • jcordes
              ... Tim, and Christian: I have reduced the file to something very short - however, at some point the error changed to E147: Cannot do :global recursive. Here
              Message 6 of 21 , Feb 2, 2013
              • 0 Attachment
                On Saturday, 2 February 2013 14:40:47 UTC-4, Tim Chase wrote:
                > On Sat, 2 Feb 2013 10:27:27 -0800 (PST), jcordes wrote:
                >
                > > On Friday, 1 February 2013 23:46:03 UTC-4, Tim Chase wrote:
                >
                > > > You could do something like
                >
                > > > :g/^\</'{+,'}-j
                >
                > >
                >
                > > Thanks very much for posting this. Your explanation (in a later
                >
                > > post) makes a lot of sense,
                >
                > > but for some reason I keep coming up
                > > with an 'invalid range' error when I use :g/^\</'{+,'}-j
                >
                > The only way I was able to trigger this was if either:
                >
                > 1) your relative-range happens to be swapped (such that the 2nd line
                > comes before the first line), or
                >
                > 2) if your file only has one line in it.
                >
                > I might be able to better determine what's going on if you can
                > produce a sample file against which I could test.

                Tim, and Christian:

                I have reduced the file to something very short - however, at some point the error changed to E147: Cannot do :global recursive. Here is the short version:

                ###########
                2010.09.06

                Enter more city directory data - I already have quite a lot for my family in
                spreadsheets.

                ###########

                There are 5 lines, the last one being empty. Lines 3 and 4 are each terminated by a LF.

                I'm not sure if I may be misunderstanding the original proposal, to do
                :g/^\</'{+,'}-j

                Was it intended that the entire file should be visually selected first? I hadn't thought so.

                Thanks for your assistance,
                John

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • jcordes
                ... Sorry for the repost - I just realized I should have attached the test file. Have done so in this message. John -- -- You received this message from the
                Message 7 of 21 , Feb 2, 2013
                • 0 Attachment
                  On Saturday, 2 February 2013 16:09:17 UTC-4, jcordes wrote:
                  > On Saturday, 2 February 2013 14:40:47 UTC-4, Tim Chase wrote:
                  > > On Sat, 2 Feb 2013 10:27:27 -0800 (PST), jcordes wrote:
                  > >
                  > > > On Friday, 1 February 2013 23:46:03 UTC-4, Tim Chase wrote:
                  > >
                  > > > > You could do something like
                  > >
                  > > > > :g/^\</'{+,'}-j
                  > >
                  > > >
                  > >
                  > > > Thanks very much for posting this. Your explanation (in a later
                  > >
                  > > > post) makes a lot of sense,
                  > >
                  > > > but for some reason I keep coming up
                  > > > with an 'invalid range' error when I use :g/^\</'{+,'}-j
                  > >
                  > > The only way I was able to trigger this was if either:
                  > >
                  > > 1) your relative-range happens to be swapped (such that the 2nd line
                  > > comes before the first line), or
                  > >
                  > > 2) if your file only has one line in it.
                  > >
                  > > I might be able to better determine what's going on if you can
                  > > produce a sample file against which I could test.
                  >
                  > Tim, and Christian:
                  >
                  > I have reduced the file to something very short - however, at some point the error changed to E147: Cannot do :global recursive. Here is the short version:
                  >
                  > ###########
                  > 2010.09.06
                  >
                  > Enter more city directory data - I already have quite a lot for my family in
                  > spreadsheets.
                  >
                  > ###########
                  >
                  > There are 5 lines, the last one being empty. Lines 3 and 4 are each terminated by a LF.
                  >
                  > I'm not sure if I may be misunderstanding the original proposal, to do
                  > :g/^\</'{+,'}-j
                  >
                  > Was it intended that the entire file should be visually selected first? I hadn't thought so.
                  >
                  > Thanks for your assistance,
                  > John

                  Sorry for the repost - I just realized I should have attached the test file. Have done so in this message.
                  John

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Christian Brabandt
                  Hi jcordes! ... I think, this happens, because there is no empty first line in your file. Simply add an empty first line in front of everything and I believe
                  Message 8 of 21 , Feb 2, 2013
                  • 0 Attachment
                    Hi jcordes!

                    On Sa, 02 Feb 2013, jcordes wrote:

                    > On Saturday, 2 February 2013 16:09:17 UTC-4, jcordes wrote:
                    > > On Saturday, 2 February 2013 14:40:47 UTC-4, Tim Chase wrote:
                    > > > On Sat, 2 Feb 2013 10:27:27 -0800 (PST), jcordes wrote:
                    > > >
                    > > > > On Friday, 1 February 2013 23:46:03 UTC-4, Tim Chase wrote:
                    > > >
                    > > > > > You could do something like
                    > > >
                    > > > > > :g/^\</'{+,'}-j
                    > > >
                    > > > >
                    > > >
                    > > > > Thanks very much for posting this. Your explanation (in a later
                    > > >
                    > > > > post) makes a lot of sense,
                    > > >
                    > > > > but for some reason I keep coming up
                    > > > > with an 'invalid range' error when I use :g/^\</'{+,'}-j
                    > > >
                    > > > The only way I was able to trigger this was if either:
                    > > >
                    > > > 1) your relative-range happens to be swapped (such that the 2nd line
                    > > > comes before the first line), or
                    > > >
                    > > > 2) if your file only has one line in it.
                    > > >
                    > > > I might be able to better determine what's going on if you can
                    > > > produce a sample file against which I could test.
                    > >
                    > > Tim, and Christian:
                    > >
                    > > I have reduced the file to something very short - however, at some point the error changed to E147: Cannot do :global recursive. Here is the short version:
                    > >
                    > > ###########
                    > > 2010.09.06
                    > >
                    > > Enter more city directory data - I already have quite a lot for my family in
                    > > spreadsheets.
                    > >
                    > > ###########
                    > >
                    > > There are 5 lines, the last one being empty. Lines 3 and 4 are each terminated by a LF.
                    > >
                    > > I'm not sure if I may be misunderstanding the original proposal, to do
                    > > :g/^\</'{+,'}-j
                    > >
                    > > Was it intended that the entire file should be visually selected first? I hadn't thought so.
                    > >
                    > > Thanks for your assistance,
                    > > John
                    >
                    > Sorry for the repost - I just realized I should have attached the test file. Have done so in this message.
                    > John
                    >

                    > 2010.09.06
                    >
                    > Enter more city directory data - I already have quite a lot for my family in
                    > spreadsheets.
                    >

                    I think, this happens, because there is no empty first line in your
                    file. Simply add an empty first line in front of everything and I
                    believe the :g command works.


                    regards,
                    Christian
                    --
                    Sprich leise und höflich, aber trage stets einen dicken Knüppel bei
                    dir.
                    -- Theodor Roosevelt

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Michael Henry
                    ... Thanks! For some reason, I couldn t see any difference in the help text between y and Y , and the empirical testing happened to work because the
                    Message 9 of 21 , Feb 2, 2013
                    • 0 Attachment
                      On 02/02/2013 01:31 PM, Gary Johnson wrote:
                      > On 2013-02-02, Michael Henry wrote:
                      >> I was interested to see the use of visual-mode "Y" above. In
                      >> the Vim help (and in brief empirical testing), I don't see any
                      >> difference between lowercase "y" and uppercase "Y" in visual
                      >> mode.
                      >
                      > I wanted the yank to be done line-wise and it was easier for me to
                      > type Y than to investigate whether y would work as well.

                      Thanks! For some reason, I couldn't see any difference in the
                      help text between "y" and "Y", and the empirical testing
                      happened to work because the original visual selection was done
                      using "V". You've helped me learn something new today :-)

                      Michael Henry

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • jcordes
                      ... Hi Christian, I tried inserting an empty line at the top of the file, but am still experiencing the E147: Cannot do :global recursive If I keep the empty
                      Message 10 of 21 , Feb 2, 2013
                      • 0 Attachment
                        On Saturday, 2 February 2013 17:29:45 UTC-4, Christian Brabandt wrote:
                        > Hi jcordes!
                        >
                        >
                        >
                        > On Sa, 02 Feb 2013, jcordes wrote:
                        >
                        >
                        >
                        > > On Saturday, 2 February 2013 16:09:17 UTC-4, jcordes wrote:
                        >
                        > > > On Saturday, 2 February 2013 14:40:47 UTC-4, Tim Chase wrote:
                        >
                        > > > > On Sat, 2 Feb 2013 10:27:27 -0800 (PST), jcordes wrote:
                        >
                        > > > >
                        >
                        > > > > > On Friday, 1 February 2013 23:46:03 UTC-4, Tim Chase wrote:
                        >
                        > > > >
                        >
                        > > > > > > You could do something like
                        >
                        > > > >
                        >
                        > > > > > > :g/^\</'{+,'}-j
                        >
                        > > > >
                        >
                        > > > > >
                        >
                        > > > >
                        >
                        > > > > > Thanks very much for posting this. Your explanation (in a later
                        >
                        > > > >
                        >
                        > > > > > post) makes a lot of sense,
                        >
                        > > > >
                        >
                        > > > > > but for some reason I keep coming up
                        >
                        > > > > > with an 'invalid range' error when I use :g/^\</'{+,'}-j
                        >
                        > > > >
                        >
                        > > > > The only way I was able to trigger this was if either:
                        >
                        > > > >
                        >
                        > > > > 1) your relative-range happens to be swapped (such that the 2nd line
                        >
                        > > > > comes before the first line), or
                        >
                        > > > >
                        >
                        > > > > 2) if your file only has one line in it.
                        >
                        > > > >
                        >
                        > > > > I might be able to better determine what's going on if you can
                        >
                        > > > > produce a sample file against which I could test.
                        >
                        > > >
                        >
                        > > > Tim, and Christian:
                        >
                        > > >
                        >
                        > > > I have reduced the file to something very short - however, at some point the error changed to E147: Cannot do :global recursive. Here is the short version:
                        >
                        > > >
                        >
                        > > > ###########
                        >
                        > > > 2010.09.06
                        >
                        > > >
                        >
                        > > > Enter more city directory data - I already have quite a lot for my family in
                        >
                        > > > spreadsheets.
                        >
                        > > >
                        >
                        > > > ###########
                        >
                        > > >
                        >
                        > > > There are 5 lines, the last one being empty. Lines 3 and 4 are each terminated by a LF.
                        >
                        > > >
                        >
                        > > > I'm not sure if I may be misunderstanding the original proposal, to do
                        >
                        > > > :g/^\</'{+,'}-j
                        >
                        > > >
                        >
                        > > > Was it intended that the entire file should be visually selected first? I hadn't thought so.
                        >
                        > > >
                        >
                        > > > Thanks for your assistance,
                        >
                        > > > John
                        >
                        > >
                        >
                        > > Sorry for the repost - I just realized I should have attached the test file. Have done so in this message.
                        >
                        > > John
                        >
                        > >
                        >
                        >
                        >
                        > > 2010.09.06
                        >
                        > >
                        >
                        > > Enter more city directory data - I already have quite a lot for my family in
                        >
                        > > spreadsheets.
                        >
                        > >
                        >
                        >
                        >
                        > I think, this happens, because there is no empty first line in your
                        >
                        > file. Simply add an empty first line in front of everything and I
                        >
                        > believe the :g command works.
                        >
                        >
                        >
                        >
                        >
                        > regards,
                        >
                        > Christian

                        Hi Christian,

                        I tried inserting an empty line at the top of the file, but am still experiencing the E147: Cannot do :global recursive

                        If I keep the empty top line and visually select the entire file, then the command works as expected. This also works for the original file I was working with. So in summary, inserting an empty line at the top *and* visually selecting the entire file enables the command to work.
                        Perhaps I misunderstood the original message and it was intended to select the whole file first.

                        Thanks,
                        John Cordes


                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • vim@...
                        ... It looks like it s the first line causing trouble. So I d expand my caveat to have a blank line at both the top and bottom of the file . I think it
                        Message 11 of 21 , Feb 2, 2013
                        • 0 Attachment
                          > I have reduced the file to something very short - however, at some
                          > point the error changed to E147: Cannot do :global recursive. Here
                          > is the short version:
                          >
                          > ###########
                          > 2010.09.06
                          >
                          > Enter more city directory data - I already have quite a lot for my
                          > family in spreadsheets.
                          >
                          > ###########

                          It looks like it's the first line causing trouble. So I'd expand my
                          caveat to "have a blank line at both the top and bottom of the
                          file". I think it stems from the '{ mark being the first line rather
                          than the zero'th line, so when you add one to it, it points to line
                          #2, coming *after* the '}-minus-one line (the top solitary line of
                          text)

                          Usually the E147 about ":global recursive" gets triggered when you
                          try something like

                          :g/pattern1/.;+5g/pattern2/d

                          where you try to do a ":g" as the Ex command issued by an outer :g
                          command. I couldn't find the help-target on that one off the top of
                          my head (the help for E147 doesn't give anything on how to remedy
                          that error).

                          -tim


                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        • jcordes
                          ... Thank you Tim. John -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For
                          Message 12 of 21 , Feb 4, 2013
                          • 0 Attachment
                            On Saturday, 2 February 2013 19:55:58 UTC-4, Tim Chase wrote:

                            > > ###########
                            >
                            > > 2010.09.06
                            >
                            > >
                            >
                            > > Enter more city directory data - I already have quite a lot for my
                            >
                            > > family in spreadsheets.
                            >
                            > >
                            >
                            > > ###########
                            >
                            >
                            >
                            > It looks like it's the first line causing trouble. So I'd expand my
                            >
                            > caveat to "have a blank line at both the top and bottom of the
                            >
                            > file". I think it stems from the '{ mark being the first line rather
                            >
                            > than the zero'th line, so when you add one to it, it points to line
                            >
                            > #2, coming *after* the '}-minus-one line (the top solitary line of
                            >
                            > text)
                            >
                            >
                            >
                            > Usually the E147 about ":global recursive" gets triggered when you
                            >
                            > try something like
                            >
                            >
                            >
                            > :g/pattern1/.;+5g/pattern2/d
                            >
                            >
                            >
                            > where you try to do a ":g" as the Ex command issued by an outer :g
                            >
                            > command. I couldn't find the help-target on that one off the top of
                            >
                            > my head (the help for E147 doesn't give anything on how to remedy
                            >
                            > that error).
                            >
                            >
                            >
                            > -tim

                            Thank you Tim.

                            John

                            --
                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          Your message has been successfully submitted and would be delivered to recipients shortly.