Loading ...
Sorry, an error occurred while loading the content.

gvim color scheme in vim

Expand Messages
  • rudrab
    Dear friends, I am using slate color scheme in gvim(vim-X11 package in fedora). The problem is this color scheme (and many other) is not obeyed by vim. So,
    Message 1 of 7 , Feb 1, 2013
    • 0 Attachment
      Dear friends,
      I am using slate color scheme in gvim(vim-X11 package in fedora).
      The problem is this color scheme (and many other) is not obeyed by vim. So, while slate is dark, vim is still showing white background and comments on yellow (neither is a slate scheme).
      Even more basic packages like blue are rendering color differently.
      In my $VIMRUNTIME, I do have those packages installed.
      So, what is the way to use same color scheme both in vim and gvim?
      NB: I can see vim's color changed if I use, say, :colo slate in vim terminal; only that the color is different from what is seen in gvim.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Phil Dobbin
      ... I use the GTK2 version of gVim on Fedora & I experience no difficulties with colours displaying correctly. What values do you have set in your gvimrc?
      Message 2 of 7 , Feb 1, 2013
      • 0 Attachment
        On 02/01/2013 10:16 AM, rudrab wrote:

        > Dear friends,
        > I am using slate color scheme in gvim(vim-X11 package in fedora).
        > The problem is this color scheme (and many other) is not obeyed by vim. So, while slate is dark, vim is still showing white background and comments on yellow (neither is a slate scheme).
        > Even more basic packages like blue are rendering color differently.
        > In my $VIMRUNTIME, I do have those packages installed.
        > So, what is the way to use same color scheme both in vim and gvim?
        > NB: I can see vim's color changed if I use, say, :colo slate in vim terminal; only that the color is different from what is seen in gvim.

        I use the GTK2 version of gVim on Fedora & I experience no difficulties
        with colours displaying correctly.

        What values do you have set in your gvimrc?

        Cheers,

        Phil...

        --
        currently (ab)using
        CentOS 5.8 & 6.3, Debian Squeeze & Wheezy, Fedora Beefy & Spherical,
        Lubuntu 12.10, OS X Snow Leopard & Ubuntu Precise & Quantal
      • Rudra Banerjee
        Mine is also gtk-2 version. my vimrc looks like(I only use vimrc, not gvimrc) set autoindent set smartindent set incsearch set ignorecase set smartcase set
        Message 3 of 7 , Feb 1, 2013
        • 0 Attachment
          Mine is also gtk-2 version.
          my vimrc looks like(I only use vimrc, not gvimrc)
          set autoindent
          set smartindent
          set incsearch
          set ignorecase
          set smartcase
          set novisualbell
          set paste
          set ruler
          "set expandtab
          "set smarttab
          "set shiftwidth=3
          "set softtabstop=3
          colorscheme slate

          Here is the complete gvim version:
          $ gvim --version
          VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Nov 12 2012 14:43:48)
          Included patches: 1-415, 417-712
          Modified by <bugzilla@...>
          Compiled by <bugzilla@...>
          Huge version with GTK2 GUI. Features included (+) or not (-):
          +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
          +cindent
          +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
          +comments
          +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
          +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
          +file_in_path +find_in_path +float +folding -footer +fork() +gettext
          -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
          +linebreak +lispindent +listcmds +localmap -lua +menu +mksession
          +modify_fname
          +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm
          +mouse_sgr -mouse_sysmouse +mouse_urxvt +mouse_xterm +multi_byte
          +multi_lang
          -mzscheme +netbeans_intg +path_extra +perl +persistent_undo +postscript
          +printer +profile +python/dyn -python3 +quickfix +reltime +rightleft
          +ruby/dyn
          +scrollbind +signs +smartindent -sniff +startuptime +statusline
          -sun_workshop
          +syntax +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
          +termresponse
          +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
          +visual
          +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
          +writebackup
          +X11 -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
          system vimrc file: "/etc/vimrc"
          user vimrc file: "$HOME/.vimrc"
          user exrc file: "$HOME/.exrc"
          system gvimrc file: "/etc/gvimrc"
          user gvimrc file: "$HOME/.gvimrc"
          system menu file: "$VIMRUNTIME/menu.vim"
          fall-back for $VIM: "/etc"
          f-b for $VIMRUNTIME: "/usr/share/vim/vim73"
          Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread
          -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include
          -I/usr/include/atk-1.0 -I/usr/include/cairo
          -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0
          -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
          -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15
          -I/usr/include/libdrm -I/usr/include/harfbuzz -I/usr/local/include
          -O2 -g -pipe -Wall -fexceptions -fstack-protector
          --param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE
          -D_FILE_OFFSET_BITS=64 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
          Linking: gcc -L. -Wl,-z,relro -rdynamic -Wl,-export-dynamic
          -Wl,--enable-new-dtags -Wl,-rpath,/usr/lib64/perl5/CORE -Wl,-z,relro
          -L/usr/local/lib -Wl,--as-needed -o vim -lgtk-x11-2.0 -lgdk-x11-2.0
          -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0
          -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0
          -lSM -lICE -lXpm -lXt -lX11 -lSM -lICE -lm -lnsl -lselinux -lncurses
          -lacl -lattr -lgpm -ldl -Wl,--enable-new-dtags
          -Wl,-rpath,/usr/lib64/perl5/CORE -fstack-protector
          -L/usr/lib64/perl5/CORE -lperl -lresolv -lnsl -ldl -lm -lcrypt -lutil
          -lpthread -lc


          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Erik Christiansen
          ... To use the same colour scheme in almost all applications, I set the colours in the xterm: $ xterm -fg yellow -bg darkslategrey -cr red For several decades
          Message 4 of 7 , Feb 1, 2013
          • 0 Attachment
            On 01.02.13 02:16, rudrab wrote:
            > So, what is the way to use same color scheme both in vim and gvim?

            To use the same colour scheme in almost all applications, I set the
            colours in the xterm:

            $ xterm -fg yellow -bg darkslategrey -cr red

            For several decades now, that has provided me with consistent colours,
            without the need to fiddle with inconsistent alternatives, in different
            ways in individual applications.

            Erik

            --
            The only thing worse than X Windows: (X Windows) - X

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Phil Dobbin
            ... [snip for brevity] You could try putting this in a gvimrc: colorscheme hybrid syntax on set guifont=Monospace 011 replacing the values for colorscheme &
            Message 5 of 7 , Feb 1, 2013
            • 0 Attachment
              On 02/01/2013 10:35 AM, Rudra Banerjee wrote:

              > Mine is also gtk-2 version.
              > my vimrc looks like(I only use vimrc, not gvimrc)
              > set autoindent
              > set smartindent
              > set incsearch
              > set ignorecase
              > set smartcase
              > set novisualbell
              > set paste
              > set ruler
              > "set expandtab
              > "set smarttab
              > "set shiftwidth=3
              > "set softtabstop=3
              > colorscheme slate
              >
              > Here is the complete gvim version:
              > $ gvim --version
              > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Nov 12 2012 14:43:48)
              > Included patches: 1-415, 417-712

              [snip for brevity]

              You could try putting this in a gvimrc:

              'colorscheme hybrid

              syntax on

              set guifont=Monospace\ 011'

              replacing the values for colorscheme & guifont with your own.

              It may help.

              Cheers,

              Phil...

              --
              currently (ab)using
              CentOS 5.8 & 6.3, Debian Squeeze & Wheezy, Fedora Beefy & Spherical,
              Lubuntu 12.10, OS X Snow Leopard & Ubuntu Precise & Quantal
            • Rudra Banerjee
              ... No improvement :( -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For
              Message 6 of 7 , Feb 1, 2013
              • 0 Attachment
                On Fri, 2013-02-01 at 10:51 +0000, Phil Dobbin wrote:
                > You could try putting this in a gvimrc:
                >
                > 'colorscheme hybrid
                >
                > syntax on
                >
                > set guifont=Monospace\ 011'
                >
                > replacing the values for colorscheme & guifont with your own.
                >
                > It may help.
                >
                > Cheers,
                >
                > Phil...
                >
                No improvement :(

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Ben Fritz
                ... Terminal Vim uses color codes 1-8, 1-16, 1-88, 1-256, etc. depending on how many colors your color terminal supports. These color codes correspond to
                Message 7 of 7 , Feb 1, 2013
                • 0 Attachment
                  On Friday, February 1, 2013 4:16:39 AM UTC-6, rudrab wrote:
                  > Dear friends,
                  > I am using slate color scheme in gvim(vim-X11 package in fedora).
                  > The problem is this color scheme (and many other) is not obeyed by vim. So, while slate is dark, vim is still showing white background and comments on yellow (neither is a slate scheme).
                  > Even more basic packages like blue are rendering color differently.
                  > In my $VIMRUNTIME, I do have those packages installed.
                  > So, what is the way to use same color scheme both in vim and gvim?
                  > NB: I can see vim's color changed if I use, say, :colo slate in vim terminal; only that the color is different from what is seen in gvim.

                  Terminal Vim uses color codes 1-8, 1-16, 1-88, 1-256, etc. depending on how many colors your color terminal supports. These color codes correspond to different actual colors depending on your terminal and the setup of that terminal.

                  GUI gvim uses full 24-bit RGB color specifications like #c0ffee

                  Many color schemes do not even bother setting up terminal colors. Even those that do rarely give exact matches.

                  There are a couple plugins which translate the GUI colors into the closest matching terminal color codes.

                  See the following for a little more detail:

                  http://vim.wikia.com/wiki/Using_GUI_color_settings_in_a_terminal

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                Your message has been successfully submitted and would be delivered to recipients shortly.