Loading ...
Sorry, an error occurred while loading the content.

Re: Windows ALT characters

Expand Messages
  • Tony Mechelynck
    ... You already got several replies about how to remove them. Those Ctrl-Z characters are a leftover from DOS ASCII mode, where they signaled end-of-file.
    Message 1 of 5 , Jan 30, 2013
    • 0 Attachment
      On 30/01/13 02:53, John McGlynn wrote:
      > Hi Vim,
      >
      > I have a load of csv files in which some rows have an arrow at the end.
      > The arrow seems to have been made using Windows ALT 26.
      >
      > It shows up in Vim as ^Z^M.
      >
      > Can anyone tell me how to remove these pesky objects?
      >
      > Thanks,
      >
      > John

      You already got several replies about how to remove them.

      Those Ctrl-Z characters are a leftover from DOS "ASCII" mode, where they
      signaled end-of-file. When reading a file, DOS used to disregard the
      Ctrl-Z and everything after it. This peculiarity was used when typing in
      a file at the console (to be read via a < redirection): the user typed
      Ctrl-Z to signal the end of data and come back to the command prompt.

      The Ctrl-M is a carriage return, which may have been added by some
      program unaware of the special meaning of the Ctrl-Z.


      Best regards,
      Tony.
      --
      Unquestionably, there is progress. The average American now pays out
      twice as much in taxes as he formerly got in wages.
      -- H. L. Mencken

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... In the past, I discovered the hard way that Perl (at least, ActivePerl on Windows) also treats the CTRL-Z as end of file and stops processing. Certainly
      Message 2 of 5 , Jan 30, 2013
      • 0 Attachment
        On Wednesday, January 30, 2013 7:51:01 AM UTC-6, Tony Mechelynck wrote:
        > On 30/01/13 02:53, John McGlynn wrote:
        >
        > > Hi Vim,
        >
        > >
        >
        > > I have a load of csv files in which some rows have an arrow at the end.
        >
        > > The arrow seems to have been made using Windows ALT 26.
        >
        > >
        >
        > > It shows up in Vim as ^Z^M.
        >
        > >
        >
        > > Can anyone tell me how to remove these pesky objects?
        >
        > >
        >
        > > Thanks,
        >
        > >
        >
        > > John
        >
        >
        >
        > You already got several replies about how to remove them.
        >
        >
        >
        > Those Ctrl-Z characters are a leftover from DOS "ASCII" mode, where they
        >
        > signaled end-of-file. When reading a file, DOS used to disregard the
        >
        > Ctrl-Z and everything after it. This peculiarity was used when typing in
        >
        > a file at the console (to be read via a < redirection): the user typed
        >
        > Ctrl-Z to signal the end of data and come back to the command prompt.
        >
        >
        >
        > The Ctrl-M is a carriage return, which may have been added by some
        >
        > program unaware of the special meaning of the Ctrl-Z.
        >
        >

        In the past, I discovered the hard way that Perl (at least, ActivePerl on Windows) also treats the CTRL-Z as "end of file" and stops processing. Certainly removing them is a good idea.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.