Loading ...
Sorry, an error occurred while loading the content.

Re: doxygen.vim: missing space before *

Expand Messages
  • Jeroen Budts
    Hi Christian, ... I found that it is caused by an indent file for php that I m using. It is this script:
    Message 1 of 5 , Jan 26, 2013
    • 0 Attachment
      Hi Christian,

      On 01/26/2013 03:22 PM, Christian Brabandt wrote:
      > Hi Jeroen!
      >
      > On Sa, 26 Jan 2013, Jeroen Budts wrote:
      >
      >> On 01/25/2013 04:53 PM, Ben Fritz wrote:
      >>> On Friday, January 25, 2013 6:31:03 AM UTC-6, Jeroen Budts wrote:
      >>>> I recently enabled the doxygen.vim script (part of Vim) to highlight
      >>>> phpdoc inside php files. (let g:load_doxygen_syntax=1 in my .vimrc)
      >>>> When I start typing a phpdoc and press enter, Vim inserts a *, but
      >>>> without a space before it:
      >>>> /**
      >>>> * <- after <enter> vim auto inserts this
      >>>>
      >>>> With the doxygen-script disabled this is the (correct) behaviour:
      >>>> /**
      >>>> * <- after <enter> a leading space is inserted
      >>>>
      >>>> Does anyone know how this can be fixed?
      >>>> My 'formatoptions' are set as follows: qrowcb
      >>>
      >>> It looks like your 'comments' option has been set incorrectly.
      >>>
      >>> Take a look at :help 'comments' and :help format-comments, and then
      >>> you'll probably need to make use of the after directory to fix
      >>> whatever the plugin breaks.
      >>>
      >> I checked the value of 'comments' but both with or without doxygen.vim
      >> enabled I can see no difference in the 'comments' option:
      >>
      >> :verbose set comments?
      >> comments=s1:/*,mb:*,ex:*/,://,:#
      >> Last set from /usr/share/vim/vim73/indent/php.vim
      >>
      >> When my syntax is set to simply 'php' I have the expected behaviour, but
      >> when I set the syntax to php.doxygen the space before the * is missing,
      >> although the 'comments' option has exactly the same (correct?) value.
      >>
      >> I checked the doxygen.vim script (which is at
      >> /usr/share/vim/vim73/syntax/doxygen.vim) in my Vim install, but I can't
      >> see anything related to this functionality.
      >>
      >> I just tested doing the same with syntax=c.doxygen and there it works as
      >> expected...
      >
      > I can't reproduce it with the latest Vim and runtime files. Can you
      > reproduce the issue, starting from vim -u NONE -N?
      >
      I found that it is caused by an indent file for php that I'm using. It
      is this script:
      http://vim.wikia.com/wiki/Better_indent_support_for_php_with_html. If I
      disabled that, everything works as expected. The indent script is
      however useful when working with files which contain both html and php
      (such as templates files), but it is not entirely clear what's the exact
      problem.

      Thanks,
      Jeroen



      --
      website: http://budts.be/ - twitter: @teranex
      ___________________________________
      Registered Linux User #482240 - GetFirefox.com - ubuntu.com



      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.