Loading ...
Sorry, an error occurred while loading the content.

doxygen.vim: missing space before *

Expand Messages
  • Jeroen Budts
    ... Hash: SHA256 Hi all, I recently enabled the doxygen.vim script (part of Vim) to highlight phpdoc inside php files. (let g:load_doxygen_syntax=1 in my
    Message 1 of 5 , Jan 25, 2013
    • 0 Attachment
      -----BEGIN PGP SIGNED MESSAGE-----
      Hash: SHA256

      Hi all,

      I recently enabled the doxygen.vim script (part of Vim) to highlight
      phpdoc inside php files. (let g:load_doxygen_syntax=1 in my .vimrc)

      When I start typing a phpdoc and press enter, Vim inserts a *, but
      without a space before it:
      /**
      * <- after <enter> vim auto inserts this

      With the doxygen-script disabled this is the (correct) behaviour:
      /**
      * <- after <enter> a leading space is inserted

      Does anyone know how this can be fixed?
      My 'formatoptions' are set as follows: qrowcb

      thank you!
      Jeroen
      -----BEGIN PGP SIGNATURE-----
      Version: GnuPG v2.0.17 (GNU/Linux)

      iQIcBAEBCAAGBQJRAnsGAAoJEBrqc/v4ufiMmSgQAODW6xq/L5WVHYTRUZNDbnBa
      9C5OEoayJUergV/sZLnTblzzXhkq3SsDPG8RuGJb9CZVtgIsPxe1MgZW+uivCRDg
      kyez7VQgxw9aG10w42A0NLHnBEM9Azy4AzAs8f1AS2gUdp/WKDQfL4smt5ZdU2N0
      b3RqXa0sYv9fbtJAjzMRHoHEh6p52X+t0EANWGXW+vj+el1ZyGgtgqCEkUzZ7GAS
      /xitzzG1DiIvb662rKt+E1Js8GHwWV0ja+sf8juXA1TmY6mxeZ8WohA6SHeHlVG0
      u8qqqnPxG1cwJZ+1qd+70TSxvnzxbIlb7FNjaflyIQMc/Grts8TzgQo6DvrP1sPQ
      71yTT6nO6Cgg3bNum/m/FgSx+YW6zPhKNQRsDcFt/4PUn0uP5QuHaapL1Q27TWRF
      101ib3iqldntgFAf5TDMtaCaNqFRk755Bp7FjCs2iph1jDjRrfZrDBsEXGrdLVZb
      7yFDFdn2zDSZDe2/HtgUrWYyMbJVChK5Cm4yxE71UIb7IcskYjhKp9dpTOThYvH2
      w3NlRrZsQ7/o+macSNWAQpjuF4awWH6n0OF0Nk7UR6hXo3yB4LSBiJOnQZZF19bF
      eoNEZ5YICWAEC359BtuSr2P7y6/yykoS+XKvrrwouMJWJROOT6/qSGzFjZfB3u4N
      M0p8Haw9Yj6czNd0rPuK
      =NErQ
      -----END PGP SIGNATURE-----

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Ben Fritz
      ... It looks like your comments option has been set incorrectly. Take a look at :help comments and :help format-comments, and then you ll probably need to
      Message 2 of 5 , Jan 25, 2013
      • 0 Attachment
        On Friday, January 25, 2013 6:31:03 AM UTC-6, Jeroen Budts wrote:
        > -----BEGIN PGP SIGNED MESSAGE-----
        >
        > Hash: SHA256
        >
        >
        >
        > Hi all,
        >
        >
        >
        > I recently enabled the doxygen.vim script (part of Vim) to highlight
        >
        > phpdoc inside php files. (let g:load_doxygen_syntax=1 in my .vimrc)
        >
        >
        >
        > When I start typing a phpdoc and press enter, Vim inserts a *, but
        >
        > without a space before it:
        >
        > /**
        >
        > * <- after <enter> vim auto inserts this
        >
        >
        >
        > With the doxygen-script disabled this is the (correct) behaviour:
        >
        > /**
        >
        > * <- after <enter> a leading space is inserted
        >
        >
        >
        > Does anyone know how this can be fixed?
        >
        > My 'formatoptions' are set as follows: qrowcb
        >
        >
        >

        It looks like your 'comments' option has been set incorrectly.

        Take a look at :help 'comments' and :help format-comments, and then you'll probably need to make use of the after directory to fix whatever the plugin breaks.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Jeroen Budts
        ... I checked the value of comments but both with or without doxygen.vim ... comments=s1:/*,mb:*,ex:*/,://,:# Last set from
        Message 3 of 5 , Jan 26, 2013
        • 0 Attachment
          On 01/25/2013 04:53 PM, Ben Fritz wrote:
          > On Friday, January 25, 2013 6:31:03 AM UTC-6, Jeroen Budts wrote:
          >> I recently enabled the doxygen.vim script (part of Vim) to highlight
          >> phpdoc inside php files. (let g:load_doxygen_syntax=1 in my .vimrc)
          >> When I start typing a phpdoc and press enter, Vim inserts a *, but
          >> without a space before it:
          >> /**
          >> * <- after <enter> vim auto inserts this
          >>
          >> With the doxygen-script disabled this is the (correct) behaviour:
          >> /**
          >> * <- after <enter> a leading space is inserted
          >>
          >> Does anyone know how this can be fixed?
          >> My 'formatoptions' are set as follows: qrowcb
          >
          > It looks like your 'comments' option has been set incorrectly.
          >
          > Take a look at :help 'comments' and :help format-comments, and then
          > you'll probably need to make use of the after directory to fix
          > whatever the plugin breaks.
          >
          I checked the value of 'comments' but both with or without doxygen.vim
          enabled I can see no difference in the 'comments' option:

          :verbose set comments?
          comments=s1:/*,mb:*,ex:*/,://,:#
          Last set from /usr/share/vim/vim73/indent/php.vim

          When my syntax is set to simply 'php' I have the expected behaviour, but
          when I set the syntax to php.doxygen the space before the * is missing,
          although the 'comments' option has exactly the same (correct?) value.

          I checked the doxygen.vim script (which is at
          /usr/share/vim/vim73/syntax/doxygen.vim) in my Vim install, but I can't
          see anything related to this functionality.

          I just tested doing the same with syntax=c.doxygen and there it works as
          expected...

          Any other suggestions?

          Thank you!
          Jeroen

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Christian Brabandt
          Hi Jeroen! ... I can t reproduce it with the latest Vim and runtime files. Can you reproduce the issue, starting from vim -u NONE -N? regards, Christian -- Arm
          Message 4 of 5 , Jan 26, 2013
          • 0 Attachment
            Hi Jeroen!

            On Sa, 26 Jan 2013, Jeroen Budts wrote:

            > On 01/25/2013 04:53 PM, Ben Fritz wrote:
            > > On Friday, January 25, 2013 6:31:03 AM UTC-6, Jeroen Budts wrote:
            > >> I recently enabled the doxygen.vim script (part of Vim) to highlight
            > >> phpdoc inside php files. (let g:load_doxygen_syntax=1 in my .vimrc)
            > >> When I start typing a phpdoc and press enter, Vim inserts a *, but
            > >> without a space before it:
            > >> /**
            > >> * <- after <enter> vim auto inserts this
            > >>
            > >> With the doxygen-script disabled this is the (correct) behaviour:
            > >> /**
            > >> * <- after <enter> a leading space is inserted
            > >>
            > >> Does anyone know how this can be fixed?
            > >> My 'formatoptions' are set as follows: qrowcb
            > >
            > > It looks like your 'comments' option has been set incorrectly.
            > >
            > > Take a look at :help 'comments' and :help format-comments, and then
            > > you'll probably need to make use of the after directory to fix
            > > whatever the plugin breaks.
            > >
            > I checked the value of 'comments' but both with or without doxygen.vim
            > enabled I can see no difference in the 'comments' option:
            >
            > :verbose set comments?
            > comments=s1:/*,mb:*,ex:*/,://,:#
            > Last set from /usr/share/vim/vim73/indent/php.vim
            >
            > When my syntax is set to simply 'php' I have the expected behaviour, but
            > when I set the syntax to php.doxygen the space before the * is missing,
            > although the 'comments' option has exactly the same (correct?) value.
            >
            > I checked the doxygen.vim script (which is at
            > /usr/share/vim/vim73/syntax/doxygen.vim) in my Vim install, but I can't
            > see anything related to this functionality.
            >
            > I just tested doing the same with syntax=c.doxygen and there it works as
            > expected...

            I can't reproduce it with the latest Vim and runtime files. Can you
            reproduce the issue, starting from vim -u NONE -N?

            regards,
            Christian
            --
            Arm ist nicht der, der wenig hat, sondern der, der nicht genug
            bekommen kann.
            -- Jean Guehenno

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Jeroen Budts
            Hi Christian, ... I found that it is caused by an indent file for php that I m using. It is this script:
            Message 5 of 5 , Jan 26, 2013
            • 0 Attachment
              Hi Christian,

              On 01/26/2013 03:22 PM, Christian Brabandt wrote:
              > Hi Jeroen!
              >
              > On Sa, 26 Jan 2013, Jeroen Budts wrote:
              >
              >> On 01/25/2013 04:53 PM, Ben Fritz wrote:
              >>> On Friday, January 25, 2013 6:31:03 AM UTC-6, Jeroen Budts wrote:
              >>>> I recently enabled the doxygen.vim script (part of Vim) to highlight
              >>>> phpdoc inside php files. (let g:load_doxygen_syntax=1 in my .vimrc)
              >>>> When I start typing a phpdoc and press enter, Vim inserts a *, but
              >>>> without a space before it:
              >>>> /**
              >>>> * <- after <enter> vim auto inserts this
              >>>>
              >>>> With the doxygen-script disabled this is the (correct) behaviour:
              >>>> /**
              >>>> * <- after <enter> a leading space is inserted
              >>>>
              >>>> Does anyone know how this can be fixed?
              >>>> My 'formatoptions' are set as follows: qrowcb
              >>>
              >>> It looks like your 'comments' option has been set incorrectly.
              >>>
              >>> Take a look at :help 'comments' and :help format-comments, and then
              >>> you'll probably need to make use of the after directory to fix
              >>> whatever the plugin breaks.
              >>>
              >> I checked the value of 'comments' but both with or without doxygen.vim
              >> enabled I can see no difference in the 'comments' option:
              >>
              >> :verbose set comments?
              >> comments=s1:/*,mb:*,ex:*/,://,:#
              >> Last set from /usr/share/vim/vim73/indent/php.vim
              >>
              >> When my syntax is set to simply 'php' I have the expected behaviour, but
              >> when I set the syntax to php.doxygen the space before the * is missing,
              >> although the 'comments' option has exactly the same (correct?) value.
              >>
              >> I checked the doxygen.vim script (which is at
              >> /usr/share/vim/vim73/syntax/doxygen.vim) in my Vim install, but I can't
              >> see anything related to this functionality.
              >>
              >> I just tested doing the same with syntax=c.doxygen and there it works as
              >> expected...
              >
              > I can't reproduce it with the latest Vim and runtime files. Can you
              > reproduce the issue, starting from vim -u NONE -N?
              >
              I found that it is caused by an indent file for php that I'm using. It
              is this script:
              http://vim.wikia.com/wiki/Better_indent_support_for_php_with_html. If I
              disabled that, everything works as expected. The indent script is
              however useful when working with files which contain both html and php
              (such as templates files), but it is not entirely clear what's the exact
              problem.

              Thanks,
              Jeroen



              --
              website: http://budts.be/ - twitter: @teranex
              ___________________________________
              Registered Linux User #482240 - GetFirefox.com - ubuntu.com



              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.