Loading ...
Sorry, an error occurred while loading the content.

Re: Word characters differ between spell files

Expand Messages
  • Tony Mechelynck
    ... [...] ... Unless you want to spellcheck both Russian and English at the same time in the same file, you might try moving away or renaming the English spell
    Message 1 of 4 , Jan 24, 2013
    • 0 Attachment
      On 24/01/13 11:34, Andrew wrote:
      > Hi there! Recently I've started using vim, and tried to enable
      > spellchecking for russian.
      > So I've tried ":setlocal spell spelllang=ru". Vim said, that it doesn't
      > have spellfile for russian and
      > offer to download it, I accepted and allowed him to locate it in
      > ~/.vim/spell/ru.utf-8.spl, also it downloaded ru.utf-8.sug.
      >
      > Then, vim said:
      > "Error detected while processing /home/ridiculous/.vim/spell/ru.utf-8.spl:
      > E763: Word characters differ between spell files."
      >
      > I'm not quite sure, what files does it mean, but I also have the same
      > spell files in /usr/share/vim/vim/73/spell directory. I've tried to
      > delete them, but it doesn't works.
      >
      > Then, I've tried to open file on russian and enter command to enable
      > spellchecking. First, it gave me the same mistake, but for the second
      > time there was nothing on output, but still, there's no highlighting,
      > and "verbose set spelllang" gives me "spelllang=ru".
      [...]

      From ":help E763":

      > *E763*
      > Vim allows you to use spell checking for several languages in the same file.
      > You can list them in the 'spelllang' option. As a consequence all spell files
      > for the same encoding must use the same word characters, otherwise they can't
      > be combined without errors. If you get a warning that the word tables differ
      > you may need to generate the .spl file again with |:mkspell|. Check the FOL,
      > LOW and UPP lines in the used .aff file.
      >
      > The XX.ascii.spl spell file generated with the "-ascii" argument will not
      > contain the table with characters, so that it can be combine with spell files
      > for any encoding. The .add.spl files also do not contain the table.

      Unless you want to spellcheck both Russian and English at the same time
      in the same file, you might try moving away or renaming the English
      spell files which are in $VIMRUNTIME/spell/. (They will reappear the
      next time you update Vim.) If that works, it means that either the
      Russian spell files don't include Latin letters as word characters, or
      the English ones don't include Cyrillic letters, or both.

      Best regards,
      Tony.
      --
      "I was gratified to be able to answer promptly, and I did. I said I
      didn't know."
      -- Mark Twain

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Andrew Fadeev
      Thanks for your answer, Tony. But, could you refine, what FOL, LOW and UPP lines in the used .aff file means? And, respectively, what .aff file is? I ve
      Message 2 of 4 , Jan 28, 2013
      • 0 Attachment

        Thanks for your answer, Tony.

        But, could you refine, what FOL,
        LOW and UPP lines in the used .aff file means? And, respectively, what .aff file is?
        I've started to read "help :mkspell", because I'm not quite represent how to regenerate .spl file manually.


        On Fri, Jan 25, 2013 at 3:15 AM, Tony Mechelynck <antoine.mechelynck@...> wrote:
        On 24/01/13 11:34, Andrew wrote:
        Hi there! Recently I've started using vim, and tried to enable
        spellchecking for russian.
        So I've tried ":setlocal spell spelllang=ru". Vim said, that it doesn't
        have spellfile for russian and
        offer to download it, I accepted and allowed him to locate it in
        ~/.vim/spell/ru.utf-8.spl, also it downloaded ru.utf-8.sug.

        Then, vim said:
        "Error detected while processing /home/ridiculous/.vim/spell/ru.utf-8.spl:
        E763: Word characters differ between spell files."

        I'm not quite sure, what files does it mean, but I also have the same
        spell files in /usr/share/vim/vim/73/spell directory. I've tried to
        delete them, but it doesn't works.

        Then, I've tried to open file on russian and enter command to enable
        spellchecking. First, it gave me the same mistake, but for the second
        time there was nothing on output, but still, there's no highlighting,
        and "verbose set spelllang" gives me "spelllang=ru".
        [...]

        From ":help E763":

                                                                *E763*
        Vim allows you to use spell checking for several languages in the same file.
        You can list them in the 'spelllang' option.  As a consequence all spell files
        for the same encoding must use the same word characters, otherwise they can't
        be combined without errors.  If you get a warning that the word tables differ
        you may need to generate the .spl file again with |:mkspell|.  Check the FOL,
        LOW and UPP lines in the used .aff file.

        The XX.ascii.spl spell file generated with the "-ascii" argument will not
        contain the table with characters, so that it can be combine with spell files
        for any encoding.  The .add.spl files also do not contain the table.

        Unless you want to spellcheck both Russian and English at the same time in the same file, you might try moving away or renaming the English spell files which are in $VIMRUNTIME/spell/. (They will reappear the next time you update Vim.) If that works, it means that either the Russian spell files don't include Latin letters as word characters, or the English ones don't include Cyrillic letters, or both.

        Best regards,
        Tony.
        --
        "I was gratified to be able to answer promptly, and I did.  I said I
        didn't know."
                        -- Mark Twain

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php




        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • Andrew
        ... So I ve tried to make a new .spl file, according to help :mkspell. Therefore I ve downloaded dict_ru_RU-AOT-0.2.7-ieyo.oxt archive from
        Message 3 of 4 , Jan 29, 2013
        • 0 Attachment
          On 25.01.2013 03:15, Tony Mechelynck wrote:
          > On 24/01/13 11:34, Andrew wrote:
          >> Hi there! Recently I've started using vim, and tried to enable
          >> spellchecking for russian.
          >> So I've tried ":setlocal spell spelllang=ru". Vim said, that it doesn't
          >> have spellfile for russian and
          >> offer to download it, I accepted and allowed him to locate it in
          >> ~/.vim/spell/ru.utf-8.spl, also it downloaded ru.utf-8.sug.
          >>
          >> Then, vim said:
          >> "Error detected while processing
          >> /home/ridiculous/.vim/spell/ru.utf-8.spl:
          >> E763: Word characters differ between spell files."
          >>
          >> I'm not quite sure, what files does it mean, but I also have the same
          >> spell files in /usr/share/vim/vim/73/spell directory. I've tried to
          >> delete them, but it doesn't works.
          >>
          >> Then, I've tried to open file on russian and enter command to enable
          >> spellchecking. First, it gave me the same mistake, but for the second
          >> time there was nothing on output, but still, there's no highlighting,
          >> and "verbose set spelllang" gives me "spelllang=ru".
          > [...]
          >
          > From ":help E763":
          >
          >> *E763*
          >> Vim allows you to use spell checking for several languages in the
          >> same file.
          >> You can list them in the 'spelllang' option. As a consequence all
          >> spell files
          >> for the same encoding must use the same word characters, otherwise
          >> they can't
          >> be combined without errors. If you get a warning that the word
          >> tables differ
          >> you may need to generate the .spl file again with |:mkspell|. Check
          >> the FOL,
          >> LOW and UPP lines in the used .aff file.
          >>
          >> The XX.ascii.spl spell file generated with the "-ascii" argument will
          >> not
          >> contain the table with characters, so that it can be combine with
          >> spell files
          >> for any encoding. The .add.spl files also do not contain the table.
          >
          > Unless you want to spellcheck both Russian and English at the same
          > time in the same file, you might try moving away or renaming the
          > English spell files which are in $VIMRUNTIME/spell/. (They will
          > reappear the next time you update Vim.) If that works, it means that
          > either the Russian spell files don't include Latin letters as word
          > characters, or the English ones don't include Cyrillic letters, or both.
          >
          > Best regards,
          > Tony.
          So I've tried to make a new .spl file, according to help :mkspell.
          Therefore I've downloaded
          dict_ru_RU-AOT-0.2.7-ieyo.oxt archive from
          http://extensions.services.openoffice.org/dictionary and unziped it to
          ~/.vim/spell. When I've started to make a spell
          file by :mkspell .aff .dic .spl, it said, that .dic file has an invalid
          region. Then I skiped .dic file in command for creating, so file was
          maden. But when i finally included spellchecking on russian, the same
          error occured...

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.