Loading ...
Sorry, an error occurred while loading the content.
 

Re: I loose Syntax Colors when switching between Buffers

Expand Messages
  • Ben Fritz
    ... There ARE no default automatic filetype and syntax coloring. You need to turn them on like this in your .vimrc: filetype on syntax on Or this: filetype
    Message 1 of 8 , Dec 23, 2012
      On Thursday, December 20, 2012 11:49:16 AM UTC-6, analogsix wrote:
      > My .gvimrc resource file only contains a few custom modifications like:
      > set ...
      > set guifont=...
      > highlight Normal guibg=black
      > colorscheme slate
      > noremap ...
      >
      >
      > I believe I have the default automatic filetype and syntax coloring VIM configuration settings, since there are no syntax-relevant commands in my .gvimrc resource file.
      >

      There ARE no default automatic filetype and syntax coloring. You need to turn them on like this in your .vimrc:

      filetype on
      syntax on

      Or this:

      filetype indent plugin on
      syntax on

      You listed a few generalizations from your .gvimrc but did not mention your .vimrc? What's in there? And do your "few custom modifications" which include some "set" commands ever touch the filetype option?

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.