Loading ...
Sorry, an error occurred while loading the content.

vim: conqueterm : truncated lines

Expand Messages
  • ping
    hi nico and other vim conquetermers: I found this a (relatively) big issue: say if you have your capture of output from a command you issued to your remote
    Message 1 of 5 , Dec 20, 2012
    • 0 Attachment
      hi nico and other vim conquetermers:

      I found this a (relatively) "big" issue:
      say if you have your capture of output from a command you issued to your
      remote machine from within conqterm,
      the big advantage of using conqueterm is the ability to leverage the
      existing vim search knowledge you acquired, but I just found that all
      long lines (longer than 200 chars?) are somewhat truncated, by conqterm.
      this makes the line based search and filtering effort painful.
      is there any knob to disable/ or even enlarge that line-truncation
      limitation ?

      thanks!

      regards
      ping

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • ping
      ... your remote machine from within conqterm, ... existing vim search knowledge you acquired, but I just found that all long lines (longer than 200 chars?) are
      Message 2 of 5 , Dec 20, 2012
      • 0 Attachment
        On 12/20/2012 12:08 PM, ping wrote:
        > hi nico and other vim conquetermers:
        >
        > I found this a (relatively) "big" issue:
        > say if you have your capture of output from a command you issued to
        your remote machine from within conqterm,
        > the big advantage of using conqueterm is the ability to leverage the
        existing vim search knowledge you acquired, but I just found that all
        long lines (longer than 200 chars?) are somewhat truncated, by conqterm.
        > this makes the line based search and filtering effort painful.
        > is there any knob to disable/ or even enlarge that line-truncation
        limitation ?
        >
        > thanks!
        >
        > regards
        > ping
        >

        oh I just realized I can report issues on the project home page:
        http://code.google.com/p/conque/
        so I 'll do it .
        plus , I tested with secureCRT/linux and I'm sure this is conqueterm
        issue.

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • ping
        ... in case someone want to track it, the issue is here: http://code.google.com/p/conque/issues/detail?id=91 this issue is really annoying and I m thinking for
        Message 3 of 5 , Dec 20, 2012
        • 0 Attachment
          On 12/20/2012 12:11 PM, ping wrote:
          >
          > On 12/20/2012 12:08 PM, ping wrote:
          >> hi nico and other vim conquetermers:
          > >
          > > I found this a (relatively) "big" issue:
          > > say if you have your capture of output from a command you issued to
          > your remote machine from within conqterm,
          > > the big advantage of using conqueterm is the ability to leverage the
          > existing vim search knowledge you acquired, but I just found that all
          > long lines (longer than 200 chars?) are somewhat truncated, by conqterm.
          > > this makes the line based search and filtering effort painful.
          > > is there any knob to disable/ or even enlarge that line-truncation
          > limitation ?
          > >
          > > thanks!
          > >
          > > regards
          > > ping
          > >
          >
          > oh I just realized I can report issues on the project home page:
          > http://code.google.com/p/conque/
          > so I 'll do it .
          > plus , I tested with secureCRT/linux and I'm sure this is conqueterm
          > issue.
          >

          in case someone want to track it, the issue is here:
          http://code.google.com/p/conque/issues/detail?id=91

          this issue is really annoying and I'm thinking for now, to move the work
          that I original thought of ideally being done in vim (with conqueterm),
          to outside of vim ,e.g secureCRT for linux...

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • ping
          ... old , unanswered issue... more observation: if I smaller my terminal, and repeat the previous command, the output lines will be truncated, regardless of
          Message 4 of 5 , Mar 6, 2013
          • 0 Attachment
            On 12/20/2012 12:15 PM, ping wrote:
            >
            > On 12/20/2012 12:11 PM, ping wrote:
            >>
            >> On 12/20/2012 12:08 PM, ping wrote:
            >>> hi nico and other vim conquetermers:
            >> >
            >> > I found this a (relatively) "big" issue:
            >> > say if you have your capture of output from a command you issued to
            >> your remote machine from within conqterm,
            >> > the big advantage of using conqueterm is the ability to leverage
            >> the existing vim search knowledge you acquired, but I just found that
            >> all long lines (longer than 200 chars?) are somewhat truncated, by
            >> conqterm.
            >> > this makes the line based search and filtering effort painful.
            >> > is there any knob to disable/ or even enlarge that line-truncation
            >> limitation ?
            >> >
            >> > thanks!
            >> >
            >> > regards
            >> > ping
            >> >
            >>
            >> oh I just realized I can report issues on the project home page:
            >> http://code.google.com/p/conque/
            >> so I 'll do it .
            >> plus , I tested with secureCRT/linux and I'm sure this is conqueterm
            >> issue.
            >>
            >
            > in case someone want to track it, the issue is here:
            > http://code.google.com/p/conque/issues/detail?id=91
            >
            > this issue is really annoying and I'm thinking for now, to move the
            > work that I original thought of ideally being done in vim (with
            > conqueterm), to outside of vim ,e.g secureCRT for linux...
            >
            old , unanswered issue...
            more observation: if I smaller my terminal, and repeat the previous
            command, the output lines will be truncated, regardless of whether I
            have "nowrap" or not.
            Ok, so per this theory,
            if I work from a larger/wider screen, say a 27inch monitor, and maximize
            my cygwin terminal. interestingly all my lines won't be truncated, as
            long as all my lines are shorter than my screen width.
            th is what happens when I use conqterm plugin -- the lines are
            hard-truncated agaist the width of current terminal, regardless of
            "wrap" option.
            well I can't go everywhere with my big monitor ...
            so if this can't be fixed by author of conqueterm, can I have any way to
            temparily "fool" vim (sorry about that) that, I'm actually working in a
            really wide terminal(monitor) here?

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • ping song
            anyone got any resolution for this issue? is conqterm a dead project ? there seems to be no bug fix since 2 years ago... it s just unfortunate since this is
            Message 5 of 5 , Dec 21, 2013
            • 0 Attachment
              anyone got any resolution for this issue?
              is conqterm a dead project ?
              there seems to be no bug fix since 2 years ago...
              it's just unfortunate since this is one of the greatest extensions that far expand vim's magic...


              On Wed, Mar 6, 2013 at 2:16 PM, ping <songpingemail@...> wrote:
              On 12/20/2012 12:15 PM, ping wrote:

              On 12/20/2012 12:11 PM, ping wrote:

              On 12/20/2012 12:08 PM, ping wrote:
              hi nico and other vim  conquetermers:
              >
              > I found this a (relatively) "big" issue:
              > say if you have your capture of output from a command you issued to your remote machine from within conqterm,
              > the big advantage of using conqueterm is the ability to leverage the existing vim search knowledge you acquired, but I just found that all long lines (longer than 200 chars?) are somewhat truncated, by conqterm.
              > this makes the line based search and filtering effort painful.
              > is there any knob to disable/ or even enlarge that line-truncation limitation ?
              >
              > thanks!
              >
              > regards
              > ping
              >

              oh I just realized I can report issues on the project home page: http://code.google.com/p/conque/
              so I 'll do it .
              plus , I tested with secureCRT/linux and I'm sure this is conqueterm
              issue.


              in case someone want to track it, the issue is here: http://code.google.com/p/conque/issues/detail?id=91

              this issue is really annoying and I'm thinking for now, to move the work that I original thought of ideally being done in vim (with conqueterm), to outside of vim ,e.g secureCRT for linux...

              old , unanswered issue...
              more observation: if I smaller my terminal, and repeat the previous command, the output lines will be truncated, regardless of whether I have "nowrap" or not.
              Ok, so per this theory,
              if I work from a larger/wider screen, say a 27inch monitor, and maximize my cygwin terminal. interestingly all my lines won't be truncated, as long as all my lines are shorter than my screen width.
              th is what happens when I use conqterm plugin -- the lines are hard-truncated agaist the width of current terminal, regardless of "wrap" option.
              well I can't go everywhere with my big monitor ...
              so if this can't be fixed by author of conqueterm, can I have any way to temparily "fool" vim (sorry about that) that, I'm actually working in a really wide terminal(monitor) here?


              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.