Loading ...
Sorry, an error occurred while loading the content.

Re: VIM moves file icon location in Windows 7 after file close

Expand Messages
  • Tony Mechelynck
    ... See :help backupcopy Best regards, Tony. -- The National Association of Theater Concessionaires reported that in 1986, 60% of all candy sold in movie
    Message 1 of 4 , Dec 14, 2012
    • 0 Attachment
      On 14/12/12 09:18, SanDiegoGary wrote:
      > I'm using Vim 7.3.67 on Windows 7. I made a change to my .vimrc file, and now when I launch vim by double-clicking a text file on my desktop, the tool works as expected. But when I exit with :wq, the file icon moves as if "auto arrange icons" attribute is set (which it is not). The icon doesn't move with :q
      >
      > The .vimrc change I made was to add:
      > set backup
      > set backupdir=C:\Users\Gary\Temp
      > set backupskip=C:\Users\Gary\Temp
      > set directory=C:\Users\Gary\Temp
      > set writebackup
      >
      > When I comment these change out of my .vimrc, the file icon doesn't move (which is good), but the backup file is auto-added to my desktiop (in an icon aligned way), which I'm trying to avoid...
      >
      > Any ideas? I've done a bunch of google searches, but no luck on this one.
      >
      > Thanks!
      > Gary
      >

      See :help 'backupcopy'


      Best regards,
      Tony.
      --
      "The National Association of Theater Concessionaires reported that in
      1986, 60% of all candy sold in movie theaters was sold to Roger Ebert."
      -- D. Letterman

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • SanDiegoGary
      ... Thanks for the reply Tony! I m not sure what you are suggesting. I read the man page for backupcopy, and tried yes , no and auto as arguments. Each
      Message 2 of 4 , Dec 14, 2012
      • 0 Attachment
        On Friday, December 14, 2012 12:41:50 AM UTC-8, Tony Mechelynck wrote:
        > On 14/12/12 09:18, SanDiegoGary wrote:
        >
        > > I'm using Vim 7.3.67 on Windows 7. I made a change to my .vimrc file, and now when I launch vim by double-clicking a text file on my desktop, the tool works as expected. But when I exit with :wq, the file icon moves as if "auto arrange icons" attribute is set (which it is not). The icon doesn't move with :q
        >
        > >
        >
        > > The .vimrc change I made was to add:
        >
        > > set backup
        >
        > > set backupdir=C:\Users\Gary\Temp
        >
        > > set backupskip=C:\Users\Gary\Temp
        >
        > > set directory=C:\Users\Gary\Temp
        >
        > > set writebackup
        >
        > >
        >
        > > When I comment these change out of my .vimrc, the file icon doesn't move (which is good), but the backup file is auto-added to my desktiop (in an icon aligned way), which I'm trying to avoid...
        >
        > >
        >
        > > Any ideas? I've done a bunch of google searches, but no luck on this one.
        >
        > >
        >
        > > Thanks!
        >
        > > Gary
        >
        > >
        >
        >
        >
        > See :help 'backupcopy'
        >
        >
        >
        >
        >
        > Best regards,
        >
        > Tony.
        >
        > --
        >
        > "The National Association of Theater Concessionaires reported that in
        >
        > 1986, 60% of all candy sold in movie theaters was sold to Roger Ebert."
        >
        > -- D. Letterman

        Thanks for the reply Tony! I'm not sure what you are suggesting. I read the man page for backupcopy, and tried "yes", "no" and "auto" as arguments. Each time the file icon moved. From the man page text, I'm assuming that since a new file is being created, it will ALWAYS be moved? If so, that's too annoying for me, and I'll go back to "set nobackup", and take my chances with .swp file restoration when needed.

        Thanks again,
        Gary

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Tony Mechelynck
        ... I thought that your setting might be the one for creating a new file and renaming the old one as the backup, but if you tried all values and it always
        Message 3 of 4 , Dec 14, 2012
        • 0 Attachment
          On 14/12/12 17:41, SanDiegoGary wrote:
          > On Friday, December 14, 2012 12:41:50 AM UTC-8, Tony Mechelynck wrote:
          >> On 14/12/12 09:18, SanDiegoGary wrote:
          >>
          >>> I'm using Vim 7.3.67 on Windows 7. I made a change to my .vimrc file, and now when I launch vim by double-clicking a text file on my desktop, the tool works as expected. But when I exit with :wq, the file icon moves as if "auto arrange icons" attribute is set (which it is not). The icon doesn't move with :q
          >>
          >>>
          >>
          >>> The .vimrc change I made was to add:
          >>
          >>> set backup
          >>
          >>> set backupdir=C:\Users\Gary\Temp
          >>
          >>> set backupskip=C:\Users\Gary\Temp
          >>
          >>> set directory=C:\Users\Gary\Temp
          >>
          >>> set writebackup
          >>
          >>>
          >>
          >>> When I comment these change out of my .vimrc, the file icon doesn't move (which is good), but the backup file is auto-added to my desktiop (in an icon aligned way), which I'm trying to avoid...
          >>
          >>>
          >>
          >>> Any ideas? I've done a bunch of google searches, but no luck on this one.
          >>
          >>>
          >>
          >>> Thanks!
          >>
          >>> Gary
          >>
          >>>
          >>
          >>
          >>
          >> See :help 'backupcopy'
          >>
          >>
          >>
          >>
          >>
          >> Best regards,
          >>
          >> Tony.
          >>
          >> --
          >>
          >> "The National Association of Theater Concessionaires reported that in
          >>
          >> 1986, 60% of all candy sold in movie theaters was sold to Roger Ebert."
          >>
          >> -- D. Letterman
          >
          > Thanks for the reply Tony! I'm not sure what you are suggesting. I read the man page for backupcopy, and tried "yes", "no" and "auto" as arguments. Each time the file icon moved. From the man page text, I'm assuming that since a new file is being created, it will ALWAYS be moved? If so, that's too annoying for me, and I'll go back to "set nobackup", and take my chances with .swp file restoration when needed.
          >
          > Thanks again,
          > Gary
          >
          I thought that your setting might be the one for creating a new file and
          renaming the old one as the backup, but if you tried all values and it
          always moves it must be something else.

          AFAIK, ":set nobackup writebackup" is usually OK on Vim versions
          compiled with +writebackup (i.e. ":if has('writebackup')" executes the
          "then" branch and not the "else" branch of the if clause). Vim will then
          keep a backup for just long enough to check that the write has succeeded.


          Best regards,
          Tony.
          --
          BEDEVERE: Oooooh!
          LAUNCELOT: No "Aaaaarrrrrrggghhh ... " at the back of the throat.
          BEDEVERE: No! "Oooooh!" in surprise and alarm!
          "Monty Python and the Holy Grail" PYTHON (MONTY)
          PICTURES LTD

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.