Loading ...
Sorry, an error occurred while loading the content.

Re: spell check latex German umlauts

Expand Messages
  • Erik Christiansen
    ... In concordance with several other posters, I have to point out that the 1978-ish a gumpf is an ugly work-around, both in appearance and the trouble it
    Message 1 of 8 , Dec 13, 2012
    • 0 Attachment
      On 13.12.12 15:30, Andreas Groh wrote:
      > Of course, key mappings are a workaround. I included two functions to
      > my .vimrc which can replace all umlauts in the document by the Latex
      > style equivalent and vice versa.

      In concordance with several other posters, I have to point out that the
      1978-ish '"a' gumpf is an ugly work-around, both in appearance and the
      trouble it is causing. To move into the current millennium, and allow
      your tools to natively handle the text, is the real fix.

      The Alt key is very convenient for input of e.g. ä, ü, ö, and it takes
      only a moment to make the mappings. (The fact that you speak of '"a'
      suggests you're not using a German keyboard.) Their use quickly becomes
      automatic, speeding entry of the subsequently readable input.

      Erik

      --
      Patient: "Doctor, doctor, it hurts when I do this."
      Doctor: "So, stop doing do it."

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... Which Alt- or AltGr-key combinations to use depends of course on your OS and locale: see for instance
      Message 2 of 8 , Dec 13, 2012
      • 0 Attachment
        On 14/12/12 04:35, Erik Christiansen wrote:
        > On 13.12.12 15:30, Andreas Groh wrote:
        >> Of course, key mappings are a workaround. I included two functions to
        >> my .vimrc which can replace all umlauts in the document by the Latex
        >> style equivalent and vice versa.
        >
        > In concordance with several other posters, I have to point out that the
        > 1978-ish '"a' gumpf is an ugly work-around, both in appearance and the
        > trouble it is causing. To move into the current millennium, and allow
        > your tools to natively handle the text, is the real fix.
        >
        > The Alt key is very convenient for input of e.g. ä, ü, ö, and it takes
        > only a moment to make the mappings. (The fact that you speak of '"a'
        > suggests you're not using a German keyboard.) Their use quickly becomes
        > automatic, speeding entry of the subsequently readable input.
        >
        > Erik
        >

        Which Alt- or AltGr-key combinations to use depends of course on your OS
        and locale: see for instance
        http://users.skynet.be/antoine.mechelynck/other/keybbe.htm for a Belgian
        keyboard on Linux; but regardless of your national keyboard layout you
        can use the "accents" keymap distributed with Vim (as
        $VIMRUNTIME/keymap/accents.vim where :a gives ä, :o gives ö, etc.), or
        you can use digraphs (where Ctrl-K a : (without spaces) gives ä, Ctrl-K
        o : gives ö, etc. (see ":help digraphs-use" and ":help
        digraphs-default"). Or you can even construct your own keymap to get ä
        by typing "a, ö by typing "o, etc., see
        http://vim.wikia.com/wiki/How_to_make_a_keymap


        Best regards,
        Tony.
        --
        Whenever people agree with me I always feel I must be wrong.
        -- Oscar Wilde

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Andreas Groh
        ... Hello Marcin, Thanks for the hint. I add the double quotes to the tex_isk variable. In this way it is recognised as part of the word and commands like b,
        Message 3 of 8 , Dec 14, 2012
        • 0 Attachment
          > Hi,
          >
          > I am not sure if that will help, but at least you may try. You can
          > change the isk setting (:help isk). To do that in a tex file, assuming
          > that you use the standard syntax file, you should change the value of
          > g:tex_isk in your vimrc file. Changing isk directly will not help.
          >
          > Best,
          > Marcin
          >

          Hello Marcin,

          Thanks for the hint. I add the double quotes to the tex_isk variable. In
          this way it is recognised as part of the word and commands like b, w, *
          work on the whole word. But unfortunately the spell checker doesn't care
          about it.
          However, thanks for trying to provide a solution for the problem I
          described.

          Best regards.

          Andreas

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.