Loading ...
Sorry, an error occurred while loading the content.

gvim incorrect window pos/sizes

Expand Messages
  • Woody Wu
    Hi, List Not sure it s a gvim problem or fluxbox. I start gvim from fluxbox menuitem run , then I get a very big gvim window on the virtual screen. It s
    Message 1 of 5 , Dec 9, 2012
    • 0 Attachment
      Hi, List

      Not sure it's a gvim problem or fluxbox. I start gvim from fluxbox
      menuitem 'run', then I get a very big gvim window on the virtual screen.
      It's title bar locates far outside of the screen, so I cannot click it
      an resize it.

      Does anyone have a clue? Thanks!

      --
      woody
      I can't go back to yesterday - because I was a different person then.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tim Chase
      ... It sounds like your ~/.fluxbox/apps file might contain the stored dimensions of gvim and is restoring them on startup. If so, you should be able to remove
      Message 2 of 5 , Dec 9, 2012
      • 0 Attachment
        > Not sure it's a gvim problem or fluxbox. I start gvim from
        > fluxbox menuitem 'run', then I get a very big gvim window on the
        > virtual screen. It's title bar locates far outside of the screen,
        > so I cannot click it an resize it.
        >
        > Does anyone have a clue? Thanks!

        It sounds like your ~/.fluxbox/apps file might contain the stored
        dimensions of gvim and is restoring them on startup. If so, you
        should be able to remove the corresponding setting lines and use
        Fluxbox->Reconfigure (I don't remember exactly where that Fluxbox
        menu option is stored by default since I've rejiggered my own menu)

        Alternatively, you might have some sort of :winpos command in your
        (g)vimrc file that is moving the window to someplace you don't want.

        As an aside, I have the following in my ~/.fluxbox/keys file that
        allow me to slam a window to the corresponding top/bottom/left/right
        side of the screen:

        Mod4 Left :MoveTo 0 *
        Mod4 Right :MoveTo 0 * Right
        Mod4 Up :MoveTo * 0
        Mod4 Down :MoveTo * 0 Bottom

        so I just use the Win+{left/right/top/bottom} key and it
        automatically pulls the corresponding side to where I want it. I
        can then use Win+rightdrag to resize the window by clicking anywhere
        inside it (your configuration might use Alt+rightdrag to do the
        dragging). You might also be able to use Win/Alt+leftdrag to move
        the window if that's easier. I know Fluxbox can also be configured
        to remember various window-settings, so you might want to change
        those (right-click on the item in the toolbar and change what is
        under the "Remember" menu for the application).

        -tim



        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Woody Wu
        ... I removed gvim info from the ~/.fluxbox/apps, but the strange behavior keeps same. ... I removed everything from my .(g)vimrc and .vim directory, then I
        Message 3 of 5 , Dec 9, 2012
        • 0 Attachment
          On 2012-12-09, Tim Chase <vim@...> wrote:
          >> Not sure it's a gvim problem or fluxbox. I start gvim from
          >> fluxbox menuitem 'run', then I get a very big gvim window on the
          >> virtual screen. It's title bar locates far outside of the screen,
          >> so I cannot click it an resize it.
          >>
          >> Does anyone have a clue? Thanks!
          >
          > It sounds like your ~/.fluxbox/apps file might contain the stored
          > dimensions of gvim and is restoring them on startup. If so, you
          > should be able to remove the corresponding setting lines and use
          > Fluxbox->Reconfigure (I don't remember exactly where that Fluxbox
          > menu option is stored by default since I've rejiggered my own menu)
          >

          I removed gvim info from the ~/.fluxbox/apps, but the strange behavior
          keeps same.

          > Alternatively, you might have some sort of :winpos command in your
          > (g)vimrc file that is moving the window to someplace you don't want.
          >

          I removed everything from my .(g)vimrc and .vim directory, then I found
          the behavior is caused by a single line:

          set guifont=Bitstream\ Vera\ Sans\ Mono\ 11

          That means, if I changed the font from my rc file, the gvim window will
          become very large and I cannot even find its title bar to move it. But
          the strange behavior won't happen if I start gvim from kconsole or rxvt.

          I think this is a gvim problem, right?

          > As an aside, I have the following in my ~/.fluxbox/keys file that
          > allow me to slam a window to the corresponding top/bottom/left/right
          > side of the screen:
          >
          > Mod4 Left :MoveTo 0 *
          > Mod4 Right :MoveTo 0 * Right
          > Mod4 Up :MoveTo * 0
          > Mod4 Down :MoveTo * 0 Bottom
          >

          Thanks for this. But when I doing this in my .fluxbox/keys, things
          broken. When I pressed the Win key + Left, my window simply disappeared
          and I cannot find out where it is. What I can do then, is to kill it
          from command line.


          --
          woody
          I can't go back to yesterday - because I was a different person then.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Roland Puntaier
          Hi I didn t follow you problem from the beginning, but scanning through this mail I thought to give you the heads up about Patch 7.3.717, which relates to font
          Message 4 of 5 , Dec 10, 2012
          • 0 Attachment
            Hi

            I didn't follow you problem from the beginning, but scanning through
            this mail
            I thought to give you the heads up about Patch 7.3.717, which relates to
            font /window size.
            If your vim is before that (:version), then give 7.3.717+ a try.

            Regard, Roland


            On 12/10/2012 5:41 AM, Woody Wu wrote:
            > On 2012-12-09, Tim Chase <vim@...> wrote:
            >>> Not sure it's a gvim problem or fluxbox. I start gvim from
            >>> fluxbox menuitem 'run', then I get a very big gvim window on the
            >>> virtual screen. It's title bar locates far outside of the screen,
            >>> so I cannot click it an resize it.
            >>>
            >>> Does anyone have a clue? Thanks!
            >> It sounds like your ~/.fluxbox/apps file might contain the stored
            >> dimensions of gvim and is restoring them on startup. If so, you
            >> should be able to remove the corresponding setting lines and use
            >> Fluxbox->Reconfigure (I don't remember exactly where that Fluxbox
            >> menu option is stored by default since I've rejiggered my own menu)
            >>
            > I removed gvim info from the ~/.fluxbox/apps, but the strange behavior
            > keeps same.
            >
            >> Alternatively, you might have some sort of :winpos command in your
            >> (g)vimrc file that is moving the window to someplace you don't want.
            >>
            > I removed everything from my .(g)vimrc and .vim directory, then I found
            > the behavior is caused by a single line:
            >
            > set guifont=Bitstream\ Vera\ Sans\ Mono\ 11
            >
            > That means, if I changed the font from my rc file, the gvim window will
            > become very large and I cannot even find its title bar to move it. But
            > the strange behavior won't happen if I start gvim from kconsole or rxvt.
            >
            > I think this is a gvim problem, right?
            >
            >> As an aside, I have the following in my ~/.fluxbox/keys file that
            >> allow me to slam a window to the corresponding top/bottom/left/right
            >> side of the screen:
            >>
            >> Mod4 Left :MoveTo 0 *
            >> Mod4 Right :MoveTo 0 * Right
            >> Mod4 Up :MoveTo * 0
            >> Mod4 Down :MoveTo * 0 Bottom
            >>
            > Thanks for this. But when I doing this in my .fluxbox/keys, things
            > broken. When I pressed the Win key + Left, my window simply disappeared
            > and I cannot find out where it is. What I can do then, is to kill it
            > from command line.
            >
            >

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Woody Wu
            ... Many thansk for the info. Now my vim is 7.3.645. I will try the new version as you suggested. ... -- woody I can t go back to yesterday - because I was a
            Message 5 of 5 , Dec 11, 2012
            • 0 Attachment
              On 2012-12-11, Roland Puntaier <roland.puntaier@...> wrote:
              > Hi
              >
              > I didn't follow you problem from the beginning, but scanning through
              > this mail
              > I thought to give you the heads up about Patch 7.3.717, which relates to
              > font /window size.
              > If your vim is before that (:version), then give 7.3.717+ a try.
              >
              > Regard, Roland

              Many thansk for the info. Now my vim is 7.3.645. I will try the new
              version as you suggested.

              >
              >
              > On 12/10/2012 5:41 AM, Woody Wu wrote:
              >> On 2012-12-09, Tim Chase <vim@...> wrote:
              >>>> Not sure it's a gvim problem or fluxbox. I start gvim from
              >>>> fluxbox menuitem 'run', then I get a very big gvim window on the
              >>>> virtual screen. It's title bar locates far outside of the screen,
              >>>> so I cannot click it an resize it.
              >>>>
              >>>> Does anyone have a clue? Thanks!
              >>> It sounds like your ~/.fluxbox/apps file might contain the stored
              >>> dimensions of gvim and is restoring them on startup. If so, you
              >>> should be able to remove the corresponding setting lines and use
              >>> Fluxbox->Reconfigure (I don't remember exactly where that Fluxbox
              >>> menu option is stored by default since I've rejiggered my own menu)
              >>>
              >> I removed gvim info from the ~/.fluxbox/apps, but the strange behavior
              >> keeps same.
              >>
              >>> Alternatively, you might have some sort of :winpos command in your
              >>> (g)vimrc file that is moving the window to someplace you don't want.
              >>>
              >> I removed everything from my .(g)vimrc and .vim directory, then I found
              >> the behavior is caused by a single line:
              >>
              >> set guifont=Bitstream\ Vera\ Sans\ Mono\ 11
              >>
              >> That means, if I changed the font from my rc file, the gvim window will
              >> become very large and I cannot even find its title bar to move it. But
              >> the strange behavior won't happen if I start gvim from kconsole or rxvt.
              >>
              >> I think this is a gvim problem, right?
              >>
              >>> As an aside, I have the following in my ~/.fluxbox/keys file that
              >>> allow me to slam a window to the corresponding top/bottom/left/right
              >>> side of the screen:
              >>>
              >>> Mod4 Left :MoveTo 0 *
              >>> Mod4 Right :MoveTo 0 * Right
              >>> Mod4 Up :MoveTo * 0
              >>> Mod4 Down :MoveTo * 0 Bottom
              >>>
              >> Thanks for this. But when I doing this in my .fluxbox/keys, things
              >> broken. When I pressed the Win key + Left, my window simply disappeared
              >> and I cannot find out where it is. What I can do then, is to kill it
              >> from command line.
              >>
              >>
              >


              --
              woody
              I can't go back to yesterday - because I was a different person then.

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.