Loading ...
Sorry, an error occurred while loading the content.

Slow vim (gvim) 7.3 on first startup

Expand Messages
  • Rick
    Background: I installed Vim 7.3 from Solaris 8 library packages downloaded from unixpackages.com (formerly sunfreeware.com) on a Solaris 10 machine to an nfs
    Message 1 of 2 , Dec 7, 2012
    • 0 Attachment
      Background: I installed Vim 7.3 from Solaris 8 library packages
      downloaded from unixpackages.com (formerly sunfreeware.com) on a
      Solaris 10 machine to an nfs mounted NetApp file system.

      Problem: After invoking gvim for example from the command line, it
      takes about 5-10 seconds for the GUI to be displayed. Every time
      after that, it comes up immediately. If I log outof the server and
      log back in again, it takes that same 5-10 for the first invocation
      and immediate thereafter.

      Problem-solving: I performed a "gvim --startuptime gvim.init.log
      <file a>" for the initial run and compared it to each of the logs from
      subsequent logs and and saw a blatant difference in elapsed time in
      the "starting GUI" task. For example the elapsed time for the
      "starting GUI" task for one of the initial invocations was: 6052.747
      and a subsequent invocation was 432.376. This difference was
      consistent despite the type/size of the file being loaded. All of the
      other tasks were consistent across all invocations.

      Does anyone have any experience in this area? Anyone else see this
      issue?

      thanks,

      rick

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Marc Weber
      options: - compare with xclock or such to make sure its not X related - try any of the followming options gvim vim DISPLAY= gvim - script relatedc? don t
      Message 2 of 2 , Dec 8, 2012
      • 0 Attachment
        options:
        - compare with xclock or such to make sure its not X related
        - try any of the followming options
        gvim
        vim
        DISPLAY= gvim
        - script relatedc? don't source custom .vimrc files:
        (g)vim -u NONE -U NONE -N

        - try vim then type :gui to start

        > Problem: After invoking gvim for example from the command line, it
        > takes about 5-10 seconds for the GUI to be displayed. Every time
        > after that, it comes up immediately. If I log outof the server and
        > log back in again, it takes that same 5-10 for the first invocation
        > and immediate thereafter.

        Maybe don't try to solve the problem, but work around it if keeping a
        session open makes everything faster. SSH supports

        Host *
        ControlPath ~/.ssh/master-%r@%h:%p
        ControlMaster auto

        which means the second ssh connection will reuse the first one if its
        still alive.

        Even if this does not solve your issue - it may help tracking down what
        is causing it.

        Marc Weber

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.