Loading ...
Sorry, an error occurred while loading the content.

E490: no fold found

Expand Messages
  • bernhard42@googlemail.com
    I m using MacVim Snapshot 65 (Vim 7.3.646) on Snow Leopard. I wanted syntax highlighting and especially folding for markdown files by headings (#, ##, etc.).
    Message 1 of 4 , Dec 6, 2012
    • 0 Attachment
      I'm using MacVim Snapshot 65 (Vim 7.3.646) on Snow Leopard.

      I wanted syntax highlighting and especially folding for markdown files by headings (#, ##, etc.). So I installed pathogen. After this I ran:

      curl -Sso ~/.vim/bundle/vim-markdown/ https://github.com/tpope/vim-markdown.git

      After adjusting my .vimrc according to the instructions it now looks like this:

      call pathogen#infect()
      syntax on
      filetype plugin indent on

      colo zenburn
      set encoding=utf8
      set fileformat=unix
      set fileformats=unix
      set fileencoding=utf8
      set nu
      set guioptions=

      This worked fine and I got syntax highlighting working. Since I'm using .markdown as file extension that was expected. What I didn't expect, was Vim telling me "E490: no fold found" when opening one of my markdown files and pressing zc to close a fold.

      I don't have the slightest clue as to what would be causing this error.

      Greetings

      Bernhard

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Christian Brabandt
      ... If I haven t missed anything, there is no folding enabled in neither the filetype plugin nor the syntax file. This is explains your error message. If you
      Message 2 of 4 , Dec 6, 2012
      • 0 Attachment
        On Thu, December 6, 2012 10:42, bernhard42@... wrote:
        > I'm using MacVim Snapshot 65 (Vim 7.3.646) on Snow Leopard.
        >
        > I wanted syntax highlighting and especially folding for markdown files by
        > headings (#, ##, etc.). So I installed pathogen. After this I ran:
        >
        > curl -Sso ~/.vim/bundle/vim-markdown/
        > https://github.com/tpope/vim-markdown.git
        >
        > After adjusting my .vimrc according to the instructions it now looks like
        > this:
        >
        > call pathogen#infect()
        > syntax on
        > filetype plugin indent on
        >
        > colo zenburn
        > set encoding=utf8
        > set fileformat=unix
        > set fileformats=unix
        > set fileencoding=utf8
        > set nu
        > set guioptions=
        >
        > This worked fine and I got syntax highlighting working. Since I'm using
        > .markdown as file extension that was expected. What I didn't expect, was
        > Vim telling me "E490: no fold found" when opening one of my markdown files
        > and pressing zc to close a fold.
        >
        > I don't have the slightest clue as to what would be causing this error.
        >

        If I haven't missed anything, there is no folding enabled in neither
        the filetype plugin nor the syntax file. This is explains your
        error message. If you can explain in more detail what you'd like
        to have folded, we can probably get you working.

        regards,
        Christian

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Ben Fritz
        ... This is unrelated to your problem, but you should move that set encoding=utf8 line way up to the very top of your .vimrc file to prevent that any text
        Message 3 of 4 , Dec 6, 2012
        • 0 Attachment
          On Thursday, December 6, 2012 3:42:45 AM UTC-6, bernh...@... wrote:
          >
          > After adjusting my .vimrc according to the instructions it now looks like this:
          >
          > call pathogen#infect()
          > syntax on
          > filetype plugin indent on
          >
          > colo zenburn
          > set encoding=utf8
          > set fileformat=unix
          > set fileformats=unix
          > set fileencoding=utf8
          > set nu
          > set guioptions=
          >

          This is unrelated to your problem, but you should move that set encoding=utf8 line way up to the very top of your .vimrc file to prevent that any text stored in Vim gets reinterpreted in the wrong encoding without conversion. Also Vim accepts "utf8" as an alias, but really the encoding name it expects is "utf-8".

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Chris Lott
          On Thu, Dec 6, 2012 at 12:42 AM, bernhard42@googlemail.com ... Some answers here should help: http://stackoverflow.com/questions/3828606/vim-markdown-folding
          Message 4 of 4 , Dec 6, 2012
          • 0 Attachment
            On Thu, Dec 6, 2012 at 12:42 AM, bernhard42@...
            <bernhard42@...> wrote:
            > I'm using MacVim Snapshot 65 (Vim 7.3.646) on Snow Leopard.
            >
            > I wanted syntax highlighting and especially folding for markdown files by headings (#, ##, etc.).

            Some answers here should help:
            http://stackoverflow.com/questions/3828606/vim-markdown-folding

            But I would recommend considering the Pandoc plugin, which handles
            markdown folding and adds much more:
            https://github.com/vim-pandoc/vim-pandoc

            c
            --
            Chris Lott <chris@...>

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.