Loading ...
Sorry, an error occurred while loading the content.
 

Re: Vim + tmux with mouse support questions

Expand Messages
  • shawn wilson
    i don t have a solution for you - I saw this same thing with tmux and found :res / :vertical resize or C-W -/+, , =/| actually worked faster anyway. more
    Message 1 of 3 , Nov 30, 2012
      i don't have a solution for you - I saw this same thing with tmux and
      found :res / :vertical resize or C-W -/+, </>, =/| actually worked
      faster anyway. more fluid too. so, if anyone has a solution, i'll
      probably use it just to be able to show off vim coolness with the
      mouse again, but it won't do anything for my productivity :)

      this is not (necessarily) an issue with putty as i use rxvt+u and
      screen-256color terminal

      also, this is with mouse=all with vim 7.3

      i'm guessing this is a tmux issue where it is stealing whatever mouse
      terminal command or signal (i don't really know how mice interact with
      the terminal) vim would use to respond the way you want. if this is
      the case, and you get no working response, there's a tmux user list as
      well with a decent community you might look to. (though something like
      this should go in vim's faq somewhere)


      On Thu, Nov 29, 2012 at 6:51 PM, xiebo212 <xiebo212@...> wrote:
      > Hi,
      >
      > I am pretty new for vim and tmux, and exploring right now. I have vim set up
      > on terminal (using putty) with mouse support, but when I moved to tmux.
      > Found a couple of problems.
      >
      > (1) I like quickfix window, use :ccopen to open quickfix window in vim, and
      > I can resize the quickfix window with mouse without any problem. But in tmux
      > + vim, mouse doesn't seem to work in resizing quickfix window (using mouse
      > to click into quickfix window is fine). Note that I was able to use mouse to
      > select/resize pan in tmux by the following settings.
      > set-option -g mode-mouse on
      > set-option -g mouse-select-pane on
      > set-option -g mouse-select-window on
      > set-option -g mouse-resize-pane on
      >
      > The problem here seems to be, how to enable mouse to resize a
      > window(quickfix window, NOT tmux window) inside one tmux pane.
      >
      > (2) I installed and enabled ctags and taglist in my vim setup. I can use
      > mouse to resize taglist window. But when I moved to tmux, taglist window can
      > still be opened and entered, but the window resize using mouse seems
      > disabled. This is similiar situation in quickfix window.
      >
      > Does anybody has an idea about how to fix these problems? I wish I can
      > entirely move to tmux using vim+mouse to improve productivity.
      >
      > Thanks a lot,
      > Bo
      >
      >
      >
      > --
      > View this message in context: http://vim.1045645.n5.nabble.com/Vim-tmux-with-mouse-support-questions-tp5712363.html
      > Sent from the Vim - General mailing list archive at Nabble.com.
      >
      > --
      > You received this message from the "vim_use" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • xiebo212
      Thanks Shawn. I also used command to get around of these types of problems, but haven t tried vertical resize. Will try all your suggestions. Thanks a lot. Bo
      Message 2 of 3 , Dec 3, 2012
        Thanks Shawn. I also used command to get around of these types of problems,
        but haven't tried vertical resize. Will try all your suggestions.

        Thanks a lot.
        Bo



        --
        View this message in context: http://vim.1045645.n5.nabble.com/Vim-tmux-with-mouse-support-questions-tp5712363p5712425.html
        Sent from the Vim - General mailing list archive at Nabble.com.

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.