Loading ...
Sorry, an error occurred while loading the content.

Re: Mouse handling in urxvt

Expand Messages
  • John Little
    ... My first suspect would be your .vimrc. A way to debug it is to add the line finish at the beginning, restart vim. If the problem s gone, move it to the
    Message 1 of 5 , Nov 22, 2012
    • 0 Attachment
      On Friday, November 23, 2012 6:22:32 AM UTC+13, Johannes Deutsch wrote:
      >So it seems for me that there is a setting in one of these filenames
      >returned by ':scriptnames':
      > 1: ~/.vimrc
      > ...
      > Unfortunately i don't know how to debug the startup of vim and which
      > setting could interfere with the mouse settings.

      My first suspect would be your .vimrc. A way to debug it is to add the line

      finish

      at the beginning, restart vim. If the problem's gone, move it to the middle, restart, and binary chop till you find the culprit.

      Regards, John

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Johannes Deutsch
      On Thu, 22 Nov 2012 16:20:21 -0800 (PST) ... Thank you for the tip! In the meanwhile i found the malefactor. The following mapping in my .vimrc broke the urxvt
      Message 2 of 5 , Nov 23, 2012
      • 0 Attachment
        On Thu, 22 Nov 2012 16:20:21 -0800 (PST)
        John Little <John.B.Little@...> wrote:

        > On Friday, November 23, 2012 6:22:32 AM UTC+13, Johannes Deutsch
        > wrote:
        > >So it seems for me that there is a setting in one of these filenames
        > >returned by ':scriptnames':
        > > 1: ~/.vimrc
        > > ...
        > > Unfortunately i don't know how to debug the startup of vim and which
        > > setting could interfere with the mouse settings.
        >
        > My first suspect would be your .vimrc. A way to debug it is to add
        > the line
        >
        > finish
        >
        > at the beginning, restart vim. If the problem's gone, move it to the
        > middle, restart, and binary chop till you find the culprit.
        >

        Thank you for the tip!

        In the meanwhile i found the malefactor. The following mapping in
        my .vimrc broke the urxvt mouse support:

        noremap <ESC> <C-\><C-N>

        Probably it interferes the interpretation of escape sequences send by
        mouse events.

        I replaced it with

        autocmd CmdwinEnter * noremap <buffer> <C-c> <C-\><C-N>

        and everything works as expected again. Although i think a mapping of
        <ESC> to <C-\><C-N> is convenient it seems that i have to do it without
        it.

        best regards and thanks for your time

        Johannes


        > Regards, John
        >


        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.