Loading ...
Sorry, an error occurred while loading the content.

unmap

Expand Messages
  • cyboman
    I m need to unmap a few of my mappings, but for some reason the unmap command doesn t work. To see what mappings I have I enter the following command ... The
    Message 1 of 3 , Nov 22, 2012
    • 0 Attachment
      I'm need to unmap a few of my mappings, but for some reason the unmap command doesn't work. To see what mappings I have I enter the following command
      :map

      The output I get looks like this:
      n -x *@dd
      n Q *@x

      Which led me to believe that -x and Q are mapped in the normal mode. However when I tried running
      nunmap Q

      I got an error, saying the following
      E31: No such mapping.

      I also tried running
      unmap Q

      and I still got an error saying
      E31: No such error.

      Does anybody know what am I doing wrong?

      Any help is appreciated.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Christian Brabandt
      ... Those are buffer-local mappings. You need to add the flag to your unmap command, e.g. nunmap Q regards, Christian -- You received this
      Message 2 of 3 , Nov 22, 2012
      • 0 Attachment
        On Thu, November 22, 2012 16:17, cyboman wrote:
        > I'm need to unmap a few of my mappings, but for some reason the unmap
        > command doesn't work. To see what mappings I have I enter the following
        > command
        > :map
        >
        > The output I get looks like this:
        > n -x *@dd
        > n Q *@x
        >
        > Which led me to believe that -x and Q are mapped in the normal mode.
        > However when I tried running
        > nunmap Q
        >
        > I got an error, saying the following
        > E31: No such mapping.
        >
        > I also tried running
        > unmap Q
        >
        > and I still got an error saying
        > E31: No such error.
        >
        > Does anybody know what am I doing wrong?

        Those are buffer-local mappings. You need to add the <buffer> flag
        to your unmap command, e.g.
        nunmap <buffer> Q

        regards,
        Christian

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Andy Wokula
        ... -- Andy -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For more
        Message 3 of 3 , Nov 22, 2012
        • 0 Attachment
          Am 22.11.2012 16:17, schrieb cyboman:
          > I'm need to unmap a few of my mappings, but for some reason the unmap
          > command doesn't work. To see what mappings I have I enter the
          > following command
          > :map
          >
          > The output I get looks like this:
          > n -x *@dd
          > n Q *@x
          >
          > Which led me to believe that -x and Q are mapped in the normal mode.
          > However when I tried running
          > nunmap Q
          >
          > I got an error, saying the following
          > E31: No such mapping.
          >
          > I also tried running
          > unmap Q
          >
          > and I still got an error saying
          > E31: No such error.
          >
          > Does anybody know what am I doing wrong?
          >
          > Any help is appreciated.

          See also (for meaning of `*@' in the map listing):
          :h map-listing

          --
          Andy

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.