Loading ...
Sorry, an error occurred while loading the content.
 

Re: Rewrapping long lined email quotes

Expand Messages
  • Christian Brabandt
    ... Make sure, your formatoptions include q and c (In Vim, check the output of :set fo? or even :verbose set fo?). I can then successfully use gqap on such
    Message 1 of 6 , Nov 19, 2012
      On Mon, November 19, 2012 08:32, Chris Lott wrote:
      > I'm trying to take email that has quotes with long lines:
      >
      > > a really long line here that wraps that has no wraps in it and
      > > drives
      > me crazy
      >
      > and format them to:
      >
      > > a really long line here that wraps that has no wraps in it and
      > > drives me crazy
      >
      > I've tried the tip(s) at:
      > http://vim.wikia.com/wiki/Fix_email_quotations_with_long_lines
      >
      > but I just end up with:
      >
      > > a really long line here that wraps that has
      > no wraps in it and drives me crazy
      >
      > (note the lack of a > on the second line).

      Make sure, your formatoptions include 'q' and 'c' (In Vim, check the
      output of :set fo? or even :verbose set fo?). I can then successfully
      use gqap on such a paragraph and have it nicely reformat and inserting
      quotation signs where needed. Other then that, I don't think I set any
      other options for writing Emails.

      Oh and forget that tip about ':set editor=vim -c...' this is just
      plain wrong. The correct approach would make use of filetype plugins
      where you can customize all needed options.

      regards,
      Christian

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Ben Fritz
      ... -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For more information, visit
      Message 2 of 6 , Nov 19, 2012
        On Monday, November 19, 2012 1:32:44 AM UTC-6, Chris Lott wrote:
        > I'm trying to take email that has quotes with long lines:
        >
        >
        >
        > > a really long line here that wraps that has no wraps in it and drives
        >
        > me crazy
        >
        >
        >
        > and format them to:
        >
        >
        >
        > > a really long line here that wraps that has
        >
        > > no wraps in it and drives me crazy
        >
        >
        >
        > I've tried the tip(s) at:
        >
        > http://vim.wikia.com/wiki/Fix_email_quotations_with_long_lines
        >
        >
        >
        > but I just end up with:
        >
        >
        >
        > > a really long line here that wraps that has
        >
        > no wraps in it and drives me crazy
        >
        >
        >
        > (note the lack of a > on the second line).
        >
        >
        >
        > This seems like it should be easy, but I am just not making it happen. Help?
        >

        Probably all you're missing is:

        :set filetype=mail

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Ben Fritz
        ... I ve cleaned up the tip page. How s it look now? Feel free to redo any of it, but I think it s more accurate and helpful now. -- You received this message
        Message 3 of 6 , Nov 19, 2012
          On Monday, November 19, 2012 2:55:37 AM UTC-6, Christian Brabandt wrote:
          > On Mon, November 19, 2012 08:32, Chris Lott wrote:
          > >
          > > I've tried the tip(s) at:
          > > http://vim.wikia.com/wiki/Fix_email_quotations_with_long_lines
          > >
          >
          > Oh and forget that tip about ':set editor=vim -c...' this is just
          > plain wrong. The correct approach would make use of filetype plugins
          > where you can customize all needed options.
          >

          I've cleaned up the tip page. How's it look now? Feel free to redo any of it, but I think it's more accurate and helpful now.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Christian Brabandt
          ... Thanks, good work. I cleaned it up even more and added some more information regarding how to use the mail.vim filetype. regards, Christian -- You received
          Message 4 of 6 , Nov 19, 2012
            On Mon, November 19, 2012 16:21, Ben Fritz wrote:
            > On Monday, November 19, 2012 2:55:37 AM UTC-6, Christian Brabandt wrote:
            >> On Mon, November 19, 2012 08:32, Chris Lott wrote:
            >> >
            >> > I've tried the tip(s) at:
            >> > http://vim.wikia.com/wiki/Fix_email_quotations_with_long_lines
            >> >
            >>
            >> Oh and forget that tip about ':set editor=vim -c...' this is just
            >> plain wrong. The correct approach would make use of filetype plugins
            >> where you can customize all needed options.
            >>
            >
            > I've cleaned up the tip page. How's it look now? Feel free to redo any of
            > it, but I think it's more accurate and helpful now.

            Thanks, good work. I cleaned it up even more and added some more
            information regarding how to use the mail.vim filetype.

            regards,
            Christian

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.