Loading ...
Sorry, an error occurred while loading the content.

E763: Word characters differ between spell files

Expand Messages
  • glts
    Hello list ... Since the de_ch spelllang isn t included by default, Vim downloads and installs it automatically at ~/.vim/spell/de.utf-8.spl (also the
    Message 1 of 6 , Nov 14, 2012
    • 0 Attachment
      Hello list

      I am trying to use two spelling languages at the same time:

      :set spelllang=en_gb,de_ch
      :set spell

      Since the de_ch spelllang isn't included by default, Vim downloads and
      installs it automatically at ~/.vim/spell/de.utf-8.spl (also the
      suggestions file at ~/.vim/spell/de.utf-8.sug).

      Spell-checking does work fine for both languages, however, every time I
      enable spell-checking I get

      E763: Word characters differ between spell files

      The help suggests doing :mkspell on the word lists but these are not
      included with Vim. Can you help me fix this? I'm running Vim 7.3.429.

      Thank you, glts

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Hubert Lubaczewski
      Hi, I have this problem on two hosts, each running Linux, one is: =$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu
      Message 2 of 6 , Apr 24, 2013
      • 0 Attachment
        Hi,
        I have this problem on two hosts, each running Linux, one is:

        =$ lsb_release -a
        No LSB modules are available.
        Distributor ID: Ubuntu
        Description: Ubuntu 12.04.2 LTS
        Release: 12.04
        Codename: precise

        the other:
        No LSB modules are available.
        Distributor ID: Debian
        Description: Debian GNU/Linux 7.0 (wheezy)
        Release: 7.0
        Codename: wheezy

        All the commands I'll run and show are on ubuntu.

        Installed these packages:

        $ dpkg -l | grep vim
        ii vim-common 2:7.3.429-2ubu Vi IMproved - Common files
        ii vim-doc 2:7.3.429-2ubu Vi IMproved - HTML documentation
        ii vim-gtk 2:7.3.429-2ubu Vi IMproved - enhanced vi editor - with GTK2
        ii vim-gui-common 2:7.3.429-2ubu Vi IMproved - Common GUI files
        ii vim-runtime 2:7.3.429-2ubu Vi IMproved - Runtime files

        In home dir, I have no customizations (for test user, for my normal user I have lots of things in .vimrc and .vim, but I wanted clean state for the test).

        To test spell, I created test file (test.txt) with following content:

        I bad-word good-word .
        I zarzółć zażółć .
        I comfuter computer .

        So, I open the file with vim, and do:

        :setlocal spelllang=pl,en_us
        :set spell

        After the second command I'm getting questions:

        Shall I create /home/testvim/.vim/spell -=> Y
        Cannot find spell file for "pl" in utf-8
        Do you want me to try downloading it? -=> Y
        In which directory do you want to write the file:
        1. /home/testvim/.vim/spell -=> 1
        Do you want me to try getting the .sug file? ... -=> 1

        This fails, because there is no sug file for .pl, but regardless, I get:

        Error detected while processing /usr/share/vim/vim73/spell/en.utf-8.spl:
        E763: Word characters differ between spell files

        Interestingly - both dictionaries work, and only bad words are hilighted.

        I know I can silence the alert in my own .vimrc, but it just doesn't seem sane.

        What is wrong and how can it be fixed?

        Pages I found on google suggested refetching spell files, but I didn't have any (at least in ~/.vim) for the test.

        Is there any information I should provide to let someone diagnose and fix it?

        depesz

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • glts
        Did you see this Stackoverflow thread? http://stackoverflow.com/q/14802136/329063 -- -- You received this message from the vim_use maillist. Do not top-post!
        Message 3 of 6 , Apr 24, 2013
        • 0 Attachment
          Did you see this Stackoverflow thread?

          http://stackoverflow.com/q/14802136/329063

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Hubert Lubaczewski
          ... Yes. Please note that I showed that it works on clean installation. Without, quoting: ... spell file that you installed long ago ... depesz -- -- You
          Message 4 of 6 , Apr 24, 2013
          • 0 Attachment
            On Wednesday, April 24, 2013 10:29:03 PM UTC+2, glts wrote:
            > Did you see this Stackoverflow thread?
            >
            > http://stackoverflow.com/q/14802136/329063

            Yes. Please note that I showed that it works on clean installation. Without, quoting:
            "... spell file that you installed long ago ..."

            depesz

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • glts
            ... Well, you didn t get your Vim from the Mercurial source repo but from a package repo. The runtime files you got may be quite old ... -- -- You received
            Message 5 of 6 , Apr 24, 2013
            • 0 Attachment
              On Wednesday, April 24, 2013 11:30:56 PM UTC+2, Hubert Lubaczewski wrote:
              > On Wednesday, April 24, 2013 10:29:03 PM UTC+2, glts wrote:
              > > Did you see this Stackoverflow thread?
              > >
              > > http://stackoverflow.com/q/14802136/329063
              >
              > Yes. Please note that I showed that it works on clean installation. Without, quoting:
              > "... spell file that you installed long ago ..."

              Well, you didn't get your Vim from the Mercurial source repo but from a
              package repo. The runtime files you got may be quite old ...

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Hubert Lubaczewski
              ... That s excellent point. I did: sudo find /usr/share/vim/ ( -name *.spl -o -name *.sug ) -delete And afterwards - it worked. Had to download spl/sug
              Message 6 of 6 , Apr 24, 2013
              • 0 Attachment
                On Wednesday, April 24, 2013 11:42:28 PM UTC+2, glts wrote:
                > Well, you didn't get your Vim from the Mercurial source repo but from a
                > package repo. The runtime files you got may be quite old ...

                That's excellent point.

                I did:

                sudo find /usr/share/vim/ \( -name '*.spl' -o -name '*.sug' \) -delete

                And afterwards - it worked. Had to download spl/sug for en myself, though.

                Looks like the packaged stuff is somehow bad.

                Thanks a lot.

                depesz

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.