Loading ...
Sorry, an error occurred while loading the content.

Re: Wildcards in Spell-check?

Expand Messages
  • Ian Donegan
    ... That is probably what I will end up doing. I discovered that if I just have it in my .vimrc file, it will not take effect when I restore a session, or like
    Message 1 of 7 , Nov 2, 2012
    • 0 Attachment
      On Friday, November 2, 2012 3:59:45 PM UTC-4, Ben Fritz wrote:
      > On Friday, November 2, 2012 12:57:02 PM UTC-5, Ian Donegan wrote:
      >
      > > >
      >
      > > > :syntax match NoSpellURL 'http://\S*' contains=@NoSpell
      >
      > > >
      >
      > >
      >
      > > Well, I thank you, Ben Fritz. I stuck that line in my .vimrc file and it fixed my problem for the most part. I still do not understand all of the syntax behind it yet but I should be able to figure the rest out with the help of the manual. It has been a pleasure learning from you.
      >
      >
      >
      > If you never apply any other syntax highlighting, I suppose adding it to your .vimrc will work.
      >
      >
      >
      > But more likely eventually you'll edit something syntax highlighted. I suggest wrapping it in a command or syntax plugin of your own.
      >
      >
      >
      > See :help new-filetype for detecting when to apply the plugin. See :help usr_44.txt for setting up the syntax plugin itself.

      That is probably what I will end up doing. I discovered that if I just have it in my .vimrc file, it will not take effect when I restore a session, or like you said, when I edit file types that have other syntax highlighting.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.