Loading ...
Sorry, an error occurred while loading the content.
 

Re: vim cannot indent awk correctly

Expand Messages
  • Ben Fritz
    ... You did not answer this directly, but I did not notice any in your list of files under ~/.vim. ... This was a very important question, which you did not
    Message 1 of 5 , Sep 28, 2012
      On Thursday, September 27, 2012 8:53:18 PM UTC-5, Peng Yu wrote:
      > On Sep 27, 11:47 am, Ben Fritz <fritzophre...@...> wrote:
      >
      > > Your Vim version looks pretty recent. I'm going to assume the standard runtime plugins are also recent.
      > >
      > > Do you have any awk filetype plugins which you've manually installed?
      > >

      You did not answer this directly, but I did not notice any in your list of files under ~/.vim.

      > > How did you achieve the indent you show (i.e. what commands did you execute to achieve that indent)? What are your indent options set to? These are:
      > >
      > > 'autoindent'
      > > 'smartindent'
      > > 'cindent'
      > > 'indentexpr'
      > >

      This was a very important question, which you did not answer at all. If the vim_dev thread which Ben H. linked does not help, then what are the values of your indent options when your are editing an awk file?

      > > Do you have filetype-based indent turned on? I.e., do you have something like:
      > >
      > > filetype plugin indent on
      >
      > I have the above line in my .vimrc. See my .vimrc below.
      >
      >

      Not quite. Your .vimrc has two separate lines:

      filetype plugin on
      filetype indent on

      I'm not sure whether this works as intended; I've never seen it done that way before.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.