Loading ...
Sorry, an error occurred while loading the content.

Autoclose plugin breaks abbreviations expansion

Expand Messages
  • Matteo Riva
    I have installed the vim autoclose plugin[1] which is quite useful but due to the remapping of now insert mode abbreviations aren t expanded anymore
    Message 1 of 6 , Sep 5 6:37 AM
    • 0 Attachment
      I have installed the vim autoclose plugin[1] which is quite useful but
      due to the remapping of <Space> now insert mode abbreviations aren't
      expanded anymore (must do it with CTRL-]).

      Is it possible to have both functionalities together?


      [1] http://www.vim.org/scripts/script.php?script_id=2009

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Christian Brabandt
      ... Are you sure it is autocloses fault? This plugin doesn t remap for me. regards, Christian -- You received this message from the vim_use maillist.
      Message 2 of 6 , Sep 5 6:49 AM
      • 0 Attachment
        On Wed, September 5, 2012 15:37, Matteo Riva wrote:
        > I have installed the vim autoclose plugin[1] which is quite useful but
        > due to the remapping of <Space> now insert mode abbreviations aren't
        > expanded anymore (must do it with CTRL-]).
        >
        > Is it possible to have both functionalities together?
        >
        >
        > [1] http://www.vim.org/scripts/script.php?script_id=2009

        Are you sure it is autocloses fault? This plugin doesn't remap <space>
        for me.

        regards,
        Christian

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Matteo Riva
        ... It does (line 456 of plugin/AutoClose.vim): inoremap = Space() also if I disable the plugin, abbreviations work
        Message 3 of 6 , Sep 5 6:54 AM
        • 0 Attachment
          On Wed, Sep 5, 2012 at 3:49 PM, Christian Brabandt <cblists@...> wrote:
          > Are you sure it is autocloses fault? This plugin doesn't remap <space>
          > for me.

          It does (line 456 of plugin/AutoClose.vim):

          inoremap <buffer> <silent> <Space> <C-R>=<SID>Space()<CR>

          also if I disable the plugin, abbreviations work fine.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Christian Brabandt
          ... This must be a differen AutoClose plugin not the one you mentioned in your first message: http://www.vim.org/scripts/script.php?script_id=2009 This only
          Message 4 of 6 , Sep 5 7:00 AM
          • 0 Attachment
            On Wed, September 5, 2012 15:54, Matteo Riva wrote:
            > On Wed, Sep 5, 2012 at 3:49 PM, Christian Brabandt <cblists@...>
            > wrote:
            >> Are you sure it is autocloses fault? This plugin doesn't remap <space>
            >> for me.
            >
            > It does (line 456 of plugin/AutoClose.vim):
            >
            > inoremap <buffer> <silent> <Space> <C-R>=<SID>Space()<CR>
            >
            > also if I disable the plugin, abbreviations work fine.

            This must be a differen AutoClose plugin not the one you mentioned
            in your first message:
            http://www.vim.org/scripts/script.php?script_id=2009

            This only has 189 lines (and doesn't remap <space>).

            regards,
            Christian

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Matteo Riva
            ... You are right, there are apparently two plugins with that name and I m using this one: https://github.com/Townk/vim-autoclose I might try the other one,
            Message 5 of 6 , Sep 5 7:06 AM
            • 0 Attachment
              On Wed, Sep 5, 2012 at 4:00 PM, Christian Brabandt <cblists@...> wrote:
              > This must be a differen AutoClose plugin not the one you mentioned
              > in your first message:
              > http://www.vim.org/scripts/script.php?script_id=2009
              >
              > This only has 189 lines (and doesn't remap <space>).

              You are right, there are apparently two plugins with that name and I'm
              using this one: https://github.com/Townk/vim-autoclose

              I might try the other one, although the automatic insertion of space is
              nice.

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Christian Brabandt
              ... I have no access to github currently, but you could open an issue at github, requesting that the mapping of space should always prepend a to expand
              Message 6 of 6 , Sep 5 7:13 AM
              • 0 Attachment
                On Wed, September 5, 2012 16:06, Matteo Riva wrote:
                > On Wed, Sep 5, 2012 at 4:00 PM, Christian Brabandt <cblists@...>
                > wrote:
                >> This must be a differen AutoClose plugin not the one you mentioned
                >> in your first message:
                >> http://www.vim.org/scripts/script.php?script_id=2009
                >>
                >> This only has 189 lines (and doesn't remap <space>).
                >
                > You are right, there are apparently two plugins with that name and I'm
                > using this one: https://github.com/Townk/vim-autoclose
                >
                > I might try the other one, although the automatic insertion of space is
                > nice.

                I have no access to github currently, but you could open an issue
                at github, requesting that the mapping of space should always prepend a
                <c-]> to expand abbreviations (this needs at least patch 7.3.489, otherwise
                it is quite un-useful).

                regards,
                Christian

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              Your message has been successfully submitted and would be delivered to recipients shortly.