Loading ...
Sorry, an error occurred while loading the content.

Re: Vim on Vista: right-click 'Edit with Vim' problem

Expand Messages
  • Steve Hall
    ... The Cream installer writes the new install path to that registry location, not sure how the old one could have not been revised unless the Nullsoft
    Message 1 of 14 , Aug 1, 2012
    • 0 Attachment
      On Wed, Aug 1, 2012 at 6:48 AM, Leszek Swirski <leszek.swirski@...> wrote:
      > > Which installer did you run to install Vim 7.3?
      >
      > Cream without Vim, although I can't recall if I was upgrading from 7.2 or not.

      The Cream installer writes the new install path to that registry
      location, not sure how the old one could have not been revised unless
      the Nullsoft WriteRegStr instruction doesn't do this?

      --
      Steve Hall [ digitect dancingpaper com ]
      :: Cream for Vim (http://cream.sourceforge.net)

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • David Fishburn
      ... Steve, sorry for not posting this earlier. When I setup my new Windows 7 64bit I used the Cream installer for basic Vim. I did a pile of searching trying
      Message 2 of 14 , Aug 1, 2012
      • 0 Attachment
        On Aug 1, 2012, at 8:52 AM, Steve Hall <digitect@...> wrote:

        > On Wed, Aug 1, 2012 at 6:48 AM, Leszek Swirski <leszek.swirski@...> wrote:
        >>> Which installer did you run to install Vim 7.3?
        >>
        >> Cream without Vim, although I can't recall if I was upgrading from 7.2 or not.
        >
        > The Cream installer writes the new install path to that registry
        > location, not sure how the old one could have not been revised unless
        > the Nullsoft WriteRegStr instruction doesn't do this?
        >
        > --
        > Steve Hall [ digitect dancingpaper com ]
        > :: Cream for Vim (http://cream.sourceforge.net)
        >

        Steve, sorry for not posting this earlier.

        When I setup my new Windows 7 64bit I used the Cream installer for basic Vim.

        I did a pile of searching trying to determine why since the registry looked correct.

        Anyway, as a different test I ran the Vim installer and everything worked correctly. Then I re-ran the Cream installer to get an updated version and everything has worked fine since.

        --
        David Fishburn

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Gary Johnson
        ... I use the Cream without Cream version of Vim on my Windows XP machine at work and usually keep it updated to the latest release on the Cream site. I
        Message 3 of 14 , Aug 1, 2012
        • 0 Attachment
          On 2012-08-01, David Fishburn wrote:
          > On Aug 1, 2012, at 8:52 AM, Steve Hall wrote:
          >
          > > On Wed, Aug 1, 2012 at 6:48 AM, Leszek Swirski wrote:
          > >>> Which installer did you run to install Vim 7.3?
          > >>
          > >> Cream without Vim, although I can't recall if I was upgrading from 7.2 or not.
          > >
          > > The Cream installer writes the new install path to that registry
          > > location, not sure how the old one could have not been revised unless
          > > the Nullsoft WriteRegStr instruction doesn't do this?
          > >
          > > --
          > > Steve Hall [ digitect dancingpaper com ]
          > > :: Cream for Vim (http://cream.sourceforge.net)
          > >
          >
          > Steve, sorry for not posting this earlier.
          >
          > When I setup my new Windows 7 64bit I used the Cream installer for
          > basic Vim.
          >
          > I did a pile of searching trying to determine why since the
          > registry looked correct.
          >
          > Anyway, as a different test I ran the Vim installer and everything
          > worked correctly. Then I re-ran the Cream installer to get an
          > updated version and everything has worked fine since.

          I use the Cream without Cream version of Vim on my Windows XP
          machine at work and usually keep it updated to the latest release on
          the Cream site. I haven't kept careful track, but it seems that
          after every maybe third installation, the Vim commands disappear
          from the Windows Explorer context menu. Running the installer again
          has always fixed the problem.

          Regards,
          Gary

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • emallove
          ... My workaround is to start a gvim.exe process, then use the right click menu option Edit with existing Vim . This way Windows isn t tasked with finding my
          Message 4 of 14 , Jun 3, 2013
          • 0 Attachment
            On Saturday, April 12, 2008 5:40:13 AM UTC-4, Simon wrote:
            > Hi all,
            >
            >
            >
            > I'm using Gvim on Windows Vista. I originally had Vim installed in 'C:
            >
            > \Program Files\Vim' but after getting annoyed with Vista not allowing
            >
            > me to change the _vimrc file without moving it to the 'virtual store',
            >
            > I decided to uninstall and reinstall in 'C:\Vim'.
            >
            >
            >
            > But since doing that, when I try to open a file by right-clicking and
            >
            > selecting 'Edit with Vim', I get:
            >
            > "gvimext.dll error Error creating process: Check if gvim is in your
            >
            > path!"
            >
            >
            >
            > I do have "C:\Vim\vim71\" in my path.
            >
            >
            >
            > Anyone have any suggestions?

            My workaround is to start a gvim.exe process, then use the right click menu option "Edit with existing Vim". This way Windows isn't tasked with finding my gvim.exe executable.

            -Ethan

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.