Loading ...
Sorry, an error occurred while loading the content.
 

Re: GVim doesn't display Euro symbol ?

Expand Messages
  • Tony Mechelynck
    ... Vim gets its language settings from the OS locale at startup. On Linux, this usually means one of en_US.UTF-8 fr_FR.UTF-8 de_AT.UTF-8 etc., so Vim uses
    Message 1 of 16 , Jul 31, 2012
      On 31/07/12 06:44, Dominique Pellé wrote:
      > Lucas Sanner wrote:
      >
      >>> :language
      >> "LC_COLLATE=French_France.1252;LC_TYPE=C;LC_MONETARY=French_France.
      >> 1252;LC_NUMERIC=C;LC_TIME=French_France.1252"
      >
      > The 1252 there indicates that your locale is not using
      > Unicode but it's using the Windows code page 1252:
      >
      > http://en.wikipedia.org/wiki/Windows-1252
      >
      > I don't know why Gvim on windows uses Windows code page
      > by default and not Unicode. It's annoying. Is it Windows fault or
      > Vim fault? I'm also surprised that I don't see LC_MESSAGES=...
      >
      > I remember that I had the same problem on Windows XP,
      > and that for me setting the LANG env variable to fr_FR.UTF-8
      > worked. I'm not sure why it's not working for you and I don't have
      > a Windows machine to try again.
      >
      > I found this http://superuser.com/questions/207264/gvim-utf-8-in-windows
      > which describe the same problem. The solution seems to
      > be to install libiconv (iconv.dll) as described in above link.
      >
      > See also:
      > http://stackoverflow.com/questions/9591813/what-do-vims-iconv-dll-and-libintl-dll-do
      >
      >>> :verbose set enc?
      >> encoding=utf-8
      >
      > That's good at least.
      >
      > By the way, you never indicated what version of Vim you're using.
      > (output of :version)
      >
      > -- Dominique
      >

      Vim gets its "language" settings from the OS locale at startup. On
      Linux, this usually means one of

      en_US.UTF-8
      fr_FR.UTF-8
      de_AT.UTF-8
      etc., so Vim uses UTF-8 by default there. But on Windows, typical
      locales are things like

      French_Belgium.1252
      etc., and therefore Vim doesn't use UTF-8 by default on Windows. See
      http://vim.wikia.com/wiki/Working_with_Unicode
      about how to tell Vim near the top of your vimrc that you want it to use
      UTF-8 rather than the OS locale. Similarly, if you want messages and
      menus in English rather than in the OS locale language, you would use

      if has('unix')
      lang mess C
      else
      lang mess en
      endif

      near the top of your vimrc (Windows knows nothing about the C locale,
      which is recognized on all POSIX installations).


      Best regards,
      Tony.
      --
      Go 'way! You're bothering me!

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.