Loading ...
Sorry, an error occurred while loading the content.

nosmartindent

Expand Messages
  • Lyuben Petrov
    au FileType py set autoindent au FileType py set smartindent I added these lines to my vimrc file but still when I open a python file smartindent is not set.
    Message 1 of 2 , Jul 1, 2012
    • 0 Attachment
      au FileType py set autoindent
      au FileType py set smartindent
      I added these lines to my vimrc file but still when I open a python file smartindent is not set. Autoindent though is.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Ben Fritz
      ... Probably it s because Vim detects *.py files as python filetype, not py . See the output of :set filetype? to determine the filetype of the current
      Message 2 of 2 , Jul 1, 2012
      • 0 Attachment
        On Sunday, July 1, 2012 7:19:12 AM UTC-5, Lyuben Petrov wrote:
        > au FileType py set autoindent
        > au FileType py set smartindent
        > I added these lines to my vimrc file but still when I open a python file smartindent is not set. Autoindent though is.


        Probably it's because Vim detects *.py files as "python" filetype, not "py".

        See the output of :set filetype? to determine the filetype of the current buffer.

        If it actually is "py" and not "python", check the output of :verbose set smartindent? autoindent? to see where the options were set.

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.