Loading ...
Sorry, an error occurred while loading the content.

Re: XIM Input Method for Motif Gvim

Expand Messages
  • Chris Jones
    On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote: [..] ... Regarding (3) above, I forgot to mention that there is an imdisable/noimdisable
    Message 1 of 7 , Jun 2, 2012
    • 0 Attachment
      On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote:

      [..]

      > > > 1) Why is XIM enabled by default?
      > > > 2) How do I use it?
      > > > 3) And most importantly: How do I turn if off?

      Regarding (3) above, I forgot to mention that there is an
      imdisable/noimdisable boolean option.

      But I guess you have already tried that..?

      CJ

      --
      SOMEBODY SET UP US THE BOMB

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... Best regards, Tony. -- It is Texas law that when two trains meet each other at a railroad crossing, each shall come to a full stop, and neither shall
      Message 2 of 7 , Jun 2, 2012
      • 0 Attachment
        On 03/06/12 02:51, Chris Jones wrote:
        > On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote:
        >
        > [..]
        >
        >>>> 1) Why is XIM enabled by default?
        >>>> 2) How do I use it?
        >>>> 3) And most importantly: How do I turn if off?
        >
        > Regarding (3) above, I forgot to mention that there is an
        > imdisable/noimdisable boolean option.
        >
        > But I guess you have already tried that..?
        >
        > CJ
        >

        Yes, see also:
        :help 'imdisable'
        :help 'iminsert'
        :help CTRL-^

        Best regards,
        Tony.
        --
        It is Texas law that when two trains meet each other at a railroad
        crossing, each shall come to a full stop, and neither shall proceed
        until the other has gone.

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Christian Brabandt
        Hi Tony! ... I guess, you meant :h i_CTRL-^ and thanks, that works. Bram, I suggest to put a link to these help topics below :h xim I am still wondering, why
        Message 3 of 7 , Jun 3, 2012
        • 0 Attachment
          Hi Tony!

          On So, 03 Jun 2012, Tony Mechelynck wrote:

          > On 03/06/12 02:51, Chris Jones wrote:
          > >On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote:
          > >
          > >[..]
          > >
          > >>>> 1) Why is XIM enabled by default?
          > >>>> 2) How do I use it?
          > >>>> 3) And most importantly: How do I turn if off?
          > >
          > >Regarding (3) above, I forgot to mention that there is an
          > >imdisable/noimdisable boolean option.
          > >
          > >But I guess you have already tried that..?
          >
          > Yes, see also:
          > :help 'imdisable'
          > :help 'iminsert'
          > :help CTRL-^

          I guess, you meant :h i_CTRL-^ and thanks, that works. Bram, I suggest
          to put a link to these help topics below :h xim

          I am still wondering, why the Motif GUI enables the X Input Method.
          Although IME and Multibyte feature seem to be independent of each other,
          it doesn't sound to be reasonable to enable the first, while the latter
          is completely unsupported.

          regards,
          Christian

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.